RTX 2060 and PiMax 4k


I recently built a new system which uses a GIGABYTE GeForce RTX 2060 GAMING OC PRO, it worked at first but after a driver update the system will only recognize that the PiMax USB is attached, not the HDMI. I had a similar issue with another system with a 2080 but a driver rollback to Nov 2018 seems to have fixed that, but none of the drivers on nVidia’s site are working for the 2060 - I am at a loss of what to do - I am tempted to just return the card and get one with the USB-c connection after looking all over to try and fix this I am seeing alot of people talking about future VR are talking about that port, BUT before I do that I would like to try and get this going again - same issue is happening with an Oculus - the system does not recognize a headset plugged into the HDMI (it works fine with a monitor, just not a headset).

Onboard video is disabled in bios so I am at a loss - appreciate any help.

Thanks - Tom

Side Question - I would like to get a PiMax 5k BE - wondering when those will be shipping if anyone knows.

1 Like

Your Pimax B1 due to piplay(@anon74848233 @Sean.Huang @Doman.Chen) not being updated will likely require an older Nvidia Driver to work.

Have you tried your pimax B1 on Pitool?

going to try that now and if it does not work I think I am going have to send the card back - the 4k works on the other pc’s I try it with - I read somewhere that the hdmi ports on some of these RTX cards are off unless they detect a monitor or some b.s. like that and there is no way to override that so guess what, they can take it back - they should not advertise VR ready with nonsense like that in there. This model BTW is a GIGABYTE GeForce RTX 2060 GAMING OC PRO 6G - I would not recommend getting one of these if you use VR.

Try using tge newest pitool beta 121 with latest Nvidia driver 419.67

1 Like

well gotta love that, so far so good but it’s a little finicky - should I uninstall any piplay software?

1 Like

You could keep piplay installed. But be sure to only have one or the other running as tgey are likely to interfer with one another. I believe Piplay itself will be discontinued with 1 pitool to rule er I mean run them all.

Nvidia changed somethings in their driver & why newest Nvidia driver doesn’t work on old piplay & older pitools (believe anything older than 103 or 109)

The plus being I hear contrast settings work in the p4k from my understanding.