Room Scale setup?

Pimax has to get PiTool to set and save room setups. Steam room setup is absolute crap. My main VR game is IL 2 Great Battles. The recommended room scale for IL 2 is Steam. Both Pimax and Steam say to use Steam room scaling for Steam games. Problem with that is, I have to re-do room scaling EVERY time I star a new mission or when I start the game up. I don’t see any option anywhere that allows me to save the room settings. This happens no matter the version of PiTool. Anyone here with any ideas for me? Is there something I can click on that saves my settings? Doing the room scaling over and over is driving me up the wall. All input is much appreciated. Take care all Eddie.

Öhmmm, nope… do the setting in the pitool, forget steam.

dstar. I got the room scale setup from the PiTool manual It clearly says use Steam for Steam games. I bought IL 2 from Steam so I tried Steam room setup. I also tried with just PiTool, and I get the same thing. Redo the room scale on every start up etc. I was told I have to do the room setup even if I use the 9 axis and no base stn, so I did and that works fine with PiTool AND OR Steam. Go figure. Maybe a new firmware will come along. Until something changes in Steam or PiTool, I’m flying my sim without a base station. Thanks my friend take care Eddie.

Maybe you should uninstall SteamVR and Pitool complete including the data stored in the user folder. I haven’t had to do a room setup since years. Once each during the initial setup of the 8k, 8k+ and the 8kx in the Pitool, that was it.

But warning, if you play a lot games, your pitool game settings are also in the user folder. Save it before.

Hi again dstar. I said the 9 axis held the room setup in Steam and PiTool, I was wrong. Had to reset room again when I started IL 2. The IL 2 sim is the ONLY sim I play in VR. I need the 6dof feature when I’m in combat as well as being able to lean out of the canopy when landing and taking off etc. etc., I put out a hell of a lot of money to buy the 8kx, the VKB Gunfighter 3 joystick with all it’s upgrade extensions etc and of course, the base station. I reinstalled windows 10, Steam, IL 2, Steam VR, PiTool 284. Nothing has changed dstar. I still have to re-do room set up with the base station or the 9 axis option every friggin time I start the game. While it’s clear most Pimax owners have no similar issues, I still want PiTool to allow saving the room scale. Why not? It can’t be that difficult for the PiTool people. PiTool users should be able to save every setting. In the meantime, I have no idea what to do to fix this room setting. I tried EVERYTHING! Oh well…

I don’t understand the problems. I even had my room setup 2 meters away from the sim rig. Start the game and recenter (mapped to stick) and you sit in the cockpit. Everything works. Whether DCS, FS2020, IL, Racing.

Recenter for IL - Settings > Key Mapping > Pilot head control tab > Default VR view.

Btw, VKB, best choice :+1:

@Heliosurge - Maybe it’s the language barrier, but I don’t understand his problem. My room setup is saved normally. And if necessary, there is also an in-game recenter for Sims. Any idea?

My steamvr asks reacently to redo my roomsetup again and again. When I do it, I can play, but next time it will ask again for room setup. I tried everything, as original poster here, but nothing helps. Even steamvr support didnt help me. They asked to try my hmd in another pc …
For now I start pitool, then steam, then steamvr, put my 8kx on ground, and in steamvr set really fast developer options, calibration, large space, calibrate. Then I can play. If I am not fast, steamvr close itself.

I will wipe my windows to solve it, but I am lasy for now.

I also play IL-2 a lot, but the problem is with all games.

I assume something went wrong with steamvr files deep in windows, something what I can not find and erase when uninstalling it.
Maybe because once I gave admin rights to steamvr. I do not know what else to do.

PS; I had many pc restarts in midle of gaming (mostly dcs), maybe that made problems.

PS2: in some games if I use steamvr my “head” is 2m higher then normal. It is in DCS and Falcon 4.0 BMS.

strange… have you also delete the user app data to try to solve?
c: user xxxx appdata local steamvr (the same for pitool)

Yes, but it doesn’t help. Thank you anyway.

PS: I uninstalled SteamVR and Pitool together, and then erased all leftovers, except win registry keys (I do not know how to find and erase there). Then after restart I installed pitool and steamvr again - it didn´t help…

1 Like

I solved my problem:
Sometimes I saw error message that data can not be saved to cloud… That make me go to steam, to find steamvr there, right click on it, settings, and then I disabled cloud saving and also I made steamvr integrity check.
I tried it several times, it works again.
Later I enabled again cloud saving, it works :slight_smile:


No, it does not work any more, it was ok several turning on/off, but now same problems again…

but sounds really like a steam bug.

1 Like


Original message: I solved it again, this time it works even after restart :slight_smile:

In Steam vr settings / developer options / allow storage of synchronization data - disable it!

@eddie you should try 2-3 things what I did, that might help you. Now steamvr do not ask me any more for recalibration, but I still have my other problems.

OK Brzi.Joe, I’ll try that later this afternoon. Do I disable the steam vr sync thingy before or after I do the steam room setup? What about PiTool room scaling? Do I have to do the PiTool setup? Thanks again my friend. take care Eddie.

I would advise to make proper pitool calibration once, then make my 2 steps, and steamvr calibration.
Try to have booth pitool and steamvr front direction approximately the same. It will help with some issues with i.E. Necksaver for IL-2, or OpenXR games and mods.

I tried everything you suggested Brzi.Joe, but no go. I tried the 9 axis, and it worked for a few plane changes but it wouldn’t hold the room scale either. I don’t know why room scaling is needed when in 9 axis, but I read that it was required so I did that too. Nothing works. Maybe the next PiTool will somehow fix this issue, but I won’t hold my breath. I guess for now, I fly with 9 axis etc. and wait for the new 12K. For sure That one will work just fine. Right?

1 Like

Then do without SteamVR and try OpenXR. However, you will then have to re-enter your access data in IL.

Instructions here with DCS, but works the same with IL.
Ahh and Start IL from pitool, not steam.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.