[Resolved] Permanent Red Green LED no HDMI DFU Firmware 265 EU

after disabling the PiMax 4k for a new USB HDMI Cable , the Pixmax HDMI Device was off. Original Firmware was 265.
New or old Cable is same result. no HDMI.
Flashing with PiMax DFU Tool has deleted the serialnummer. The Red and Green LED ist permanent on or with some other Version blink between Green and Red. The Off Button has no Off Function.
How can i reactivated the HDMI Device.

Please Help.

@Pimax-Support @Doman.Chen


Try the above link. Might help reset firmware. Use the new cables. With changing out the cable it sounds like the intrusion in the firmware was tripped.

The Firmware Update DFU Mode starts manuell and automatic with Updater. Firmware is 102XX.rar. Firmware update runs completly. but it is no HDMI Device in PiPlay. LED blinks permanently between Green and red. Original Firmware was 265. Has PiService the unlock Firmware for Repair my Device ? 20 tests later.

What is the first 3 serial numbers on bottom of hmd?

@Pimax-Support @Doman.Chen

SN 10281 … the Red Green LEDs blink now simultanly.

Okay cool. Support might be delayed due to weekend.

@Sjef has a few tricks in his toolbox & is likely able to help get your firmware reset.

Could we use the teamviewer which I would like to assist you remotely.And then send me the ID&password of teamviewer when you are available.

Teamviewer is installed.

Sure just pm me,pls.

Edit: @users who may need to disassemble the headsets

Notes: Please do not supply power to the headset when you disassemble the headsets. Usually we do not recommend this operation, which will break the product warranty.

If your headset encounters the issue, please do not hesitate to contact support@pimaxvr.com or post your topic in forum, we will be here :slight_smile:

Very Great Support Team !!!

ive got this issue again and now the flasher tool doesnt run , missing a bunch of dll files that i cant find anywhere. i have disabled all services and still doesnt work , any advice ?

Hey @Doman.Chen should be able to get you fixed up with a working flasher tool.

@Sjef also created a flasher tool that may still work.

To add to what Doman said if you do choose to disassemble. Unplug the headset wait 30m then press power button. This should ensure stored power is discharged. Probably don’t need 30m; 5m may do.

yeah i dont think it was the flasher tool. i think my pc had some issues as a heap of dll files were missing. i have pimax support on it remotely atm.

1 Like

Tried it many times but it do not work for me
When pust 3 buttons together and pluggin to USB, LED are white, ater 8s green and after 8s red but came back red & green flashing after a while. My headset serial number start with 100…Is there another way to reset it ? It just stuck after latest PiPlay update…Please help…Thanks!

Soinds like a failed firmware update.

@Pimax-Support @Doman.Chen

How can i correct this problem…Thanks!

Hi ,please do not hesitate to contact support@pimaxvr.com , we will be here.

1 Like