[Resolved] Multiple organ failure

Hello again,

OK, right now this feels like buying this headset was one of the worst ideas I have ever had, but I will give it a go to see if I can get any help in here before I return it to the stores and forget it ever existed.

First of all, my system:

Main board : ASUS z170-P (no onboard gfx)
CPU : Intel i5-6600K
RAM : 8 GB
OS : Windows 10, 64bit
GFX : Geforce GTX 970
Antivirus : Bitdefender Free

I should also mention that I am a VR noob, so maybe some of all this is my own fault.


Thinking that the download page would provide you with the latest version of the software, I downloaded and installed Piplay (as admin, AV turned off), I did not get the splash screen as described in the quick start guide, Piplay just opened on he screen. For further help with installng, the quickstart guide then kindly refers to www.piplayvr.com/setup … which doesn’t exist.

Opening the settings, the first thing that happens is that Piplay tells me that there is a new version of it and needs an update to v. (How about putting that version on the download site?) An update that it takes me 6 or 7 attempts to download before it finally works, as the grindingly slow download keeps crashing and makes Piplay shut down.

After connecting the headset, Piplay seems to recognise it, (blue light) but now the fun starts.

  • The settings claim that I have V1.0.0.248 and need to update. Clicking update downloads version version v1.0.0.265 and installs it (?) but when I have clicked “confirm”, it still says that my installed version is V1.0.0.248 and that I need to update. Again, and again…

  • Magnetic calibration does absolutely nothing. It shows me a picture (on the monitor) and tells me to tilt and turn the headset, but no matter how I wave it around, the calibration never ends.

  • I downloaded the three different free items to try the headset. 2D movie (Jurassic park) seems to work but in the 360 movie (The dream collector), my left eye shows a warped image of a road whereas the right eye is looking upwards towards some hanging road signs. In the game (Showtime) , my eyes are at least looking at the same direction, but all I see is the Unreal logo at the bottom of a lake with a frame rate of about one frame every 2-3 seconds, paired with a short audio burst.

  • Even though I am getting images, Windows does not detect the headset as a second screen. My monitor is connected to the DVI and the headset to the HDMI outputs of the graphics card. Only the monitor is shown under Advanced Display Settings. If I connect a second monitor to the HDMI instead of the headset, it works, so there is nothing wrong with the output.

Any ideas of how to fix this, or do I have a faulty headset and need to have it replaced?

1 Like

Okay your motherboard does actually have Onboard graphics. Your i5-6600k haa a graphics built in. Your motherboard shown below has hdmi & Dvi outputs.

You will need to go into your bios settings & disable onboard graphics.

This link should help better.

Putting @Community & @Pimax-Support will make your support posts quicker to find.

1 Like

Hi and thank you for your reply.

Yes, of course there is an onboard gpu, I should have realised since there are outputs on the back. Problem is that there is nothing said about it in the manual and the settings were buried deep down in a crazy menu system in Bios as seen here. The setting that should be deactivated, here called “Multi monitor”, was already disabled on my computer. “Primary monitor” was set to Auto so I set it to PCIE, but it didn’t change anything.

Also, if the wrong GPU were active, I probably shouldn’t get any image at all on the headset, so that doesn’t seem to be the problem. There is also no extra device (i.e. no onboard GPU) listed under “Display Adapters” in the Device Manager, only the GTX 970.

I was also wrong about Pimax not showing up in the Advanced Display Settings, I didn’t know it only showed up in Vido Mode and not in Pimax Mode.

So, as far as I understand, the hardware should be installed and working and the problem seems to be the software.

So the questions remain:

  • Where on earth do I download previous versions of the Pimax drivers? I have looked everywhere and can’t find them.

  • Should I still be getting the greenish splash screen for PiPlay? (I’m not)

  • Why does the gyroscope calibration never end?

Thanks again for your help!


@Community @Pimax-Support

1 Like

Try reinstalling the current drivers/Piplay updates with your antivirus/firewall/spyware apps disabled. What do you think @Heliosurge?

1 Like

I had the AV disabled when installing all versions of Piplay so far, so that shouldn’t be an issue but I may have had it enabled when I plugged in the headset and the drivers were installed. I also can’t find it in the device manager so I don’t know how to uninstall the present driver so I can reinstall it.

1 Like

Let’s approach this in sequence as per your questions

  1. @Heliosurge is right the on board GPU must be disabled, whether it detects it or not, pimax will check minimal specs and will see the on board GPU and not work as required due to not hitting minimal specs - you will have unpredictable results. It is recommended to disable in device manger and disable in bios.

  2. The version downloads, you basically install the latest stable version and then there may be a patch on that version to bring it to the latest sub version. The same happens with windows… You get the version… I.e. Installing Win10, then get its patches. Same thing works here.

  3. You mentioned the version 248 going to 265. This sounds like the link has done the download, but has not installed, I found a similar issue when testing the latest drivers and found the downloaded installer behind the main piplay splash screen waiting to be installed, try minimizing the splash screen and then running the installer.

  4. There are a few calibration options in that version. The magnetic one is there in case the hmd has a rotational drift. It’s best to rotate it like a large figure 8 as well as rotations all the way forward and back 180deg and tuning 180 as if it was on your head but do it in your hands to you can turn more

  5. The horizontal calibration is if the headset is tilted to the horizontal plain as if you have a few degrees tilt when looking forward.

  6. I read you worked out why the pimax display is not showing, but for clarification the display appears when in video mode and is not displayed when in pimax mode.
    Basically video mode is for movies 180/360 etc, and Pimax mode is for games.
    If you are using video mode mainly you need to use a video player that is vr compatible, there are many out there, but if you don’t use one then the displays will be messed up! Different visuals in each eye etc. Ask and one of the helpful people here will recommend good vr movie players and you will get some good ones to try, I even saw a thread about them somewhere here!

  7. If you want to see what it’s like, download Unity Chan for a pretty good demo, to see if the hmd performs as you want… If it does then we can help you set it up properly and if not you can send it back for a refund.

Good luck



Do you see anything in device manager that is listed as an unknown device? You said that the HMD was recognized when in movie mode?

Try putting it in that mode and then removing, or check for unknown devices.

Better yet, listen to @Enopho

1 Like

The Banner has this link for 2.0.7 piplay here is the link for convenience.

Also with uninstalling piplay. Be sure to uninstall Klite codec pack. Let piplay install Klite as if you have a different install of it some users have reported issues.

With that as per The Getting Started Guide. Disconnect from the internet so your system is safe.

Myself I mainly use my windows install for games & only use Windows Defence pog (ie Windows Defender)

I haven’t had to disable it for installs.

Summon Windows Taskmanger & kill pi servers & piplay. Run the uninstaller.

Also good to kill the above processes before installing new versions. Though i have found the installer seems to do this for you. But still a good idea to do if having problems.

1 Like


  1. Piplay download link: http://piplay-us.pimaxvr.com/PiPlay_Setup_3.0.0.85.exe

  2. for firmware, you could refresh 265, here is the introduction:


Installation Guide:

a、Copy dfu.exe to \Pimax\PiPlay2 (or right click Piplay icon by mouse,choose “Open the location of the file”, will locate to the right folder )
b、After coping, double click dfu.exe to start.
c、Click “select file” to choose the firmware which you want to refresh.
d、Plugin USB cable, and also confirm LED is on.
e、Click download firmware to start refresh.
f、During the process, the LED on HMD will flicker. Before finshed, please do not disconnect USB connection until the upgrade finish tip is displayed in the tool.

if Piplay connection is not ready, you could enter DFU mode to refresh the firmware. http://pisetup.pimaxvr.com/DFU_CMD.zip

how to enter DFU mode?

a. When the device is turned off, press the power button + volume plus+ volume reduction at the same time.

b. Insert USB cable to PC, LED light will be white, after 6-7 seconds to release the power key, LED will be green, and then continue to release second volume reduction, LED will be flickered, that means the device enter the DFU mode.

how to refresh the firmware?

a. Exit Piplay app and stop the PiserviceLauncher service in windows task manager service.
b, enter DFU mode
c. command line is DfuSeCommand.exe 0 file name like DfuSeCommand.exe 0 c:\123.dfu
dress windows key+R to enter CMD, drag the DfuSeCommand.exe into the command window, then input 0, drag the firmware directly to the windows, press “Enter” key, upgrade will be conducted and finished.

  1. Watching video:
    you could play 2D/3D movie in video mode by importing movie clip to piplay library.
    you could play 2D/3D also 180&360 degree movie in pimax mode by importing movie clip to piplay library

    you also could download simplevr player(https://store.steampowered.com/app/500500/Simple_VR_Video_Player/) or other video player to play almost all kinds of video clips on steam store.

  2. For calibrations, please follow up what Enopho have told you. Thank for @Enopho help.

If you have other issue, please share with me again!


Thank you everyone for your help.

I have tried some of the things that were new and will get back to some of them but first if all, I decided to install Piplay on my laptop as well to see if it made any difference. It’s a Lenovo Yoga 520 with a Geforce 940MX, so it is below specs and it is NOT possible to deactivate the onboard GPU since it is a necessary feature for converting the laptop to a tablet. (You can deactivate the Geforce though, but that doesn’t really help.) I decided to try anyway.

Basically the result was the same on the 360 video. Eyes are looking in different directions and it’s a general mess. The game however was much better. I was able to start it (unless I missed something, it’s actually just a game gfx demo as you can’t actually do anything apart from looking around you) and though it is obviously on a too low framerate (it also seems to play in slow motion, but I think that is the way it is supposed to be) at least it worked.

This makes me think/hope that the 360 movie is messed up but the HMD works, so let’s get back to my gaming computer.

I have reinstalled Pimax several times by now, always as admin with the AV off and after deinstalling Piplay, Dr.Pi and the Klite Codec Pack. Last time I even deleted the Pimax folder and deleted every single registry entry containing Pimax or Piplay. None of this has helped, so I don’t think this is the problem.

I have deactivated the onboard graphics to the best of my knowledge and it is not visible in the Device Manager. Last time I even activated it in BIOS, then deactivated it in the Device Manager before deactivating it in BIOS again. Also, Dr.Pi detects the Geforce card as GPU and nothing else and checks the specs as OK for 4K. If this is still the problem, I don’t know what to do. The only thing I can think of is to update the BIOS which I may try later on.

@Enopho : “If you want to see what it’s like, download Unity Chan for a pretty good demo”

  • Where? The only things available on Piplay are the three items I have already tried and on Steam I can only find “Attack of the Giant Zombie vs. Unity Chan”, but not for free.

@Heliosurge, thanks. I’ll try the 2.0.7 later. (downloading but have to go to work)

@Sean.Huang, thanks. I managed to update the firmware with your help, but unfortunately with no change.

What I am still thinking about are the drivers. Not the Firmware or Piplay, but there must be some kind of drivers installed for the USB connection and possibly HDMI. Any clues? I have deinstalled both the Audio and Video component in the Device Manager, but when I reconnect the HMD, it’s back up again. Obviously deinstalling the devices doesn’t delete the drivers.



OK, this is possibly where I need to apologize.

I downgraded Pimax to 2.0.7 but nothing changed until I did something I probably should have done already the first time I tried the software.

When I happened to open the device settings, I decided to try out the 19201080 resolution setting and realised that the game seemed to be running a bit faster. I then realised that the image quality in PiPlay were set to max. (3.0) Obviously, my system is not a high end one and I can’t remember setting this to max myself, but once I set the resolution to 19201080 and the image quality to 1.5, the “game” worked and looked great. Still a bit focal problems and some vertical lines when I watched the sky (or the brief white full image before the game started) but at least it seems there is no real problem with drivers or any of the other things I have gone on about, it simply seems like I have overcharged my system.

I reinstalled Piplay and everything still worked just as well. Funnily enough, the settings were transported from the deinstalled Piplay to the new one.

The 360 movie is however still a mess. If this is what it looks like to everyone, it needs to be taken down. It was the one thing that made me think my HMD was faulty.

Does these settings sound normal to you, given my specs?

At least now I can start testing the HMD with some more games/movies (any suggestions are most welcome).

Thanks again for all your help!


@Sean.Huang @Enopho @Sean.Huang @VRGIMP27

1 Like

good to hear you’re getting there!

ok lets talk about Video mode.

when watching any videos on the pimax, you need to use a vr video player. @Sean.Huang mentioned one in his post above, but there are many out there. Personally i use Kodi in VR mode, but i mainly use my pimax for games. If the video player your using is not set to a vr mode them each eye will be displaying incorrectly. Here is a link to download simple vr player. https://simple-vr-video-player.en.softonic.com/ you need to load your videos into that and watch them on the pimax for it to display properly - dont just load a video into whatever your fav video player is and expect it to play in vr… if the player is not designed for vr, then the headset will not show it in vr!

Lets talk about games
if you are playing steamvr games, you need to run through the steamvr room setup. then in the settings page ensure that the applications slider is set to 1.0
in piplay set your render quality slider to 1.0 - and then try as game, some vr games are more resource hungry than others and as your gpu is minimal set the starting point low, and change the render slider if you are not getting stutter/lag/latency or missed frames.

to launch a steamvr game, these are the steps.

  1. make sure hmd has a blue led on the top of it.
  2. launch steamvr
  3. in steamvr, click the drop down menu and choose Display Mirror
  4. click into the Display Mirror windows, (make sure HMD is facing forward), then press Z key to have HMD lock the forward position.
  5. in your Steam Library, click PLAY on one of your VR games

Thats it

there are lots of vr titles to choose from, some being demos so you can try them out, have a look in the pimax category VR Content. maybe try this thread for some ideas. Free VR Content



wow did not know that there is a free non-steam version of simpleplayer. It has the best picture quality of all players I tested. Just make sure to have the latest LAV installed and activated for 5k/6k footage. Otherwise you will be running into issues or even end up not seeing any picture at all. If you do not mind having less picture quality (not bad though) and want a free player that works right out of the box without any hustle go for DEO. (I recommend choosing directshow inside the players options though to increase the picture quality a bit) Probably the better choice at least in the beginning to check whether video is working.