[Resolved]Extended mode only?

I’ve received the Pimax VR 4K, great hardware!
The fact I wouldn’t have to upgrade my laptop right away was a deciding factor over other systems.

My problem now, appears to be that my Geforce GTX 960M hybrid with Intel HD Graphics 4600 isn’t detected by PiPlay?

It always switches over to “Extended mode” with a message telling me I should reconfigure or get a NVidia graphic card. I’ve updated drivers, gone through the control panel with “global 3D settings” and what have you.

So far, I only could watch video’s but none of the OVR_Launcher_x64.exe applications work. I’d love to try other things as the videos… Thanks for any insight!

Could you post your laptop specs? Model & such.

Not sure on laptop but on desktop the onboard graphics ie your intel may need to be disabled.

This is a MSI GE62-2QD-Apache, I’ll list the specs below.0
It has this hybrid kindof graphic card:

The HDMI port with the pimax becomes listed under the Intel Graphics while using the Nvidia engine in this screen:

15.6-inch (1920 x 1080) 141 ppi IPS matt anti-glare display
Windows 8.1 (upgraded to 10 by now)
2.6 GHz Intel Core i7-4720HQ (3.6 GHz Turbo) 4C, 8T
Nvidia GeForce GTX 960M (2 GB GDDR5) + Intel HD Graphics 4600
8 GB (1x 8 GB) 1600 MHz DDR3 RAM
128 GB M.2 SATA SSD + 1 TB 7200 rpm SATA HDD
gigabit ethernet
802.11ac, 1x1 MIMO (Intel Dual Band Wireless-AC 3160)
Bluetooth 4.0
tray-load DVD±RW drive
3x USB 3.0, 1x USB 2.0
Mini DisplayPort 1.2, HDMI 1.4
Kensington Lock Slot
SDXC card slot
stereo speakers (Dynaudio)
webcam and mic
3.5mm headphone, 3.5mm mic jack
UK tiled keyboard with numberpad (Steel Series ENGIN3)
two-button multi-touch trackpad, 103x61mm
50Wh lithium-ion, non-removable battery
120 W mains charger with IEC C5 inlet
387x258x27.8mm
2355g

Hmm. I know vr hmd sometimes don’t like Dp2hdmi adapter. If you have one around… It might force extend mode… Maybe

Hmm thanks, I’ll give that a shot… Now I’m using the HDMI port and not an adapter, but maybe using an adapter on the display port might route things a bit different.

I’ll keep update once I have gotten round trying this.

@tivl82 Hi, which Piplay version you installed? The latest Piplay 1.2.97 may auto detect PC config and switch to a lite Piplay if PC can not meet the minimum requirement (GTX960 / AMD R9 290) or has a Intel graphics.

“Extend mode” you referred that is “Video mode” that only used for watching regular 2D / 3D videos. You still can manually switch to complete Piplay version in Piplay setting and then you will see “Video mode” and “Pimax mode”. Pimax mode can be used for 180 / 360 degree panoramic videos and VR games.

Meanwhile, please right-click the desktop and choose NVIDIA control panel -->NVIDIA control panel -->Manage 3D settings–>Global Settings -->change “Auto-select” to “High-performance NVIDIA processor”. Finally restart the computer to effect.

If it is useless, please download a driver from Download The Latest Official GeForce Drivers and then install it manually same as below:

not working for me. 1080ti is not working

I’ve downloaded the last version of PiPlay that was posted on the website (the “other download” version). And updated my NVidia drivers. This evening I will try to follow all the suggestions.

  • Hook the Pimax on the displayport (I have an adapter laying around)
  • Fresh install NVidia drivers
  • Try the settings as described above

Turns out, my work laptop is an Asus with the same “hybrid Geforce MX 960” with the exception the Asus allows me to select the Nvidia as main graphic chip in the bios. The MSI gaming laptop I have tried yesterday, does not allow this setting.This will be a good way to compare settings and get at least one working:

  • Test the Asus laptop with bios setting “only nvidia”
  • Test the asus laptop with bios setting “Intel graphic chip” and change Nvidia software settings

I’ll update this thread with the results from both laptops in a few hours.

  • Changing to display port doesn’t make a difference
  • Updated the NVidia drivers & installed piplay again, no difference
  • The performance settings for Nvidia and reboot didn’t change anything either
  • Reinstalled java completley too but this didn’t help anything either

The pimax shows the logo and flashes between my desktop background and stays there. Then when I start any pimax game there is a black window but there is nothing happening. The Pimax shows the logo but nothing is going on. While my mouse and desktop lose focus. (I need to alt+tab out of it)

The same is going on with the other laptop the bios “setting” was just informative and never changed anything.

So for now I’m stuck with only video’s it seems and hoping a driver or update will solve this?

This issue is related to http://community.openmr.ai/t/resolved-cant-get-into-steamvr-on-laptop-please-help/2704/14