[Resolved]Can't get my (new) P4K working

Hi guys,

Installed the P4K software on my PC but i didn’t get the HDMI connection to work.
Piplay reports USB Connected but HDMI Disconnected. (green led)

Tried the newest AMD drivers on my RX480.
I am stuck. Is my P4K unit defect or is this a software/driver issue?

Need help !!!

@Pimax-Support @Doman.Chen

1 Like

Added some pokes to your message.

With your install; have you tried installing offline with running installer as admin?

Exit Piplay

Also launch the taskmanager & kill any instances of pi server.

When offline (not connected) to internet disable the antivirus.

Then launch installer as admin.

Once install finished. Re enable antivirus & then you can safely reconnect to internet.

Run Piplay & see if it works.

Alternatively you can leave Antivirus on & Run as Admin.

1 Like

Have you both plugged the HDMI cable of the helmet and the cable of monitor to PC discrete graphics ports?
You may access control panel to uninstall AMD related procedures and restart the computer ,then it is recommended to manually upgrade the AMD driver on its official website.

I’ve been getting this issue a lot lately. What I do is (1) close out of all Pimax/vr applications, then (2) open task manager and end the three pimax/piservice tasks. Then (3) Unplug pimax headset, (4) start piplay, (5) replug pimax headset hdmi then usb.

Okay Helio,
Thx for the remarks;

Did the following steps:

  • Removed Piplay/Piserver,
  • Reinstalled Piplay as Admin, Off-line, Viruschecker disabled.
  • Plugged-in HMD.
    Same result:
  • In Piplay: HDMI disconnected
  • USB connected (recognized as Rift P1)

The “Display Adaptor” screen shows “No other monitor detected”

Thx CryCoh for your comment.

Tried your advise:

  • Killed the 3 pimax related apps
  • Started piplay.
  • After connecting HDMI - piplay still reported no HDMI connection
  • After connecting USB - piplay acknowlged the USB connection.

Hi Pimax Supporters,

Made some promising progress,

  • Removed all the AMD-software.
  • Started Piplay
  • Got HDMI connected for the first time !! :slight_smile:

But I don’t see content displayed, not yet.

So looks like the unit is not defect…

Now trying to install the AMD-drivers step by step and analyse progress.

I’ll keep you posted.

Hi Guys,

Got my P4K working finally!
After more than 2 hours immersive one of a kind installation :wink:

I had to downgrade the AMD driver of my RX480 from Adrenalin Edition 17.12.2 to

Seems that the latest driver did break the support of the P4K.

It did at least in my setup.

Thanks for your support!

Now going to explore the possibilities …


Awesome news! Thanks for sharing new amd driver not working.

Great!Thank you for following up.We will note that for further estimate.Have a nice day!

1 Like