[Replied]Pixel noise an flashing in new 8K (SUPEN-885)

UPDATE: It’s the cable! Using my 5K’s cable resolved the issue. Seems like cable quality is another new factor to consider.

I’ve just received my loaner 8K today and after the usual game of service restarts, folder deletion to get it tracking, I noticed a serious problem with the panels:

There is random pixel noise all over the screen, with the screen flashing every couple of seconds. I tried the following without success:

  • using another Displayport
  • using another USB port
  • rebooting
  • flashing older firmware (Pitool keeps updating it automatically)
  • rebooting the HMD
  • rebooting the PC
  • pushing in the cable

The headset is tracking (I can see the mirror view fine), and appears to be otherwise working. I’m using the same power adaptor as my 5K+, so that’s not the problem.

It looks very similar to this issue:

@anon74848233, @Pimax-Support, @PimaxVR - please advise.

I also created the following support ticket:

EDIT: Here’s a screenshot from the video showing the flash:


These various reports make me wonder what experience to expect from the 10m cable I ordered extra… :7


This made me wonder about the quality control Pimax is doing before shipping these units. I mean this is so obvious - turn it on and you see it.

There was a similar case reported before. I cannot remember solution, but I think it was either a powered USB hub or a replaced video cable. Have you tried other USB (not video) connectors?


Who says they’re testing the headsets with the included cable and/or power supply?

They might very well have a test bed where cables are attached.

So if this is just an issue with the cables, they won’t see it.

Cables should be tested by measuring the resistance through them while bending them etc I guess, but that might not be done by Pimax as they’re most likely not producing the cables themselves.

I guess the same goes for the power supplies… :slight_smile:

1 Like

I did try another USB port.

Not sure how to replace the video cable though, seems to be glued in to the headset. Plus it’s an all-in-one cable. This might be faulty but I can’t diagnose or fix it in any way.

1 Like

Well, the most common sense QA check would be on the final unit: plug it into a PC with Pitool already installed, check image in headset, check tracking.

It is detachable. It’s just tugged in there behind the plastic piece that You attach the foam onto.

That piece comes off too (clicks in place).

SweViver showed it in one of his videos, but I can’t remember which :slight_smile:


You would normaly use some kind of test bed and run a suite of tests by the press of a button, but who knows what Pimax does? :slightly_smiling_face:

Maybe they just “eye it” :smiley:

1 Like

That was a great tip! I managed to pull out the 8K’s cable and plug in the 5K cable instead - the screen now works flawlessly.
Also the 8k cable refused to work in 2 out of 3 of my Displayports (and was noisy in the working one), whereas the 5K cable works in any Displayport right away…

So we have a winner here: it’s a defective cable. I’ll update my support ticket - hopefully Pimax can ship me a replacement cable only.


Indeed Psu & cables should be tested by the supplier otherwise it will take even longer to complete testing. These kind of issues usually result in supplier paying for extra folks to come to test & sort.


Here is the pictures and video of SUPEN-885.I will contact you latter

1 Like

We have received your question and alan replied you yesterday.
Please check your service desk

1 Like

Hi Dallas,
yes, he asked if I could make a video or a photo about the problem. Which is disappointing as I included them in the ticket.
Anyway, I replied with the same youtube video.
Can you please confirm with him he got it this time?


I have the same problem. but I do not have another cable :disappointed_relieved:


of course i will tell him face to face


Any updates? I guess a logical next step would be to send a replacement cable. Can I count on that happening? Without that, the 8K is unusable.

A lot of people have been asking me to do a comparison with my 5K (based on my previous review), but I can’t do that unless I have both units working (I’m not willing to plug-unplug the one working cable between the two HMDs, as it will likely damage that also, plus it’d be a very tedious process).


@anon74848233, @Matthew.Xu I’d like to escalate this case.
I’ve reported the defective cable 8 days ago, doing all the troubleshooting myself, reporting the root cause and the solution.

Since then, the only thing that happened was I got asked to take pictures (which I did as part of reporting the issue), and to try replugging the cable (which I also mentioned here and in the ticket).
It’s disappointing to see that the engineers don’t even read the problem report carefully and that a replacement cable was not shipped express immediately. The whole HMD is unusable and has been gathering dust since.

Please ship a replacement cable ASAP.

Thank you.


I got a replacement cable AND a replacement headset, both have the same problem.
I have returned all headsets and cables today…

Well, f*ck, that doesn’t sound too good. Could this be a major component issue?