[Replied]Connection problems and a display error on my Pimax 5K+

A few days ago I finally received my backed Pimax 5K+ and I finally found some time to test it. My results are not very good and I wonder if I need to replace it.
I’m running the Pimax with an i7-8700K and a Nvidia RTX 2080Ti with the latest drivers.

  • First thing after setting it up was the Firmware update that started automatically immediately after starting Pitool: the progress bar went fully from left to right and stayed there when it should be completed. I waited for about half an hour until I closed the program (without any errors) but the LED on top of the HMD stayed blinking red/green/purple.

A look at the forums showed that I am not alone with this problem and Sweviver luckily had some video showing how to fix this by reflashing the firmware manually.

  • Now the HMD LED was red and Pitool showed the error 10500. A system restart didn’t help, after changing the Display Port on my GPU like someone suggested, I got the error 10600. After a restart of the Piservice, the HMD LED finally got green - but the displays were still black. Pitool now said everything is fine and I could even see that tracking works in the SteamVR display mirror, but only black displays in the HMD.

At this point I almost gave up but I tried replugging the Display Port once again and now it finally worked… (After this I tried to completely unplug the cable from the HMD and to reseat it but it didn’t change the behaviour)

  • The experience was fine and I liked it but I suddenly recognized that I had some purple pixels showing up only on the right eye and only where a specific blue/grey color should be. The first time I recognized it was by looking at the sky while it rained in SkyrimVR, after that I recognized it in other applications too.

I was hoping it’s gone after a restart but it stayed. In addition, I always have to replug the Display Port after I started Pitool and turned the HMD on, otherwise I always get the error 10500 or 10600 (it alternates).

I tried to create a support account but it doesn’t let me log in, even after trying it the next day and resetting the password - it just tells me the credentials are wrong.

What can I do now? Is this something future versions of Pitool and the firmware will fix, is the cable faulty or is the HMD broken? Does anyone have similar experiences?

3 Likes

Have you checked the Table of Content Wiki in Pitool Downloads in Banner topic?

Pixel flashing issue @anon74848233 @Doman.Chen should be able to help. (Add to earlybackers)

Supportbis working on fixing support site & will hopefully have it resolved soon.

Are you a backer or pre order?

I’m a Kickstarter backer that changed his pledge from 8k to 5k+.
I don’t think it’s the same “pixel noise” that others are reporting since it’s a discoloration of a specific color and it’s also no stuck pixels.
It even appears only on the right eye and only at the bottom half of the display.

1 Like

With luck can maybe fix through software.

Still the same issues even after trying the headset on a different PC. The support account also still doesn’t work.

I have sent an email to support@pimaxvr.com in hope of a response.

@Doman.Chen

1 Like

Please PM me when you are available,thanks.

1 Like