[Replied]5k+ bricked after update. Flashing hmd does nothing Please HELP!

after upgrading to pitool 109 the hmd is not recognised by computer. 10500 error on pimax. for 2 full days i have searched and tried to flash the hmd but it does nothing. i always get the " last usb devise you connected malfunctioned" notice. i have tried using Swevivers method of flashing and Sjefdeklerk’s Pimax Flasher. both say successful flash, the flasher tool says wait! rebooting, but never does. ALL Pitool services are stopped via task manager before flashing. i have tried switching usb ports. i am supposed to flash ONLY the p2.dfu that comes with the pitool download right??? i had 3 days off from work and meant to spend it in vr but have spent my time instead trying to fix this. so frustrated!
NVIDIA driver

i just managed mine a diffrent way as none of the others worked

Go to Management console -> Device Manager
Uninstall the driver for the device “DFU in FS mode”. When asked if you want to remove the driver files say yes

delete the stm_dfu_3040_64.exe from C:\Program Files\Pimax\Runtime\dfudriver

deleted all pimax folders plus the STMicroelectonics folder via remove programe

then install /download https://www.st.com/en/development-tools/stsw-stm32080.html
run apllication ,dpinst_amd64 , from DfuSe v3.0.6 > Bin > Driver > Win10

Had to reinstall pitool after this before update would complete

it worked for me it may work for you


i have no Device DFU in FS mode or any Pimax in Device manager. it apears as a Unknown usb device {device descriptor request Failed} I searched in every catagory

i am missing some thing here. there is no STMicroelectonics folder on my pc. also

why do this if i am supposed to delete all pimax folders anyway? i am assuming delete pimax files = uninstalling app via settings>Apps>pimax>uninstall. or just delete files in c: drive>programs>pimax?

if you downloaded the package “en.stsw-stm32080.zip” with "DfuSe v3.0.6.exe " and installed it, in the folder it was installed to you will find the driver for the unknown device (dfu mode driver)
in theory:
C:\Program Files\STMicroelectronics\Software\DfuSe v3.0.6\Bin\Driver\Win10\

im sorry i dont know what to suggest if there is no usb in dfu ?maybe you dont have the relavent dfu files

Sorry i dont know what that is ,cant be of any help

  1. The new PiTool is supposed to unconditionally reflash the firmware. Did it happen? Or did it failed?
  2. Why did you want to reflash the firmware afterwards?
  3. When you were flashing the headset, was it in DFU mode? If not, how did you put in DFU?
  4. What is the current state of the headset? Does it have a LED lit when you power it on, if yes, which color?
  5. Have you tried to completely power off/on the headset (disconnecting all the cables)?
  6. What does Windows report when you connect the USB cable? Can you check the Windows event log?
  7. Can you run usbdeview (View any installed/connected USB device on your system) and see what it says about the connected Pimax.
1 Like
  1. first time i ran 109 it flashed automatically. that is when it messed up. i could see Windows background through the lenses for a few seconds

  2. because it does not work at all after initial upgrade to pitool 109. hmd is not recognized. pc says last usb malfunctioned.

  3. yes. i have to hold 3 buttons down, plug in power release buttons in order. made sure lights were flashing multi colors. using flasher tool does not put into DFU mode automatically

  4. light stays on red

  5. pushing power button does nothing, yes cables removed from pc, not hmd

  6. i can open windows event log but i have 0 idea how to use it

  7. ran it. says "Unknown usb device {Device descriptor Request Failed} under Driver InfSection tab it says “BADDEVICE.Dev.NT”


Here to help please

please PM me with details,thanks

Off to work now… But most info already in this thread. I will pm this evening

Better next time hit reply to my post or quote me, so I get notified you replied.

So to sum up, if I understand correctly what happened:

  1. You installed PiTool 109, it run firmware update and the update finished (without an error?), but after that the Windows started to report “Unknow USB device” error. The device did not end up in DFU mode (LED color flashing) after the update.
  2. You decided to reflash the firmware, put the device into DFU mode manually, it was correctly recognized as “Device in DFU mode”, you run the DFU updater tool and successfully reflashed the device again (with the same firmware as PiTool had done already).
  3. After exiting DFU mode the Windows again started to report “Unknown USB Device” as it was happening after the first PiTool refresh.


  1. During installation, pc started making USB plug/unplug sound rapidly, after it was finished it showed Windows home screen in hmd like it being treated as a 3rd pc screen.

  2. I first used Sweviver method using cmd in start win. So yes I had it in DFU mode because led light was flashing multi color. I used file that came with the Pitool as per video instructions.

  3. Yes, within 10 seconds of it saying “successfull”, pc says “last usb device malfunction”.

This video. Start at 11:50.

When I tried using flasher tool, I still have to manually put it into DFU mode. The DFU button does not work. Says pimax not found

1 Like

If you by “installation” mean also the firmware update then USB plug/unplug sound is correct as for the flashing the headset needs to change the USB device from one (Pimax headset) to another (ST Device in DFU mode) and back again.

Having the headset working as the regular display however is not correct.

Ok. In this case your first firmware update did not finish correctly (as the headset was left in DFU mode). @SweViver method looks as good as any other, so I would not worry there.
BTW: Which version of the firmware you flashed to the headset? The new one which came with the new PiTool version, or the old one which you have there before?

First thing I would try is to uninstall the drivers for the USB devices, which are currently reported as “Unknown USB Device” and let the Windows reinstall them.

If it does not help, I would suggest uninstalling PiTool and then removing the drivers by choosing remove driver files when uninstalling the devices from the management console. Then reinstalling PiTool (and the drivers) again.

1 Like

I have flashed a dozen times now trying different Pitool versions and using the p2.dfu file that comes with whatever Pitool version i am using. I will follow your advice from last post as soon as i get a chance.

THANK YOU SO MUCH for your time and input! It is GREATLY appreciated!!!

1 Like

Nothing worked… Hoping pimax support can help