Received hand tracking modules

A few days ago i received the two hand tracking modules i ordered already via kickstarter.
After a few weeks without VR (was busy with more important things…), today i had time to try them out.

Aaannndd…taaataaatatatataaaaa: Pimax at its best! (beware: ironic)

But, from the beginning:
I received my second 8kX a few weeks ago, and it sat in the box (was busy, as i said). But after a first peek inside the box i realised that Pimax sent two thin pads with it but the second thick pad (which came with the first 8kX) is still missing…support ticked issued.

today i tried the second 8kX and good, it has the metal (correct) hinges - good.
Then i installed the first hand motion module - nothing happened. usb seems to not detect it.
Tried the second module - same. hmm…
swapped to the first 8kX, installed the hand module: bing, usb detected it. was working in pimax experience. Checked the second module - working, too.

So it seams as if the second 8kx´s usb port is somehow not working. So i compared the 8kX firmware reported by pitools: New 8kX: V2.1.255.292, Old: V2.1.255.290. So maybe a firmware problem?

does any of you have the same problem?

Did i miss a firmware update of the 8kX?

Another thing: when dialing in the ipd (69.5) in my second 8kX i realised that the picture was very blurry. so i closed my right eye and moved the hmd horizontally left and my left eye was sharp. So i had to dial in around 65-62mm to have both eyes sharp like with my correct setting on the first 8kX.

Man, Pimax is a total mess! IPD is completely different from hmd to hmd - i think its a production tolerence issue with the mounting of the panels. What else could it be?

Will issue another support ticket for the not working usb on my second 8kX. Wasting another precious time of my life…grrr…

Bought the Quest 2 today and was dissapointed by the sde. i can see it way more clearly than on my 8kXes. And my big IPD is not perfect for the few ipd settings coming with the quest 2. But still it is a nice experience. Honestly the picture of the 8kX is far superior - despite all the hassle with pimax.


The only firmware update I’m aware of is this one:

Newer than both of Yours… :wink:


THANKS! It works now on the second 8kX!


Good to hear from someone that can try two of them at the same time so they can tell things like differences in IPD as you have already that narrows down the problem to production tolerances - any other differences; mura for example?

Just being nosey but can I just ask why you got two 8KXs?

1 Like

for my son and myself


I can confirm my 8kx came with a hand tracking module and also was DOA on the bottom USB C port so this could be firmware related then. I recently flashed it to the newest beta (highly dodgy do not recommend, was told to not have dp connected, nothing was happening with the 2x usb, connected dp and headset initialised and previously clicked firmware started deploying, did not correlate to the state of the dfu tools progress etc. Luckily it worked but id be worried about bricking it when the tool behaves like that).

I will double check if the hand tracking works with the new firmware and let you know if its worth risking an upgrade…


i left it connected (both usb and dp) and simply started the dfu.exe in the pitools folder as admin. then selected the fw and pressed upload (the only other button). The state of progress was almost correct. did halt a few seconds on 98% and then hmd rebooted. after i checked the hmd i closed the dfu.exe.

i flashed the .294. which one did you flash?

So what are your thoughts on the hand tracking? Is it worth it? Responsive? Accurate? Any latency? Etc?

hmm, did try it just for a coupe of minutes. i had to deinstall because i need the usb for the eye-tracking…thank you pimax.

Well, tracking was good. but not as smooth as with the quest 1/2. you can see that it runs with lower refresh rate. immersion was still very good. When i pinched my thumb and my pointing finger (gesture to select on quest) the index finger was partly in my thumb. But, as i said, just a short try…


Is the handtracking only working in PE or also in SteamVR? If it’s the latter it would allow me to finally use SteamVR without controllers.

PE only… :lying_face:

EDIT: What is it You want to do in SteamVR? PE takes care of launching and settings and You can just leave SteamVR Supersampling at 100% for example. Only issue I have is I can’t stop SteamVR after exiting a game and thus can’t return to PE without either using a keyboard or a VR controller.

That is exactly my issue. I cannot leave SteamVR without a controller.

As I’m pretty much only using the 8KX for racing AC via CM, I have fallen back to using VD which allows for a setting to automatically bring VD back up when exiting AC.

It just means that the whole concept of using PE as a launching pad without the need for desktop use doesn’t work for my specific use case, and for others, it only works if the have a controller or keyboard at hand.

BTW, how do you exit SteamVR via keyboard?

1 Like

It’s usually in the foreground so I just Alt-F4… :wink:

I guess You could use VoiceAttack like @mirage335 and a “kill SteamVR” command… :wink:


Right, will give both a shot.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.