Received 5K+ but cannot make it work properly. Any help?

Hi all,

so i’ve received the 5K+ yesterday and i tried to set it up but i am facing some issues.

Issue #1
I cannot seem to be able to calibrate it correctly. So i went through all the calibrations steps and somehow when i launch a game I am at the ground level. (its like if im stuck in the ground, my head at the level of the ground).

Plus i can see my remote like if they were 2meters away from me (even though they are in my hand).

During the calibration steps they are 2 similar steps (one with the center calibration and one for the ground calibration).

For the center calibration, does my headset need to be on my head? (The picture seems to show the headset at a given height). I both (on the ground and on my head).

and for the ground calibration the headset is on the ground and i enter 0m.

Issue #2
Also i tried playing movies and somehow when moving my head the image gets distorded somehow like if one eye doesn’t follow the other (a bit like a ghosting effect or like the image is dragging). I dont have that with my vive.

This happens even when moving my head very slowing.

Issue #3
Another issue is that launching a game like arizona sunshine only works if i launch it from Steam directly. If launched from PiTool, it see it open on my desktop for a few sec (white screen) and then close.

When i manage to launch it, Issue #1 makes it imposible to play since its not calibrated well.

Any help would be appreciated.

1 Like

1 do roomsetup in steamvr, if you dont you miss chaperone.
2 have had no problem with SKYBOX VR Video Player do i have not used it much
3 never tried to start game from pitool Always started from steam


Thanks, i will try SteamVR room setup tonight. Hopefully this is it.

Are you using basestations? If not, then disable the basestation setting in PiTool and calibrate to ~head height. If you are using basestations, then you can set the headset on the ground and enter 0m.

Have you tried turning parallel projections on in PiTool? It increases GPU usage (so it should generally be left off) but some games require you to use it.

1 Like

As @Davebobman said if you don’t have Lighthouses. Lighthouse tracking needs to be disabled & your height entered manually.

I have used BigscreenBeta for Videos at present. Fairly friendly.

I recieved my 5k yesterday and I’ve experienced issue #1 twice. Restarting my pc and rerunning setup fixed it… sometimes. The controllers where tracking though (Running PiTool v109).

What was strange was that when I ran room setup from PiTool, the headset position was stuck where I placed it during setup. While when running room setup from steamVR it was stuck at one of the base stations. It’s surprising PiTool manages to calibrate the floor while there is seemingly no tracking of the headset.

I guess the different positions could be caused by PiTool calibrating floor position from the headset(?) while SteamVR calibrates from the controllers(but a sample size of 2 isnt much to go off of).

If you are using two basestations, then make sure that the switch on one is set to “B” and the switch on the other is set to “C”.

Yes im using basestations. Ill try Parallel projection tonight.

1 Like

I think its like this already, ill double check.

1 Like

So I tried to use steam VR to do the room setup and it fix the calibration issue.

Although I now realize that I have the bad cable issue where I see white blinking pixels (I will post some photos/videos tomorrow).

Not only this but I seem to have an ‘jaggyness’ issue. Not sure how to explain but it feels like:

  • One eye doesn’t follow the other’
  • I feel a lag from time to time, it jumps frames. The image kind of skips.
  • Sometimes the image follow my head. Best example is the LOADING… screen of Arizona sunshine. If I move my head left, it moves left with me. It is suppose to stay put. This makes me feel dizzy.

I try with and without parallel projection.

No a great experience so far…

more then one possible causes

  1. usb problem, sensor data from LH tracken not reaching computer ir not fast enough
  2. GPU does not deliver enough frames (you did not prvide iforamtion about your hardare), but should differ depending on game and should not be the case with smart smoothing on, try to use something easy to render (steam vr home?)
1 Like


i would doubt that its a CPU/GPU issue since i am able to play any games maxed out (like anthem recent game and very demanding)

Here is my system info:

System Information

     Operating System: Windows 10 Pro 64-bit (10.0, Build 17134) (17134.rs4_release.180410-1804)
             Language: English (Regional Setting: English)
  System Manufacturer: Alienware
         System Model: Aurora-R4
                 BIOS: A11 (type: UEFI)
            Processor: Intel(R) Core(TM) i7-4960X CPU @ 3.60GHz (12 CPUs), ~3.6GHz
               Memory: 16384MB RAM
  Available OS Memory: 16302MB RAM
            Page File: 5607MB used, 16964MB available
      DirectX Version: DirectX 12

Display Devices

       Card name: NVIDIA GeForce RTX 2080 Ti
    Manufacturer: NVIDIA
       Chip type: GeForce RTX 2080 Ti
        DAC type: Integrated RAMDAC

even under “bad conditions” this hardware should deliver at least a good framerate
but i had choosen usb problems for 1. for a goog reason
(ok tracking problems with lighthouse in general like through reflections or other ir signals are also possible but if a vive is at hand its easy to test that tracking works)

Im using the USB 3.0 port for both my vive and pimax.

When i switch to Vive, everything is working perfectly.

I also have a feeling like the left eye of my pimax is more blurry than the other. For example with arizona sunshine, when i close my left eye, it is very sharp the face of the zombies are very clear and so it the text.

However when i close the right eye, the face of the zombies and the text becomes blurry.

I tried to move the HMD to see if its a bad fit, but that doesn’t seem to be the case. I will run more tests tonight

So after 3 days, still having issues…

In some games it seems like the drag effect is less visible. I’ve tried Skyrim and elven assasin and both was not “too” bad. But i can tell something is wrong.

The quality is not as i would expect. Both look so blurry. For example in elven assasin the text is so blurry and not sharp at all. when i switch to my vive, its night and day.

I tried both with and without parallel on. In Small/Normal/Large, with rendering at 1, 1.25, 1.5…

In arizona sunshine i manged to capture the dragging effect when moving my head:

Normally it should look like this:

And this is what the text looks like when i bring the steam menu (on the vive it is very sharp):

1 Like

Yeah something definitely seems off.

So a small update on my case.

During the weekend i tried to play with many options with resolutions, parallel projection On/Off, etc and was not able to achieve anything.

Although yesterday i tried it out again and baam, great resolution! Very weird. It became sharp.

Im wondering if the cable was wrongly connected or something. Although i still have the ‘Snow’ flicker but now most game are playeable.

I still have the same problem for Arizona sunshine for the ‘dragging’ effect. This one im still clueless.

Anyone got Arizona sunshine working fine?

I finally got it working (Oculus version) and it ran smooth enough, but I couldn’t stand playing it with Vive wands.
My specs I5 6600K @4.5, Gigabyte GA-Z170XP mobo, Corsair H80i Liquid Cooler, MSI GTX 1080 ti Gaming X gpu, SoundBlaster X-F1 sound card, 16 gig Corsair Vengeance ddr4 ram @ 3200 , 3 ssd drives.

2 areas I see slowing your performance would be your cpu clock and your ddr3. Both will have impact depending on the games you play.
For example the difference in DCS between 3.5 and 4.5Ghz is about 15fps and the difference DDR4@2133 vs DDR4@3200 is about 9fps so I can imagine what DDR3 is costing.