Quick 8KX Day 2 Review

After a weird mishap with FedEx here in Australia, I finally got my 8KX about 27 hours ago.
Visual quality is fantastic, much nicer than the 8K.
I mostly run it in native mode, Normal or Large FoV (as the games allow). Some games seem to crash at start if I try to run them at a very high resolution. Eg. Tethered, Aircar and Batman Arkham VR.
I found that they work at 0.5 Render Quality and Normal FoV (with only Parallel Projections ticked). And even at this reduced render quality, they look really sharp, clear, and nice.

I even ran Elite Dangerous and did some of the challenge missions (man I’m rusty at that game) it looked awesome. Comparable to my 3440x1440p monitor.

I tried it a little bit in upscale mode, in Project Cars 2, and the 114hz is certainly very smooth. But then I did it in native mode at 75hz and that too was smooth (smooth enough, for sure) but with better picture quality. So I prefer native. Especially since you can lower the render quality in pitool and still get great results at a lower performance cost.

I still haven’t got a base station (Pimax said they will be sending the kickstarter one I pledged for before the end of Oct, hopefully sooner than that)
or controllers (Can’t buy Index Controllers here in Aus, and I don’t wanna waste money on Vive wands that are destined for the bin)
so I’m limited in what I can do in VR. But I’m already enjoying the experience much more than I ever did with my 8K. There is still some drift in the 9dof tracking.

One oddity that I will test more, is that my left lens seems to sit closer to my nose than the right lens. It means that I have to shift the HMD slightly left on my face and the back of the MAS to the right. It kinda feels like its not centered, but it results in an optimal image.

I can also fit my Headphones (HyperX Revolvers) over the MAS, if I want better audio. But I tried the MAS speakers in Arkham VR and they got the job done. They are more comfortable than fitting over-ear phones on top of the MAS obviously.

tldr: “I’m already enjoying the experience much more than I ever did with my 8K” and it’s got me kind of excited to get into more VR games… Hyped for Star Wars Squadrons.

PC Specs:
i7 6800k (OC@3.8Ghz)
RTX 2080 Ti (some EVGA OC)
32Gb ram

18 Likes

This is cool, I was thinking that my 5k+ was the only way to get high frame rate but the fact that this is even still an option is great. What a great product!

Good Luck.

This is good to hear as I personally find the quest audio good enough for most things, i’m not an audiophile. When I get mine maybe I will become one.

Can you elaborate on this a bit more, I’m not fully understanding what you mean?

2 Likes

Clearly I am doing something seriously wrong as while I can run Elite Dangerous on the 8KX it looks like it is running on a VGA monitor.

1 Like

I think he means that, by reducing the super sampling via the PiTool Quality setting, you can get faster framerates.

4 Likes

Yes. under-sampling still looks great, and gives you more fps.
0.5 Render Quality in 8KX is better than 1.5 Render Quality in 8K.

4 Likes

Well that sucks.
For reference I have posted my specs:
i7 6800k (OC@3.8Ghz)
RTX 2080 Ti (some EVGA OC)
32Gb ram

I have everything set to max in ED settings, except display resolution to something small and windowed (this doesn’t affect VR, just the display on your normal screen) and I disable blur which i don’t like and AA which doesn’t do much in VR.
Supersampling is 1x and HMD Image Quality is 1x

Pitool settings are:
Native 75Hz
FoV Large
Render Quality 1
GPU Catalyst 0
Fixed Foveated Rendering Off
Parallel Projections On
Smart Smoothing Off
Hidden Area Mask Off
Vive Only Game Compatibility Off

There is still a little bit of edge shimmer in some places, but that’s the same on my monitor unless I really crank up the AA.

I hope you can figure out why yours doesn’t look right

4 Likes

Have you edited the maxRecommendedResolution setting in your steamvr.vrsettings file? If not, Steam VR is limiting your res. This is especially bad when using Parallel Projections, which is required for Elite D.

If you haven’t, just search this forum for details. This is a Steam VR issue, but soon the Pimax Experience app will be able to automatically update this for you.

2 Likes

Yes, I have, set to 16384. I had seen references to parallel projections on these forums but have not seen it referred to in either StemVR settings or Pitool.

Thanks. I’m sure I’ll work it all out eventually.

The file can be in one of several places and there have been reports of several copies of the file on peoples’ PCs.

To verify that it’s not the problem, try setting the value to 2048 and see if it makes any difference. (It should be really obvious.) If you don’t see a change, it means that you’ve edited the wrong file.

1 Like

Wow so really? That sounds nuts to me… would you say that running undersampled looks at least as good as the 5k+?

Hello, thanks for the help. And apologies for hijacking the thread. I have an i7 8700K @ 3.7GHz, and a mildly overclocked 1080ti. 64 GB (!) RAM.

I tried temporarily resetting the value to 2048 and it did make a difference in Elite, mainly in the legibility of the text. I set Pitool as you suggest, with the exception of “GPU Catalyst” and “Fixed Foveated Rendering”, which do not appear, presumably because my 1080ti does not support them.

Results in Elite were better than before, although lower quality than I achieve on my 1920x1080 monitor, which is disappointing, because Elite is the only reason I bought this HMD. I’ll keep fiddling with it, and reading the forums.

Meanwhile, Galnet reports that a single Sidewinder keeps taking off from Jameson Memorial, flying around for a bit, then returning and docking.

EDIT: I also found BNP’s WFOVFix tool which confirmed that I was looking in the right place.

3 Likes

I’ve never tried a 5k or 5k+ so I can’t really help you there.
Also two caveats to what I said:
I haven’t really determined that the PiTool Render Quality setting is properly affecting the final render resolution in games. (I have suspicions because 0.5 and 0.75 both look too good, I expected to see a more obvious degradation in picture quality)
I also haven’t personally determined if lowering the PiTool setting increases performance. I’m making the assumption that if it is affecting the final render resolution, it should be reducing the render load.
I haven’t been able to determine these things because the maximum and minimum settings I can use are already stable at the 75fps cap, and look great.

What I can tell you is that in some games like Arkham VR and Tethered, they won’t load up at all if you are trying to start them with a very large render resolution (eg. 1x quality and Large FoV and PP = large res images.)
I think there is some limit on the render resolution in the older UE4 engine (all games I’ve had this problem with are from 2017 or earlier)
You can either make the FoV ‘Potato’, or lower the Render Quality setting. I found that I can go to FoV Normal, and 0.5-0.75 Render Quality. So it is having SOME effect.

As I said, in Arkham VR I didn’t really see any visual difference between 0.5 and 0.75. 0.75 may be slightly better but it might be my imagination. The thing is, they both look great, and much better than anything my 8k ever produced, or the HTC Vive which is the only other HMD i’ve tried.
Even at 0.5 everything is sharp and clear, there’s no blurriness or muddiness.

2 Likes

I’d say the 8KX undersampled looks BETTER than my 8K. That’s at PiTool Quality set to 0.5. Yes, it’s pixelated to hell, but the lack of SDE and the higher fill-factor are a huge improvement.

5 Likes

Hey Troz, I’ve been thinking about your problem, I have a few ideas.
In PiTool, do you have a game-specific setting enabled for Elite Dangerous? If so, it will be overriding the normal settings in PiTool.
Also check your settings files for PiTool, as the GUI may have hidden the ‘GPU Catalyst’ and ‘Fixed Foveated Rendering’, but the actual settings may be set to something.
I believe the settings files are located in AppData/Roaming/PiTool/manifest/PiTool
Common Setting.json is the default settings file, and Elite Dangerous.json is the game-specific override settings file that PiTool may be using.
Open the .json files with notepad or wordpad or something and make sure that near the bottom the following settings are like this:

“foveated”: false,
“foveatedcom”: -1,
“hiddenarea”: false,
“smartfill”: false,

I just tried the FFR setting in ED, and it doesn’t work properly. It basically makes the whole left eye extremely pixelated. The right eye is fine though. It looks quite bad. The effect is comparable to an old low res CRT. If that is what’s happening to you, then this might be the reason.

2 Likes

Strange, i have NEVER been able to launch Arkham VR on a pimax . That particulat error in UE that complains about memory , I assumed that something like a 3090 would solve that, but if its an engine limitation then throwing more Memory at it may not solve it.

Youre suggestions are great though I might finally be able to play batman on my 5k+ after all

2 Likes

I had this problem with Hellblade. It seems that some games apply a large super sampling value to your res. I could only play it with PiTool Quality set to 0.5, otherwise it crashed on start up. The game actually looked pretty good on my 8K (and didn’t appear to be using a low res).

2 Likes

Me too. My problem was that the in-game supersampling was way too high (set when I was using a Vive instead of the Pimax) so lowering the PiTool quality or per game SS in SteamVR (don’t remember which it was) allowed me to start the game and lower it… :slightly_smiling_face:

1 Like

Hey, thanks very much. I will try those and let you know.

The Pimax Experience should be able to solve that kind of problem. If there is a setting that literally prevents loading then it can be adjusted in the default cloud profile.

2 Likes