PiTool 2020.3.24 - HLA ready

I agree. My headset is worthless if it stutters, and my 300 dollar controllers are too without an update. Any negativity is met with backlash on here, but man.

I’m a pre-order and not a backer, and I’ve maybe had 3 months of usability out of the year I’ve had this thing. An index would not have these basic problems. Instead of prioritizing the customers willing to take a risk on their obviously sketchy product they focus all engineering on making new hmds that will also hardly work. It’s just sad that a new firmware engineer and computer scientist with some experience could easily fix these issues in weeks not years. That’s not to talk down on the obvious engineer accomplishments pimax have made, but their priorities are just so laughable.

3 Likes

That’s true. Pimax has not managed to get a basic requirement right yet - the software.

It’s still not working. Every iteration comes with a new problem. It’s unbelievable.

2 Likes

It wont install.Says it has a virus.

Works well and getting alyx tomorrow.Should brainwarp smart smooth work on gta5 despite it not being a official Vr title ?

Tried reverting same as you to PiTool V1.0.1.253 and Firmware V2.1.255.255
No more tracking issues with 1½ hours continuous platime in HL Alyx.

Before reverting to this I could go for 10 to 15 minutes the my Index controllers would glitch, loose connection just long enough to dissapear and the reappear allmost instantly.

3 Likes

Since nobody here is using 253 Tracking Issues April 2020
maybe they should try it.

3 Likes

Yeah, it defo should default to 0 otherwise it’s going to break for people who have no idea why.

2 Likes

so does the alyx Pitool still have the tracking issues ?

the firmware is 255

does 255 have the issue. I dont know because I had upgraded to 258 beta before I played alyx and now im back to 253

I suppose I could try it myself. Flashing is such a pain it the butt.

3 Likes

I can’t speak to tracking issues. i haven’t ever had them. Using 249 myself.

Afaik Pitool 253 and 258 use the same firmware fv255 unless you manually flashed FV 263. Pt 249 is the same as 258, so seems a reasonable assumption.
I don’t see the 253 posted here so not sure of FV

@Heliosurge

1 Like

I have been setting up game profiles more often recently and couldn’t agree more. There is no reasoning behind the ordering of the list. I did find that you can enter the first letter of the game and it will jump to the different games that match.

1 Like

253 is still in the Release Notes Category. Just with being an alpha pitool didn’t list it. But can add it if need be.

2 Likes

I seem to be having the problem I used to have in getting the headset to track. Previous Pitools fixed it but it’s back with 258.

Yes it does unfortunately

1 Like

Well, I am hoping for support now.

Not about the Controllers, they will fix them anyway. But about tracking latency of my headset in 90Hz and especially 65Hz. I have a 5K+ SN204 and especially in 65Hz it has always been unusable - because the world moves with me when I turn.
Just like the old first 8K headsets.

I have tried literally everything short of a Format C: - fortunately I borrowed a RiftS to check. No problem. Then a Samsung Odyssey OG. No problem. It’s only my 5K+.

Hoping for support now. It seems they misunderstood and thought my issue was about controllers, and forwarded me to Mr Liu. I hope they understand that it’s just the headset (helmet).

Update: Mr Liu has responded and seems to look into helping me. I will share the result so you can profit as well, in case you experience the world lag as well. I have found a video of the issue on YouTube now: https://youtu.be/WEaZK4kVds4?t=54

1 Like

Damn, well guess the tracking issues must be with the pitool driver itself not the firmware.

is this just another beta or will my Pitool finally upgrade after a year?

1 Like

It’s PT 258 for dummies. :grinning:

2 Likes

By the way: I saw somebody write that there IS in fact a startup option that lets you to disable the dynamic quality scaling in Alyx, and SteamVR Home:

-console -vconsole +vr_fidelity_level_auto 0

I am assuming the first two arguments, that by the sound of them disable the console, are not necessary, but kept them just in case. :stuck_out_tongue:
Seems to work, judging by a quick test…

There is also:

+hlvr_continuous_normal_speed 150, +hlvr_continuous_combat_speed 150

…or more, to make Alyx move around more like the 19-year-old she is, instead of a rheumatic pensioner… :stuck_out_tongue:

@SweViver

16 Likes

This is awesome. Had been looking for a solution to dynamic quality scaling. Thanks.

3 Likes

There’s a new Pitool with a GpuCatalyst.

I installed it, and disaster, an image like a CV1 …

I go back to the previous one, same thing! I go back even further and same horrible result.

I have beautiful to chip, to deregulate, to go back, 90 Hz, 75 Hz, 120 Hz etc…nothing to make, always this undrinkable soup in the eyes.

Whereas since I have the Pimax, each new Pitool or Nvidia driver improved the visual result, to the point that I thought I had an in game image at 85% of a screen.

I’m confused.

1 Like