Pimax 8KX panel stopped working after 299 update

I have been spending the past 4 days trying to sort one of my Pimax 8k X. I have not used it for the past 4 months. Five days ago I connected it and it was working fine, however I then made the mistake to update the Pitools and afterwards it automatically updated the firmware to 299 which made the right panel stop working and the left panel to go snowy grey and turn on and off. I then flashed the headset, however any version of 299 gives me the same issue or a yellow led (wrong firmware issue). If I revert to 294, 295, 296 only the left panel works, however I could never get the right panel to ever turn on again. I have two Pimax 8kX and 2 older 5K (P2 and P3). I interchanged the cables to no avail. I then tried using the other 8KX on the other computer that had an old Pitool version installed and it works fine. When the second headset automatically updated the led turned yellow. However with this second headset I easily managed to revert it to 296 without issues and works fine now. I tried so far PiTool 271, 273, 275, 277 and the 279 beta that just got announced today to try and fix the problematic 8KX headset (with the right panel turned off), however nothing works. I tried all the 299 firmware versions that I could find in this forum’s archive, the 296, 295, 294 and another 296 version that Heliosurge was very kind to provide, however I cannot seem to get it to work. For the past 5 days I spent more than 30 hours on this and I feel like screaming in a pillow. Is there anything I am missing? Is the right panel gone for good? I also got the USB not recognised error (the guillemot conflict). I followed the steps that usually fix that, however it does not seem to help. Also even with that error, if I then connect the second headset then that one works perfectly fine. I tried all the usb slots on both computer and also a powered usb extender. I would create a ticket, however I purchased both headsets second hand. The one working fine I purchased in Oct 2020 and the one that now has the right panel issue I purchased in Nov 2021 so I doubt any of them have the revised hardware from Pimax. Anyway, none of the PCs have AMD cards on them (RTX3090 FE). Any help would be greatly appreciated.

Kind Regards,

Don’t worry just yet. I had that happen as well with a firmware goof. Pimax walked me through it. I had the one-sided issue. Certainly work with Pimax to have them help you as it may look dire, but once they show you how to fix it I sincerely doubt you’re bricked/broken.


Thank you for the encouraging words, I really hope that will be the case. Their engineers do some great things, as I still remember how they managed to give full FOV at 110hz for the old P2 version of the 5K. When they do get things right, it works wonders and the 8kx is an amazing heatset. That being said, I also bought with high hopes two pretty much worthless eye trackers at some point. Kind of a mixed bag sometimes and it is what it is I guess. I just wished they did not force firmware updates with Pitool if they have so many versions of 299 due to the revised hardware etc.

Yeah that’s an issue, but I know it’s being actively worked on from what Pimax’s notes indicated. The bifrucation that occurred with the 8KX revisions was a cluster. You may not get quick help as they are working only on weekdays during the day in China, and their resources are probably stretched thin. The only thing I can recommend is to follow descriptions elsewhere here and on Pimax’s troubleshooting related to firmware about forcing the unit to flash the default firmware, then there’s something about removing a erroneous USB driver, then finally using their DFU app to flash correct or current firmware. Any of those steps can’t make your HMD worse at this point and those were the steps they took me through via email. Basically I thought my unit was dead and it simply needed the firmware reset or fixed. I hope they help you soon as I know the feeling/frustration.

Was working well before I installed the most recent beta software. Now I keep getting 10935 and 10936 errors despite anything I do. I have gone back to the v277 without luck. I am considering attempting to flash the firmware back to the older version.

Flashed to the previous firmware (P2_RELEASE_8KX_M296). It appeared that the firmware was appropriately performed as I got the red, green. and blue lights as the support page discussed. Now all I have is a purple light on the 8kx and nothing happens. PiTool fails to recognize the device. I am also getting the windows error “Unknown USB Device (Device Descriptor Request Error)” under device manager.

Did I just brick my 8Kx?

Original discussions in Reddit

Submitted at ticket #28470


Could you provide us the ticket number?So we can take a look at it with the technician.


Hi Pat,

This should be a software glitch, please remain calm my friend.

I would suggest you to file a ticket with the tech specialist, Yvette or Adonis are here to assist you to flash a working firmware which allows you to run the headset again without any issue.

Did you check @guppyexpress eye-tracking software? It received lots of good reviews. I bet you should give it a shot.

1 Like

Thank you kindly for your reply and support. My apologies for the delay in my response as it has been a busy week at work. I submitted a ticket just now ( #28689) and I will wait for their reply. In the mean time I also tried upgrading one of the PCs to Windows 11 hoping it might change something with flashing the firmware etc, however it did not help with panel problem. Thank you again for your support.
Kind Regards,

1 Like

Hi Pat,

Your ticket has been passed to Criss, one of our technical specialists.

I received a response from him, stating that the blackout panels were mostly caused by the firmware.
He will provide a suitable solution to address it.



This worrying as I have a new 8KX DMAS being delivered next week !

It sounds like hit & miss whether the headset works properly out of the box.

Is there any FW that just works reliably without bugging out some way or another ?

Sorry to sound pessimistic but there seems to be so many issues on these forums for the new version 8KX. I don’t mind tinkering & testing but not endlessly.

Thank you Pimax Quorra, Heliosurge and everyone for your kind help. Just to bring an update on my situation. In the meantime I got the invoice for my headset and it was still in warranty. I followed the advice from Pimax support which were very fast with their replies and keen to help, however nothing seems to bring that right panel back to life. I sent it back via the RMA process. The return is still being processed by Amazon until 25.07.22. I asked if I could get a DMAS version since I use only RTX cards and thought it may be a less risk option of facing this issue again. However, they do not have any DMAS stock with Amazon in the UK. They only keep 272 stock in China. I offered to wait until they restock UK, however they said that the only option for DMAS would be for me to pay for the taxes and delivery from China. At the end of the day I plan to hopefully exchange both mine and my partner’s headset with 12K via the exchange program when it will be available, so for now I will just get another KDMAS which they currently have available in UK. My current questions is this though: Which version of software should I use for the remaining headset I have at the moment. I had stable 90hz on both headsets with the old software (I think it was the beta version of the software that came out in Dec 2021). The remaining headset I have is not in warranty anymore, as it was purchased in 2020 when it was really hard to get your hands on a Pimax 8KX. For instance, this helmet (from 2020) has a pretty strong mura. The newer helmet (from 2021) that I had to send back had no mura issue and did not heat up as much as the remaining helmet (2020) and I felt so lucky to have it. What I am trying to ask is, should I risk putting the remaining helmet to a software version that offers 90hz or should I just count my blessings and keep it on 75hz until I can exchange them for a 12K. I do not want to risk puting unecessary stress on Pimax with needing to do any further RMAs, but the whole purpose of me exchanging both of my RTX3080 cards to RTX 3090s was to hopefully reach 90hz in most games and stop the perceived flickering effect. My partner, she also seems to prefer the 90hz option.
Kind Regards,

It sounds like your 8KX suffered a hardware failure. This was almost certainly not actually caused by the firmware update to 299. I know due to the circumstances it will seem like it was. And it is possible that performing the firmware update was somehow involved, but it could also have been something else you did at the same time that happened to trigger it which you may not even remember doing. Like just disconnecting and reconnecting the cable. Or maybe it hadn’t been turned on in a while, and just powering it up did it. My point is that when hardware fails, just before the failure it may be in a state where literally just looking at it funny is all it takes.

I have my own example of this effect with the first 8KX I received. After I’d owned it for about three days, I was experimenting with the different modes. I tried switching it to the upscaling mode, and suddenly there were horizontal lines through the right side display in the headset. I switched back to native mode, but the lines didn’t go away. I tried all sorts of troubleshooting, but the lines didn’t go away, and eventually it was RMAed by Pimax. Was changing to upscaling mode what actually broke the headset? Almost certainly not. Possibly the mode change was involved somehow, but it couldn’t have actually been the cause. The headset was already defective and about to break. Any number of other actions or even no action at that point could have “caused” the failure to be realized.

In your case, applying a firmware update feels a lot more like it could cause the hardware to fail like that, but this is an illusion. Firmware updates can indeed cause a product to fail, but that risk comes from the possibility of leaving the firmware code in a bad state, not actually damaging the hardware.

All of this is to say don’t be afraid to apply firmware updates on your other 8KX headsets because of this. Go ahead and try to get 90Hz working. You’re not going to break the headset.

Do make sure you record your current Pitool and firmware versions first so you can come back to them if you have trouble. Pimax is not great on updates going smoothly. I’d say just try going to the latest Pitool and firmware and see if 90Hz works for you. If it doesn’t, open a ticket with support.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.