Pimax 8kx: Not registering LH at startup (random)

OK… getting frustrated an Pimax support seems spotty but they seem to be trying, at least.

Last night, I startup the system and the LH register immediately with HMD. Cool!

This AM, I startup exactly the same way and it took me multiple plug/unplug, restart of PiTool, restart PC, etc to get LH registration… Ultimately, it worked but I’m frustrated by the inconsistency.

Procedure:

  1. boot computer
  2. start PiTool
  3. plug in USB; then plug in DP
  4. wait for PiTool to show connection to HMD and verify that both LH are active/connected/recognized
  5. power up controllers; verify connection
  6. start SteamVR

ANY HELP WOULD BE APPECIATED.

Whenever I have issues like this I unplug the cable from the headset itself, so just pull it out slightly and put it back in (no need to take off the face gasket). A lot handier than getting in at the back of the PC and for some reason I have found better results.

1 Like

One tjing I have found on my pc pimax is picky about which usb port I use. So once you find one thst it likes make note of which one.

Might be an idea to to see if there is bios and chipset driver updates for ypur motherboard.

I have seen others have issues with the hmd lh driver loading properly. Might be an idea to filr a support ticket as well.

2 Likes

Fair about port selection. I’ve been specifically trying NOT to shuffle ports while debugging.

Will try alternate ports next, I guess.

1 Like

(post deleted by author)

I answered your question before. The controllers have nothing to do with it. PiTool recognises base stations the same way SteamVR does. As long as there is ANY device that sees the base stations, they will light up. If you paid attention to the solution I gave you in the past, you wouldn’t have this problem. Stop unplugging your headset USBs if you don’t want to have this problem and turn your headset off through the power button instead.

I did pay attention to the solution you provided. Thank you as it was very helpful. Since your feedback, I’ve been leaving the controllers off until I can confirm that the bases are connected to the HMD. If I power off with the power button what is the expected behavior for the LED?

Regarding your last comment, I’m not in a situation currently where I can leave everything all plugged in and just power off the headset via the power button. On that note, what are the meanings of the HMD LED? I’ve seen RED, GREEN, PURPLE, and WHITE. I did find a reference on Pimax’s site but their info didn’t seem to jive with what I was observing.

I appreciate the feed back and apologize if you thought I’d ignored your help. I didn’t.

I never leave my pimax hmds plugged in and have yet to have a Lighthouse driver in the headset fail to connect. There does seem to be an issue with some of the pimax hmds Lighthouse chips.

Reason pimax hmds do not remember or didn’t last power state and on a reboot usually powers itself on. While lcd burn in is usually reversible there is a chance it might not. A couple if users have had this problem.

Much like how some users have had & maybe still do; have problems with LH stable tracking. Some of the users were able to recalibrate the LH tracking. There is a whole topic on it.

The difficulty at times troubleshooting pimax hmds is there seems to be a quality issue in mfging. The most note worthy is the 8kX serial 2075 compatibility with the DMAS. Some have the 1.2k noise and others do not(have not heard of anyone reporting issue on 2073 or 2074). Instead of tracking down this quality issue and fixing they side stepped it going with 2075 being changed to not compatible with DMAS; releasing a downgraded MAS(v2.0) that is only compatible with the KDMAS audio module to discourage/prevent users from buying the DMAS Module.

There are two states of red. Dim red and bright red. Dim indicates standby. Bright red indicates complete shutdown. Green means active. Purple for when parallel projection is on. White is usually rarer but from what ive seen its when the headset isnt able to load its firmware properly.

Yes pimax still needs to do alot of work on making clearer guides.

On here we have the #guidebank and if you click on your profile pic. Click on the :star: and you will find a link there ‘Table of Content wiki’ that contains a wide range of solutions.

There is also a link in the Hamburger menu called “Docs” that will help for the Guide Repo.

My procedure on boot leave hmd unplugged. After your pc is finished booting fully:

  1. Load Pitool.
  2. Connect Hmd DP.
  3. Connect Usb. (One that you know works)
  4. Wait for headset to see Lighthouses.
  5. Power controllers.

I don’t leave the headset plugged in as people have had there PC reboot unattended and the headset went into On state.

One user in particular had screen burnin snd iirc had to create a negative pimax logo image and leave it on for an extended period to clear the after image. One simple fix is to replace the default image with a solid black pic.

sometimes a simple click on “Reboot HMD” in Pitool helps.
I haven’t unplugged my cables in years.

Just to chime in: I’ve been running my 8kX for a couple of years(?) now, without much issue. I have had intermittent issues but I just unplug/replug the usb port and things are fine. I leave it plugged in and start Pimax to start it up.
Lately, the headset will not see the LH’s no matter what I do. I’ve done all of the replugging that always worked before but it just will not see the LH’s. The controllers see them fine, the Pimax LH pics light up when a controller is turned on, etc, but my hmd will not. It seems to be stuck in 3dof mode. I haven’t mentioned it so far as I’m getting ready to reformat C to see if that helps, but I just haven’t felt like doing the work, yet.
One of the reasons that I’m mentioning it is that I’ve only recently started seeing a lot of posts about the hmd not seeing the LH’s and I’m starting to wonder if Pimax did something. According to the logs, the headset is definitely ‘phoning home’ on startup. I seriously doubt it but who knows…

1 Like

Very unlikely considering your expertise already, but just incase, is the headset set to 9-axis by accident? Sometimes something simple like that can happen.

2 Likes

@SmallBaguette maybe correct on this as sometimes you may need to rerun Room setup or possibly the headset settings are not saving properly; to which I recall sometimes reflashing the firmware may resolve.

However it is also possible a change in a newer pitool might be causing an issue. I bought a 5k+ off another backer after selling my first one. For some odd reason it only liked the 2nd DP on my 1080ti vs my og 8k and 8kX preferring DP1. Where as on my Amd 390 8g the 5k+ was fine with the same DP as the og 8k. On the last bad forced firmware flash it seemed to correct the odd behaviour with the DP preference. However thst forced FW caused an issue with 1 panel staying Dark and other earlier FWs has not corrected the issue. I have used my og 8k cable on the 5k+ and vice versa. So not a cable issue. Still need to find time to get a ticket filed and have them remote in.

1 Like

That’s the odd thing: it seems to either get stuck in 9-axis mode or it says that it can’t see the LH’s. I’ve never played with 9-axis mode so I don’t know much about it but it sucks. When it gets stuck in 9-axis mode, switching in and out does nothing. When the message is that it can’t see the LH’s, clicking the button puts me back into 9-asix mode and the LH message disappears, but when stuck, it does not switch back to “can’t see LH’s”.

@Heliosurge I’ll try re-flashing the firmware and see if that helps. Room setup seems a waste of time as the headset does not seem to see the tracking info, but it might be interesting to see what it does. Haven’t changed pitool versions and changing the dp didn’t help.

Thanks for the ideas!

1 Like

Yep if the headset is not seeing the LH(s) than the LH receiver is likely not initializing. I would file a ticket with support. Verify your usb drivers/chipset & bios is latest.

I think with just the Headset connected you should be able to see the LH receiver in device manager. Just don’t have controllers on/connected.

It seems some users han issue with the LH receiver not connecting. Support might be able to fix it.

Due to security concerns, I don’t allow remote login so I don’t know how much help a ticket would be, but that’s an issue for another day. I’ll give the drivers/firmware a shot first, then the OS. My OS is getting bloated anyway.
Do you have any idea what the LH shows up as, in Device Manager?
Thanks for the help!

1 Like

Not sure the exact. But eill be domething like ‘lhr#######’ iirc.

The controllers also have a similar entry if on.