Pimax 8KX must be unplugged and replugged every time PC is started (Very Frustrating)

Pimax 8KX must be unplugged and replugged every time PC is started (Very Frustrating)

I thing the title says it all.
I turn on my PC to get some racing in VR going, I power on my V1 Light Houses, I start piTools, I turn on my 8KX and it either won’t track or is not recognized

I then proceed to unplugged both USB’s and sometimes even the Display Port Cable and then everything works.

I can’t be the only one that this is happening to, Please Assist if you have any info that can help correct this behavior, it really is Very Frustrating.

1 Like

Probably the USB is shutting down to preserve energy and “crashes” the 8K-X.

I recommended that you get a pcie-usb card or try another USB port.

I have the same issue… and the power saving feature of my USB controllers is disabled

I have this only in some cases, then only unplugging USB allows to restart the 8KX. Yes, there is a bug.

I wanted to verify everything before responding to this.
I disconnected my 8KX from the usb hub and plugged the usb 3 connector into a usb 3 port on my PC (Directly).
I connected the 8KX usb 2 connector to a usb 2 connector on the PC (Directly)
I then re-configured the BIOS/UEFI setting to Not shut down power on the usb ports so that there would be no chance of the 8KX loosing power or connection.

The result is exactly the same, when I power the PC on, start piTools, power on the 8KX, it doesn’t work, I then unplugged both usb cords from the PC and replugged them and the 8KX shows connected and recognized along with the light houses in piTools and it then works.

I do not like the idea of constantly unplugging/replugging things from the motherboard ports. That is just too much wear and tear on these things and they always eventually break or get loose.

first the X, then pitool!


I will try that today to see if it makes a difference.
So, what about power off, I normally stop Steam VR, then power off the 8KX and then close piTools.

I will try anything at this point to avoid frustration.

When I quit pitool, my X switches off automatically.

(nonstop USB Power required)

My 8K-X stays off till i open Pitool, then it starts normally.

Then, when i close pitool it closes too.

Did you try to ONLY restart the pitool service instead of repluging everything ?

Also, this can be the DP port and not the USB ones.

1 Like

Yes, I have tried to just restart the service, I have tried to reboot the HMD, but non of that works.

How many DP ports do you GPU have ?

Can you try to plug your monitor on the HDMI (or other non DP port) and then plug the 8K-X only ?

My display is already using HDMI, I use a 65" LG OLED with GSYNC at 120Hz, so the only thing using DP port is the 8KX. My GPU is a 3090 Founders Edition, it has 3 DP ports and 1 HDMI port.

Ok, so this is the second time I started my PC today, as explained before, the usb ports are configured to stay powered.

Both times, I turned on the 8KX, then I opened piTools and the 8KX and Base Stations were recognized.

I’m hoping this continues, if this keeps working, you have relieved a Ton of stress and frustration.


My 8KX does not switch off when I quite piTools though, I guess you can’t have everything…lol


Thanks so much for jumping in there to try and help me, this has been a painful annoyance lately, this didn’t alway happen and I’m not sure why it started.

It seems to be working for the moment, but I fear that this will only be temporary but I will keep my fingers crossed.

It’s funny that your 8KX operates differently than mine, My 8KX powers on and off without piTools and definitely does not power off when I close piTools.

It’s very strange, which firmware do you have ?

Im on:

And my setup is almost as yours, 3080ti with the HDMI being used by my OLED C9 too.

Another question, what’s your motherboard ?

That’s funny, my OLED is also a C9.

My motherboard is the Gigabyte Gigabyte Z490 AORUS MASTER with a i9 10900k

My piTools is:

What do you do about shutting down Steam VR? What sequence?

I see your firmware is later than mine, so I just did a check for new version and got this:

We have very similar setups indeed, i’m using a 8086k with a Asrock Z370 Taichi something.

I always open Pitool first and then start SteamVR, doing the inverse when i shutdown.

Yes, i bought this 8Kx used and it came already with this firmware flashed ! Suposedly it’s a beta beta version of the 90hz (although it just shows a black screen no matter what)

You can try to persuade the support team for this version or someone could send it to you.

Thanks again for taking the time to respond, I really appreciate it.

1 Like


This is a weird scenario. We do suggest you file a ticket to the tech support, they can take a look at your issue, and provide further assistance.


1 Like

Well, it looks like that was very short lived.
I used the 8KX 2 days ago, today without any changes what so ever, I decided to jump in a get some hot laps in, but I guess my 8KX had different ideas.

I first Powered on the Base Stations
I then booted my PC
I then Powered on the 8KX
Finally I started piTools

And…Drum Roll Please, Yes, the 8KX and base stations did not get recognized in piTools, so unplug both usb’s and replug them and the 8KX and base stations are instantly seen and working.

This is very annoying, I guess it’s time to do as suggested by @PimaxQuorra and open a ticket.