Pimax 8kx half life Alyx no PP large FOV with Fog, really amazing

Hello all,

I found a way to play with the fog and all effects with the wide FOV with no PP(Parallel projection) on HL Alyx.

The command to add in steam:
-console -vconsole +vr_fidelity_level_auto 0 +vr_fidelity_level 8 +vr_multiview_instancing 0 +vr_shadow_map_culling 0 +sc_no_cull 1

With this I can play in great condition with large FOV, I didn’t see any clipping on the side of my field of vision. No image duplication.

15 Likes

Thanks a lot for sharing! When i finally have the SS controllers, i will try out Alyx and along with it your tip!

4 Likes

Nice, I’m using @NextGenVR’s one: -console -vconsole +sc_no_cull 1 +vr_multiview_instancing 0 +vr_shadow_map_culling 0 +volume_fog_enable_stereo 0

Is setting fidelity level 8 better than disabling stereo fog I wonder?

5 Likes

There’s still something weird going on with the fog, so I think we still need this to disable the stereo fog… :wink:

I’m going to try a combination now (added “+sc_no_cull 1” and “+volume_fog_enable_stereo 0” to OP’s suggestion):

-console -vconsole +sc_no_cull 1 +vr_fidelity_level_auto 0 +vr_fidelity_level 8 +vr_multiview_instancing 0 +vr_shadow_map_culling 0 +volume_fog_enable_stereo 0

EDIT: That seems to work very well…! :wink:

9 Likes

Great I’ll try the new combo as well!

Edit I’m glad I rechecked this, for some reason I had previously set fidelity level 3 :thinking:

1 Like

I currently use

-console -vconsole +sc_no_cull 1 +vr_multiview_instancing 0 +volume_fog_enable_stereo 0

I found disabling shadow map culling doesn’t seem to do anything, so I took it out. And I recommend keeping the automatic fidelity engine. Setting to level 8 is the highest and you may notice a performance hit in some parts of the game. (Level 3 is 100%)

P.S: All those commands, with the exception of the fidelity ones were discovered by me and shared a long time ago on this forum.

Also for in-Game graphical settings I recommend setting Characters -> Low, Shadows -> Medium or High, Fog -> Medium

It saves a huge amount of performance while having practically no difference to the image quality.

6 Likes

What exactly is the fidelity % corresponding to?

1 Like

You can read about it here:

1 Like

Ah, cool, it’s just another supersampling toggle.

Alyx’s auto fidelity engine ensures you maintain a smooth framerate in all areas of the game. Some parts of the map, fidelity can go up to 8 and in others it may go below level 3. But with the 4K resolution of the 8KX you likely won’t notice when this level changes.

I might disable MSAA as well. Don’t need anti aliasing blurring everying with dual 4k screens and 1.25 pitool resolution scale.

2 Likes

I think MSAA is still important even with the 8KX. I notice a big difference when it is disabled for example in beat saber. But you can try it and see how the image looks for you.

Yeah, I’m not a fan of most AA implementations in VR. Subjective of course like most things in VR!

2 Likes

I hope you don’t mind if I collect the link here :point_down:

Collecting useful posts about 8KX

3 Likes

MSAA is quite taxing on ones GPU - for myself I prefer to either bump up SS in PiTool or use FXAA but with FXAA, make sure it is enabled in the Nvidia Control Panel.

Horses for courses.

2 Likes

Hello

i have an i7 9700k.
and it runs on 8x 4.9 GHz.

I have an RTX 3090 MSI X Trio.

Unfortunately used up

  • vr_multiview_instancing 0
    too much CPU power.

My CPU reaches 100%

is there another way to reduce the CPU performance?

with parallel projection and without + vr_multiview_instancing 0 it works better.

but GPU is higher then.

is there any other option?

1 Like

I am not sure what you are trying to achieve? Just by name, I would guess that “multiview instancing” uses multiview rendering, which is supposed to save GPU and CPU perf. Disabling it should then increase the perf. hit, which it seems it does.

You don’t need to use Parallel Projections if you use the commands in this thread in the launcher.

1 Like

Here’s the info, so you don’t have to hunt for it…

HL Alyx can be run with Parallel Projections turned off, but you need to configure the “Launch Options” in Steam to: (Discovered by @NextGenVR)

-console -vconsole +sc_no_cull 1 +vr_shadow_map_culling 0 +vr_multiview_instancing 0 +volume_fog_enable_stereo 0

From:

2 Likes

I believe when I tried it (together with the fidelity mod) I had a problem with the lighting on several occasions. One I remember was in the metro station (with the heavy combines) I saw the lights on the wall and their projection was off to left. Eventually I went back to PP on.

I wonder though, if multiview instancing is optimizing the rendering for a single pass (shading), could disabling it have actually the opposite effect? So you win something on having canted rendering and then lose something on disabling an optimization. I would guess the benefit could eventually depend on the size of the FOV you set for rendering, and that on small FOV this can even be a disadvantage (if anyone plays Alyx on Small).

1 Like