Pimax 8K stopped working

Hello, I updated Pitool last week, also steam vr. Since then my 8K has stopped working… well it occasionally tracks if I move the HMD about a lot but after 15 seconds it looses tracking again. I’ve tried everything and have heard back from steam support saying its not them and the answer maybe in the Pimax VR server log file… I cant find that… any idea?
What I cannot find out how to do is to rollback the firmware… can anybody help with that?
Sadly I’ve not heard back from Pimax to date.

1 Like

Welcome to the Open[color=orange]MR[/color]!

Can you post your system specs?

Including pitool version.

Pitool V2020.3.24
Headset Firmware V2.1.255.255

i7-7700K @ 4.2Ghz
1080Ti 11Gb

1 Like

I have 2 Vive lighthouses V2

1 Like

Maybe try pitool 255

Thank you, I tried 255 and its the best so far but again I loose tracking for no good reason at random moments. Do you know what version of firmware should go with 255 and how to rollback?


Your welcome. 255 uses the same firmware as the one you had installed.

You could try increasing the height of your lighthouses and/or space between them.

This link has a table of pitools for download and lists firmware version of each pitool.



This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.