Pimax 5k+ - Prepar3D v4.3 white flickering texture in the far right periperal vision

Hello folks,

Have anyone tried Prepar3D 4.2/4.3/4.4 in singe pass VR, not “stereo” mode (setting in P3D menu)?

No matter what I do in the PiTool or in P3D v4.3 I get these strange white texture flickering in my far right peripheral vision. They are there only when I set P3D to “Singe pass” (in the P3D VR menu), not when I set “Steroe pass”. However, the performance in “Stereo” in P3D is way to low, and the clouds and water dont render correct in each eye when using “stereo”. I don’t get this on my Vive.

I have also notised in the Steam VR Home scene that when turning my head, the textures in the far right eye periperal disaper just before the edge on the right screen/lense.

1 Like

try to enable parallel projection to get rid of the disapearing objects in the edge area, might cost some perforamce to have it active

@IG88 enabling or disabling parallel projection don’t help with the flickering white textures. It seems this is a problem with P3D rendering in “Single pass” (not Stereo), and is reported by other P3D users. For example the Samsung Odyssey + has the same issue. But with wider FOV the issue gets worse…

at least this should not happen with PP on

The same issue with disappearing geometry on the right side of the right lens is also present in x-plane 11. I really wish Pimax would publish the exact openVR requirements to correctly render to the wide FOV non co-planar displays.

1 Like

@RiftFlyer If both P3D and XP11 has this issue it can be a Steam VR Open VR problem. But I have tried many other games in Large FOV with no flickering (I think I had PP on in PiTool). But with P3D it doeas not matter if I use PP on or off, still flickering textures/lines in my far right periperals…but only in “single pass rendering”.

1 Like

@IG88 Yes, in Steam VR Home and PP on the textures in my far right periperals does not disaper to early - but only in Steam VR. In P3D with PP on/off it is still a problem, but only in “VR single pass rendering”.

1 Like

I have that Problem with the black bars with Prepar3d V 4.4 and Pimax (or beta) …
Monomode is unusable - is there another workaround?

Sorry but there are no workaround. With small FOV it is better, but still visible. I am using normal or large FOV and just try to ignore the mess…

Just upgraded to P3D v4.5 and the flickering texture in the far right periperal vision it still there. However, I think this is an issue with all HMD’s and P3D - but is much more visible in the pimax because of the wide FOV.

Regarding “black bars with Prepar3d” -> disable the “Hidden area mask” in PiTool. I have posten this is several other threads, but I will mention it here to…