Pimax 5k+ Packet Loss

I have been trying to fix an issue since I got my pimax about a month ago. It works great all around visually.

My problem is that I get packet loss, and its linked to something with the background services for pimax, either piservice pi overlay or something of that variety. So while the headset works great, every time I’ve tried to play online games with it I get intense lag due to packet loss. Even with other games I play online, I havent ended the pitool background services I get packet loss.

I have tried rolling back to one other version of Pitool, but I’m hoping to either get a specific version to rollback to or find another solution here. I have only found one other comment on a post regarding this.


“having strange issues with internet packet loss since installing this update, uninstalled 1.29 pitool and deleted everything in appdata and installed this version and bang i am having packet loss, was able to confirm using winmtr tool with pitool on and off, dont know why this software version is causing it as previous versions did not, please fix it.”

Are You using a wireless adapter? Maybe a USB-based one?

That would make sense since VR headsets are known to hog the USB bus.

If so, You could do as I, and many others, have done and use a dedicated USB PCI-e card for Your VR headset.


No, I am not using a wireless adapter. Why would this problem occur on a completely wired setup?

Is PiTool running in the background? Try exiting the program. (It doesn’t have to run for VR to work.) Why? There have been reports of heavy internet usage by PiTool. (It might be a bug, since it really shouldn’t be talking to servers.)

I’ve never investigated this, but there have been posts about it on this forum.


Thanks a bunch, I had tried this before but it seems I needed to take it one step further as you suggested, and end Pitool in task manager.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.