Pimax 5k disconnected:diagnose 10500 after instalation of PiPlay

Pimax 5k disconnected:diagnose 10500 after instalation of PiPlay
before worked without issues with PiTool
Tried couple times : plug off/on usb and dispaly port , restarting PC , servcies , nothing helps
It works before PiPlay installtion.

Any idea?

1 Like

Have you tried open up your task manager and under services tab, PiServiceLauncher
right click on this and choose restart. This works for me on 10500 when I turn on and off 5k+ and gone wonky.

Whats PiPlay for? I am able to run everything without that installed.



Keep piplay aside unchanged, and re-install the latest Pitool, and the connection will recover.

1 Like

for instance to gain extra fps in Oculus games, revive is more resources hungry…

1 Like

In pitool, under games you could import your oculus games and that would run too without piplay

1 Like

Yes I Have Oculus games imported to pitool but based my knowledge they using revive drivers not Pimax one…

Sorry I’m abit lost here,
I have pitool and oculus software and steamvr installed.

I’m able to run the oculus games through pitool, I have not installed revive.

What’s the difference between this and piplay?

1 Like

As I understand it, they work similarly, but PiPlay / PiTool has lower overhead, so you should have a somewhat better framerate, if you do NOT use Revive.