Pimax 4k, webvr on firefox. headset is tracking but no images on the headset

I was wondering if the issue described in the title is something related to my setup: desktop 1080gpu piplay 1.1.92 (why fix something that is not broken :P)

Here is a link A-Blast to a vr demo game made by mozilla (I ll get there sooner or later) on webvr. Would be nice to know if it works for you and if so, what piplay version you are using.
I have the same issue with other demos and web based video players. the video mirrors fine and tracking but steamvr says that firefox is unresponsive and I am stuck in the dark loading screen.

If is working for you guys on the 2.x I will try update too.( my last try was a disaster)
Thanks in advance!

1 Like

Looks neat. Gentlemen that might know how to get to work would be possibly @Sjef @Enopho & possibly @jonnypanic.

I’ve added your post to bookmark as it looks like a go on my phone at least. Working next couple of days so unable to trial on pc till week over. :v::disappointed::+1::sparkles:

Works on latest Piplay.

Are you selecting the Cardboard icon on bottom right?

Just tried on Piplay 1.1.92 and it’s also working.

1 Like

i would suspect that you would run this in video mode and make the pimax the default monitor so the browser would jump to the pimax, then click the headset icon on that webpage and it should work. i have seen other demos like that before and they work in this method…

for your ref i have 1.1.92 on one of my pcs and latest 2.x on my other one

1 Like

For reference:

Piplay 1.1.92 & latest worked in Pimax Mode.

1 Like

Hi @ureroll, you may manually upgrade the graphics card and the Piplay version.Please be advised.

1 Like

Alright, looks like it is indeed something on my end, I’ ll give it a closer look. Thanks all for the feedback

1 Like

Could not figure it out so I updated to latest Piplay 2.0.7 install goes fine. At first startup piplay reqires to flash the firmware and after that steamvr compositor fail to start. Blacklit black screen and blu led on the hmd.

Same thing happened last time with 2.0.4 now that I think about it. I will dig in forums to revert the changes & reflash the hmd.

Anyway CMM said it was working for him in 1.1.92 so I ll try some other way ( once i get the headset usable again)

When uninstalling Piplay, it does not remove everything it should.

Piplay 1.1.92 usually leaves this folder behind and it’s contents conflict with Piplay 2.0x.


Also, make sure Steam/SteamVR related tasks are all shut down.

More times than not, when exiting SteamVR, “vrserver.exe” does not actually shut down properly.

1 Like

i got same issue when i try and play games of firefox