Pimax 4k Not Powering On


Just last night my HMD was working perfectly fine, now today I go to power on the headset and nothing happens. No power led, nothing. Tried on two separate computers and using different USB ports and nothing seems to work. I tried to use DFU mode and the LED remained off. I’m not sure whats wrong with it, I haven’t had it for very long and it’s been taken care of well.

Have you tried holding the unit’s power button? Another thing to try is hold all three buttons on i think for 8s

Yeah, I’ve tried holding the power button. Also tried holding all of the buttons.

can i ask, when you run piplay (and nothing happens) can you please right click on the piplay icon in the system tray and try to switch modes… 1st try VIDEO mode and then try PIMAX mode - wait 10 seconds between doing them to see if anything happens.
Video mode - should (if working) make another display appear in windows display properties, the screen may flash and Kodi may launch… have a look in the HMD and check windows display properties to see if there is another screen… if there isnt check you device manager while in video mode and see if you have any ‘!’ icons on any devices.

Let us know how that goes…



Switching to either mode through the icon doesn’t do anything, the LED is still off and nothing changes. Nothing different shows up in my device manager in either mode.

thanks for that clarification, it means that the pimax is not getting any power at all… can you please try another USB port. make sure its NOT plugged into a USB hub! are you using a USB 2 port or a USB 3 port? is it on the back of your PC or on the front?


I’m using USB 3 and have also tried USB 2 and its not plugged into a HUB, its plugged directly into the motherboard. I can try more ports but I’ve tried 3 so far.

ok thanks for the info… you said it was working last night, and on a reboot it is not working? im thinking 1 of 3 possible issues…

  1. some windows updates hit your pc and messed up the motherboads usb hub - this is unlikely but still possible
  2. the cable from your pimax has become loose in the headset end there are videos on youtube on how to dismantle your headset but if its new you prob want to speak to @PIMAX-Support 1st as this may break warranty - if they say its ok to open to reseat the USB cable on the headset its not too hard to do.
  3. the pimax is faulty and dead in the water, also should speak to pimax support.

if you have a spare pc, you could always plug it into that… even if it does not have piplay drivers the USB should be detected!


Yeah I’ll contact support over Skype. As long as they say opening it to reseat it wont cause issues with the gearbest return policy I’m open to trying it.

thats the ticket! i have already added pimax support to the last post i made, so they will be notified that your needing some help… i will also add @deletedpimaxrep1 who works at Pimax and is very active on these forums to help as well.

Good luck Jvk1166z

Thanks for the help!

your most welcome… Pimax can even flash the headset remotely if they think its a firmware issue… so keep positive!

1 Like

Thanks @Heliosurge @Enopho

It may be something wrong with Firmware update. Please operate again as below:
Firstly press all 3 buttons in 8 second, and then loose power button and keep other 2 buttons in 8s, and then loose middle button and keep left one in 8s, you could loose the final one after 8s more.
PS: I also made a small video about operation above for your reference, link at: MEGA

Edit 30/08/17: Sorry for confused expression above.

Please firstly press all physical buttons at the same time (do not connect the headset), and then just plug the USB cable of the headset to a port 2.0 / 3.0, and then loose power button after 8 seconds, meanwhile keep other 2 buttons in 8s, then loose middle button and keep pressing the last button in 8s,
then you should see the light is flickering, it means the headset enters to DFU (Firmware update) mode. If not, please operate above again.

When the light on the helmet is flickering, please download firmware update tool to flash it, link at: http://community.openmr.ai/t/attention-pimax-official-firmware-manual-update-tool/2160


@Jvk1166z did the instructions by @PIMAX-Support fixed it? Please update us!

I have the same problem but after doing the described activities, the equipment turns off after a while (disconnection signal from the computer). Please help.


Hi,please send your detailed issue you have met to our mailbox:support@pimaxvr.com
We will help you.:slight_smile:

1 Like

Unfortunately, nobody responds to this email :frowning:


Someone help me?

@Pimax-Support @Sean.Huang @Doman.Chen @bacon

Support might be on a much needed time off. Added some pokes.

Can you post your system config?

Bumped your user level up one.

@Petendo pls send detail issue and process of use to us by support@pimaxvr.com. and is it normal to use it before?