Pimax 4K crashes Windows 10

When i plug in my pimax 4K, Windows freezes after a vew seconds and I need to restart my pc. It doesnt freeze if the pimax is turned off. I tryed reinstalling windows, reinstalling video drivers, reinstalling piplay, changeing graphics card, and I tryed another PC. My gpu is not overclocked. Can someone help me plz?
My pc:
cpu: i5 8600K
gpu: GTX 1070 (tryed R9 280)
Mainboard: Asus Prime Z370-A
RAM: 16GB Corsair
OS: Windows 10 X64

thanks for helping :smiley:
Installing amd driver 17.12.1 did solve my problem.
(I had also a problem with the gtx 1070, because i didn`t uninstall the newest amd drivers ._. )

Okay i see you have an Intel cpu. Have you disabled Integrated graphics in the bios? You might also need to uninstall it in Windows device manager.

While I am not certain that is causing your crash.

I have added a poke to support to your post. Support has an excellent tool if needed may need to arrange a Teamviewer session.

Can you also ensure non essential USB devices are unplugged and in you have a spare mouse and kbd Try that as well as we have seen faulty hardware affect piplay in the past

1 Like

Hi @Alex1, regarding the issue you have met, please contact our mailbox: support@pimaxvr.com
We are willing to help you with remote control.:slight_smile:

@Alex1 : I had a problem at first with my system: e5-2670 and radeon RX480. When I would plug in the HDMI the PIMAX software would show that the HDMI connection was live, but windows would lock up. I found that I had k-lite installed on my system. After I uninstalled the PIMAX software I uninstalled K-lite from my system and reinstalled the PIMAX software. After this I didn’t have trouble with my system locking up.

1 Like

same problem here cannot seems to manage.

windows 10
i5 6600K
when installing piplay, the pc suddently stop working, crashes.

Have you tried the above?

Also with your processor ensure Integrated graphics (aka igpu) is disabled in the bios.

yes i have. i’ve disable igpu and only use the pcie. i just bought the pimax. yesterday i’ve try using laptop nvidia 1050ti and it work. but when i’m connecting to the pc it doesnt work like in laptop. in fact when i tried installing the piplay 2.07.54. the pc suddently crash and froze. thah also happen when i’m installing the piplay first, then connect the hdmi.it just froze after hdmi connect.

well now i know 1 thing. my pc didnt detect the pimax when connected. when i connect using laptop, it detect pimax as another monitor. but when i connect to my pc via HDMI port. nothing happen.

Try uninstalling both Piplay & k-lite codec pack.

You might be experiencing what @Blue_Beetle_13 said. Reinstalling Piplay after uninstalling both above might fix the Windows freezing.

I’ve done uninstall both codex and piplay. But the problem still persist. I’ve formatted my pc still, the problem occurs. When i plug in the pimax’s HDMI, the LED turns red and froze my pc after installing piplay. One thing i’ve notice is when in the installation wizard. The software only mention my graphic as AMD graphic and coloured yellow. Is it that it didnt detect my graphic and that is why when plug in HDMI it froze? If theres no piplay. The LED turn blue and i can see my desktop.

After all that is done. All attemp only results in frozen windows and i’ve to manually restart.

1 Like

if you have formatted your pc and rebuilt windows then i doubt that the issue is software related… i would be looking to see what USB devices you have connected?

we have had an issue in the past with a person having a faulty usb keyboard and while it was plugged into the pc the piplay would crash the pc.

eliminate all your usb devices 1 by 1 to see if any are causing the crash… doubtful its software if you have reinstalled all of windows and the issue is still there!


1 Like

okay it seems i manage to fix. well not entirely fix. there are conflicting software between AMD newest driver and piplay making my pc freeze. i’ve uninstall the current driver and install the older version 17.12.1 AMD driver and it works. i wonder wheather there will be a fix about this. i almost gave up.

thankyou Enopho and Heliosurge


Yeah not the first time Amd has brokw things with a driver uodate.

1 Like