PC freeze issue

Good morning
I have spent all the week end trying to fix my problem- no luck
It is important to understand that this is a replacement set as my first 5k+ ended up having screen problem. I dis not have any problem running this first 5k+.
I finally reinstalled the full W 10 Famly OS and

  • installed Pitool (latest relaease - not he beta)
  • installed steam
    -installed the lastest DP 1.3-1.4 firmware for my GTX970
    Just the fact plugin DP and/or USB port of the pimax ends up in freezing the computer after 3 mn of use. No way to the in the venet logger of the PC what is happening.

I have to say that even without steam, just with Pitool, the PC is freezing when DP/USD port are plugged. At tstart of PC the PIMAX VR Start Page is working ok.

I do not understand why this Headset is not working when the previous one was, with the same PC Specs : GTX 970 EVGA, i7 6700k, 16GB Ram, OS running in a 500GB samsung EVO SSD

Thanks for your help


I thought I had this, but it turned out my mouse and keyboard had both stopped responding. The PC was still actually running, it just wouldn’t respond to me. Have you tried running something in the background, perhaps a youtube vid, and then see if it carries on playing while your PC ‘freezes’?

I solved it by reducing hubs / extensions and swapping ports around.


The PC is not responding, mouse and keyboard,and his on the desktop screen. If I open another program, i cannot use the alt tab to switch. PC is completely frozen.

Yeah, but can you try starting something that plays audio, like a vid, before starting pitool / turning on the hmd, etc.

Then if the vid carries on playing, and making noise, while the mouse and keyboard is not working, we know that the problem is there rather than on the PC itself.

1 Like

I will try this, but I have no hubs, just the pimax plugged in(and the mouse/keyboard. i ahve troes all usb ports as well.


Try switching around the mouse and keyboard ports too, if you have only been switching around the Pimax one.

1 Like

Oh and also try disabling any software you may have for the keyboard or mouse. Macros, custom rgb stuff, etc. My gaming keyboard seems more reliable when I stop all the fancy stuff running.

Sorry to hear. The pitool your using is it tgw same version that was used on previous headset? (Shouldn’t matter)

But reducing usb devices to mouse keyboard plus pimax can be good for debugging.

Well, last time i installed pitool was 1 month ago with the current version at that time.
I will now play with the keyboard and mouse.

1 Like

If it happens when you plug in USB cable (but not the DP) the issue is most likely with the headset initialization. Even when everything works ok, there is always a perceivable stutter when the headset is connected or powered on (by the button).

Now, when something goes wrong PiService tries to initialize the headset again, and fails again, and again, etc. basically putting the OS into an infinite lock down (at least for what the UI is concerned). I would assume there is either a problem with the USB connection (cable) or USB stack (driver). But it could be also a hardware problem of the headset.

Do you have PVR Home option in the PiTool enabled or disabled?


Note that they also fixed some issues with USB initialization in the latest beta (PiTool 121).


I played around with the USB¡s and that seems to work now. One brilliant person will have to explain me how that can be possible. The unique USB port wich is working is one remote USB port on one the lateral of the PC case. I will leave the PC overnight to see if the non freezing condition is stable.
NEVERTHELESS, when I do start the PC, and the HMD starts I have strange 1 cm high band in the middle of the vision field whcih is quite strange. Whn I go to Pitool and i do reboot HMD, this artifac does disappear. But everytime i restart the PC, I have this artifact (and whatever the DP)


If you can identify which ports are connected to which chipsets may yeild some ideas what is going on.

Some usb chipsets are known to cause issues for vr headsets for a variety of reasons. I think @Raujok might have been one to mention that asmedia chipsets caused him to have issues related to usb ports & fixed his via an add on card.

Just too many chipsets out there. I was fortunate to have not gotten Asus Sabretooth 990fx board that they tried to implement pci-x v3.0 on Am3+ cpu. It failed to perform well. Luckily I didn’t waste money on that consumer beta.

1 Like

What about the artefact. Any idea ?

1 Like

Hard to say as would need more folks to weigh in. Comparing Gpus & psu quality. Preferably also having someone with a similar setup.

Software & hardware troubleshooting can be tricky.

I bought 3dmark & gifted it to a buddy. When I popped over to see him I installed 3dmark. He had dismantled his 3 monitor setup & move his pc to the living room with 1 of the 3 monitors (they were mismatched).

Gary’s Mod ran fine. But 3dmark & a few other programs produced video corruption similar to a failing/failed gpu. I tried everything I could think of to try & fix.

What fixed it was rehooking it up to the 3 monitors. In this case it was due to w10 changed how it dealt with Multimonitor displays & would apply scaling to the monitors to keep ratios looking the same accross unmatched displays. Since he hadn’t disabled the displays it hid this annoying scaling. Was not a happy camper after spending a couple of hours trying to debug it. :beers::dizzy_face::+1::sparkles:

This is why PCs can be quite aggravating at times compared to limited consoles.

Is it a red USB port? Apparently those will continue to provide power even when the PC is turned off.

1 Like

Nope, it is a blue one… I will look at the motherboard chipsets, as suggest by @Heliosurge

Nevertheless, I have not found a solution to the artefact in the HMD as described above. the only solution is a reboot. Should I downgrade the firmware ??

After a few hours, the PC did freeze again. I have switched to a red USB por, let’s see whats happening

1 Like

The red USB seems to have done the trick