Overall image fine but all floating menus completely blurry!?

Well, this is a strange one. When in Steam VR Home, everything but the floating menus look fine. With floating menus I mean fpsVR, the Home menu, the Preview-image when you launch a game etc…Those floating menus are a complete blurry mess! I am currently on PiTool 264 Beta.

Any idea?

That would be the compositor scaling its render resolution in accordance with the results from a benchmark it runs every time you start SteamVR.

It keeps a record of the last ten sessions, as the keys: “gpuSpeed0” to “gpuSpeed9”, in your steamvr.vrsettings file, and use the average of these to calculate a scaling factor for use with the current one.

You can edit these to, let’s say 9999, to trick SteamVR into believing you have an insanely fast machine, which will make the scaling factor the maximum of I believe 1.5. (EDIT: Keep in mind that your spoofed values will be queued out one by one, every time you start SteamVR, and so need to be replenished.)

If you are using the Pimax Experience application, that was included with the latest PiTool distro, it can make this edit for you, automatically.


Are you using SteamVR beta 1.15.1?
In my case, the SteamVR menu is now displayed in low resolution after the update (I’ve edited steamvr.vrsettings, of course).
It seems to be some kind of spec change or a bug.

1 Like

This is exactly what I did when I set up my 8KX for the first time. I gave “gpuSpeed” 1-9 a value of 2000 and the gpuSpeedRenderTargetScale a value of 1.5. Also, I set the Steam Render Resolution to 1.5 (PiTool 1.0). Then I set the steamvr.vrsettings-file to “Read Only”, so the values won’t be overwritten every time. With these settings, everything was running fine.

Yesterday, I wanted to give the new Beta (including Pimax Experience) a try but unfortunately, I couldn’t change any settings in Pimax Experience. Maybe I forgot to make steamvr.vrsettings editable again before trying to fiddle with Pimax Experience (not very likely as I couldn’t change any settings in Pimax Experience even those that have nothing to do with steamvr.vrsettings). Exactly at this point the issue with the blurry menus appeared. I then switched back to Beta but the blurry menus are still there.

Since I didn’t change anything in steamvr.vrsettings as this file is “read only” since I first customized it when I did the setup for my 8KX, how could it be explained that the compositor scaling changed? My steamvr.vrsettings file still looks exactly the same like before. Any idea which value needs to be modified to get rid of the “wrong” compositor scaling? All the gpuSpeed values are still set to 2000 and the gpuSpeedRenderTargetScale is still set to 1.5.

Ah… I am at a loss, then.

Just speculating here, but: If you didn’t had one before, I imagine the situation could be such that PE added a SteamVR vrsettings file to your Windows user/appdata hierarchy, whose values override namesakes in the global one from the Steam installation location…

SteamVR also recently added an Overlay Render Quality setting to the Video section of its settings, but I frankly have no idea what that does, exactly. :7

Just jumped into VR after a reboot, and it seems I have now caught the affliction, too. :7
Looks like utterly regardless of what the gpuSpeed numbers are, gpuSpeedTargetRenderScale ends up 0.08, for some reason. :7

Just wanted to inform everyone, that the new SteamVR Beta 1.15.11 fixes the compositor scale issue, where floating windows in Steam VR Home (Steam Menu, fpsVR etc.) look extremely blurry. It’s even mentioned in the patch notes.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.