Option in pitool for switching off headset after booting

The newer pimax headsets are USB-powered, which normally means that they are always plugged in. This in turn means that they are switched on after the PC and pitool has started up. For people like me who don’t have a pure VR gaming PC, this is annoying: you always have to remember to switch off the headset after booting the PC…

I would like to have an option in pitool that enables the headset to be switched off after booting the PC/ pitool.

4 Likes

This has been pointed out before, but there has been no official response to it.

I figure it might not be possible for them to control this via a firmware update or they just don’t think it’s enough of an issue to address.

Not sure if You’re aware but if You configure the USB ports to be always on in the BIOS, the headset will stay in the standby state.

You can also keep it in standby by using a powered USB hub.

5 Likes

…but it should be defenitely possible with the drivers/pitool. Of course it would be required to start pitool when booting.

so you would have the power supply again that you saved before :wink:

Just hang the USB 2.0 port on a cell phone charger and that’s it. :see_no_evil:

Please explain how You know that?

I mean, I personally don’t know which components are inside the 8KX and thus don’t know what is configurable… :upside_down_face:

Basically, yes… :wink:

2 Likes

Total nonsense, it doesn’t work! If you are the “dstar” who is also on the German VRForum, then you should know why!

if you haven’t installed any pimax software, the HMD is in the standby state after booting the PC. The logical conclusion ist, that software is able to control wheather the HMD is in the “on” or “standby” state.

1 Like

I haven’t tried that (I’ve had PiTool+services installed since receiving my 5K+), but that makes sense then… :wink:

Do not let Pitool to start with your PC, as without pitool HMD is black. Also unpick option in pitool that window just hide when you close it - it suppose to close.

When you want to play, start pitool. When you are done, close pitool. That´s it.

2 Likes

So that’s not the case with me - and I’m wondering why it’s the case with you. Because, even if pitool is not started when booting, drivers and processes will still start (piservice, pi_server, PiServiceLauncher)

Only when I uninstall the complete pimax software the HMD remains in standby after booting.

1 Like

I double-checked my settings, my pitool is set to start with administrator rights
(C:\Program Files\Pimax\Runtime/PiTool.exe - right click, check “start program as Administrator”).

Then in Pitool settings / general /

  • run pitool at windows startup =disabled!
  • hide to taskbar when you click the close button =disabled!
  • Home = close

I have pitool V1.0.1.270, firmware V2.1.255.296

3 Likes

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.