Ongoing connection issue 5K+

Hey guys haven’t posted in ages… been enjoying the 5K+ too much.

Anyway, I still have an issue that it takes me anywhere from 2 minutes to 15 minutes daily to get the headset to connect. It says disconnected with one of the many error codes.

Sometimes a PC restart fixes it, sometimes cycling the power on the headset fixes it, sometimes unplugging USB and HDMI fixes it, and sometimes powering on a steam controller fixes it. The odd time doing an end task on the piservice helps.

Is this happening to everyone? or maybe I have something conflicting?

I have an 8th gen CPU and board, with a 2080Ti. I keep my nvidia drivers bang up to date, and most system ones too.

When it works it works perfectly, just takes ten minutes usually…

Pitool version 1.01.121 currently. Newer one seemed to give me even more difficulty.

Any help appreciated, Even a good power up order or something would do.

1 Like

Here’s my power up order, hopefully it helps.

  1. Fully exit out of Steam.

  2. Check task manager >>> services >>> to make sure piservice launcher is running.

  3. Turn on the headset power and wait until the light is green.

  4. Open pitool.

  5. Open Steam.

  6. Start Steamvr.

2 Likes

For me i have no order sometime headset Before pitools sometime pitool Before headset, steam most off the time running Before turning on pitool or headset, dont have start with windows on anything. Have pitools home off. only i can Think off testing is a other usb port, like for me i use one on the side off my computer so its not getting hot air from case/gpu on it.

2 Likes

I used to have a fair bit of trouble getting my 8K to connect (and especially trying to connect to my (single) base station). The problem has improved a lot for me in the last month or so, due to (I think) new drivers and/or a replacement cable. I do think the .121 drivers are better than .129 in this regard. The situation has improved to the point where I’m not considering going back to .121.

On the off-chance it’s a connection problem, try plugging the USB portion of the Pimax cable into different USB slots, especially if you have a non-motherboard UDB port (via a plug-in USB board).

1 Like

Thanks guys will give these ideas a go.

I did also receive a replacement cable from Pimax recently, as I have intermittent sparkling screens. Haven’t plugged it in yet. Never considered that may help…

Just an update.

Pitool V1.01.132 has fixed all my connection issues. Happy days…

Thats great to hear mate. Sorry I totally missed this post!

Well you can still help as I spoke too soon… getting error 10935 everyday now, pressing diagnose just says unknown reasons.

Disconnecting both cables and re connecting sometimes fixes it, but then I get a new issue, where even though everything is working, the refresh rate in pitool under brainwarp drops from 90Hz down to 64.

So I switch to 90Hz, and now I’m back to error 10935!! infuriating.

Completely stuck in this loop now…

Go back to Pitool 129. Same firmware and stable even though beta

This could be caused by USB ports being underpowered or going in some kind of “power saving” mode. Try disabling all power saving for USB, both in BIOS and also in WIndows settings.

You were right, V129 connected immediately and reconnected even when i switched to 90Hz.

That said, 132 did that at first… Let’s see what happens.

Cheers.

2 Likes