Oculus Games Won't Work from PiTool

I am unable to play Oculus games with Pimax. When I launch Edge of Nowhere from the Pitool, the game opens up, goes black, and then stops responding.

I haven’t the slightest clue on how to approach this. I’ve reinstalled Oculus Rift software. I’ve reinstalled the latest PiTool. I’ve re-installed the game. I’ve changed all PiTool settings to random values hoping something would work. I’ve restarted the computer.

After 6 hours of troubleshooting, I’m starting to think that Oculus content is a waste of time. Steam VR content works perfectly fine; I don’t know why anything from Oculus is an absolute headache, which is a shame because they have a ton of exclusive games that I would like to try.

I manage to currently run all Oculus games through PiTool.

But there are some nuances when the game starts as if, then a black screen appears and closes immediately.

In my case, the problem was solved by reducing FOV to “Normal” or reducing the rendering scale. (1.0). Maybe it will help you.

(At least I could not have started LuckyTales through “PiTool” a couple of days ago. But having reduced the FOV to “Normal” I was able to run it :beer: )


Are you able to test the title he mentioned?

Unfortunately, I do not have this game … (but I already thought that I would never be able to run LuckyTales through PiTool, but it happened suddenly (with only normal FOV). Similarly, other games did not start with high rendering 1.5 and large FOV, and when reduced to 1.0 was launching :beers: : )

In the future I will definitely try “Edge of Nowhere”, this game is also interesting to me.


Indeed. I know some games in steam will crash if FoV too high. Might even need small FoV for some.

1 Like

I’ve tried Small, Normal, and Large FoV at 0.5 and 1 for Rendering.
Are some games just completely incompatible with Pimax?

1 Like

What is your GPU and CPU?

And does Lucky Tales run? Try it, it’s free… :roll_eyes:

By the way, have you tried running Edge of Nowhere with SteamVR? (not directly from PiTool)

1 Like

Have you checked Edge of Nowhere & Oculus log files for crash info?

Long ago now some Oculus games would look for Oculus Camera to prevent running on non oculus headsets. I think @jonnypanic had found a work around involving a ps3 camera but not sure.

1 Like

So I’ve made progress. I downloaded and installed Revive and ran Edge of Nowhere from that. It actually launched this time, but it looks graphically horrible and super stretched looking. I’m going to reduce FoV to see if that helps.


What I don’t like about running Oculus games through SteamVR and Revive is that there is a terrible delay … (therefore, I run all Oculus games only through PiToool, there is no delay)

1 Like

Would it matter if Oculus Rift software was installed on a different drive than PiTool?
Due to Oculus Rift still not being compatible with Dynamic Disk for god knows what reason, I had to install it on my D drive.

As for Revive, I can’t get that to work correctly. I’m able to launch the game, but it’s not tracking the headset at all on top of a huge delay.

My GPU is a 2080 TI, CPU i7-6850K 6x Core 3.6GHz

1 Like

I have Oculus software installed on the “C” drive (where PiTool is).
The directory with installed Oculus games has always been on another “D” disk.

I have it pretty much the reverse. Oculus software on D drive, Oculus games on C drive.
The reason being, if I need to install the Oculus software on C, then I would need to reformat all of my system partitions.

1 Like

Yes, an interesting situation, not faced with this yet :grin:

For the sake of interest and comparison, you can try the possibility of running other Oculus games (for example, Lucky’s Tale) to see if there is any influence from the drive installation.
(In my case (1080ti + 8600K), Lucky’s Tale works only with “Normal FOV”, directly from PiTool.)


Looks like this is a Edge of Nowhere only issue. I was able to launch Power Solitare form the PiTool with no problems.


Yes, it’s sad … after all, it’s a great game, judging by the reviews.

(in general, all oculus exclusives are pretty good and of high quality)

Here @Skyrimer tried it, also dissatisfied with the quality:


I finished Efge of Nowhere with the Pimax and I wouldn’t call it a great game, it’s an average third person game with ps3 graphics at best and repetitive gameplay, story is good but it would be a mediocre game in 2d, however in VR it gets extra points for immersion.


Fine! So you set it up for a comfortable walkthrough :slight_smile:


Oculus games I can run in Pimax

Island 359
A-Tech Cybernetic
Arizona Sushine
Lone Echo
In Death
Robo Recall
From Other Suns
PimBall FX VR
Guns and Stories

Games that don’t work (last I checked)
The Climb

These are all I have checked so far. Because they run doesn’t mean I play all of them in the Pimax. I prefer to play Arizona Sunshine, Robo Recall and In Death in my Rift because Vive wands are crap. A couple of others may also have controller limitations but I only confirm they load and work. When I get gen 2 controllers this will change,

Even a non Rift title like Alien Isolation, I play on Rift because the wands are too fast in locomotion (especially turning) for my liking. ymmv