No more 64 Hz option in last Pitool?

Hello, I have the last firmware and pitool, I have the 144hz to 72Hz option in pitool, but no more 64Hz.
It is needed for DCS, as its very low fps makes 32 Hz a better target for smart smoothing. 36 fps are a bit high for DCS, so in some cases it breaks fluidity.
Am I thé only one to have problem ?
The “old” version sith menu provide the 64 hz, but I have stuttering with them.

The refresh limits are offered by the firmware and PiTool just displays that list. Try installing an earlier firmware with the “standalone” update tool. Instructions are in this forum, just do a search.

but why did I still have the option with an older Pitool (253) that provide a menu for frequency instead of check boxes ?
It should also be linked to Pittol only displaying 4 top requency…
Unfortunately the 253 gives me stutters…

I installed the most recent pitool yesterday and have a 5k+ starting with 203:

1 Like

Thanks. I have 144 Hz, 120 Hz, 90 and 72. For me that’s because they handled only 4 frequency in the Pitool GUI…
I will downgrade my firmware, as SS is only handling 1 frame on 2 frequency above 72 Hz are useless.

Ah, they appear to have changed the UI. That used to be a dropdown list. Pimax should change the UI back to using a dropdown or add more radio buttons.

1 Like

They need to change it back to drop down. I down graded me fw due to the missing 64hz. Don’t get these let’s use up all the space for no reason design choices

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.