New PiTool 1.0.1.255 Released!

Ouch that’s quite a lot. I want to upgrade to this from 180, but I hope I won’t lose that much performance…

2 Likes

good luck Mate! Hope all goes well for you.

1 Like

Thanks I hope you get it back with 254!

1 Like

This sounds strange. I really do not see any micro-stutters. What refreshrate are you running at, and what games? Maybe you are simply pushing the GPU too much and get a low fps?

I still havent compared the vertical FOV between versions, but its nothing Ive noticed at least. Will investigate this though.

Wow that sounds like a huge decrease in framerate, very odd. Let me do some tests and comparisons. The Alpha 254 was already running maybe 5-10fps better than the more stable Alpha 253. But how is the new 255 compared to the previous stable 253?

Yep, same experience here, even on both my laptops :slight_smile: Lets investigate the performance now…

Nope, the team is still elaborating with the backlight brightness option. And some refreshrate modes.

The options enables and disables the automatic screensaver and stand-by modes that kicks in after a few minutes when headset is not in use (not moved at all).

The screensaver turns the panels black after 3 minutes I think. To prevent burn-ins (yes even LCDs can get burn-ins if a static image is shown for a day or two in a row.

The stand-by mode kicks in later, maybe after 5-6 minutes. It puts the GPU into a low-power mode, and limits the rendering to 15fps. Use fpsVR and you will see it kicking in after a while, when framerate goes down to 15fps.

Power-led will remain green. The headset never goes to sleep this way, it only saves the panels (screen saver) and also lowers the GPU usage (stand-by mode).

5 Likes

Nice, I’ll give it a try tonight, keeping my fingers crossed.

1 Like

great way to rule out viewport changes is to use handy tool by Risa: Hmdq - a new tool for an OpenVR headset (and other hw) introspection

2 Likes

Thanks. I am currently using High value with 5K XR, any idea what am I supposed to use on this one to keep image similar? Some people claim I can adjust Brightness sliders and it’ll do the same, is that true?

1 Like

I agree, I see it now too. >.>
Does someone here have 144? I don’t have access to my old version of it right now and I cannot find a link on this forum that works. Only one google link which links to a zip with password.

“5.Image blinking during application loading repaired.”

After short test found out that there is no more “flickering loading map screen” in IL 2 Sturmovik ! Bravo Pimax , I heard that other headset still some problems with that particular issue.

Also good improvement with fast LH/Pimax weak up in PT . Nice !

I have not experienced frequent micro stutter like others folks before this version but looks like Pimax did some optimization . So far very stable version and imho the best over a year.

7 Likes

>older pitools download<

8 Likes

Thank you kzzyn! This helps

1 Like

So i loaded up my fave Dirt Rally 2 with the exact same settings and track I use in 249. I run DR2 with No Smart Smoothing, Normal fov 72Hz and SVR customs settings for DR2 at video 70% and ALL re-projection OFF. With 249 I can maintain 72 fps solid and total smoothness.
With 255 I lose between 4 to 8 fps and is enough to induce stutter at that framerate. Not smooth. Both clean installs, Returned to 249.

4 Likes

Have you double checked steamvr resolution and fov between versions?
I have execaly the same fps when using the same resolutions in steamvr. But looks like 255 indicated some minor changes in resolution given to steamvr.

Also try to disable “stand by mode” in 255. Let me know please what fps are after that. I have 5k+ 204 right now so cant switch to 72 hz mode.

5 Likes

I always use fov Normal. The SVR res is at 70%. Will check the actual numbers to see if they change between versions and get back to you. Will check standby mode too.

3 Likes

Could the stutter some users are reporting, be possibly affected by the following?

A] Pi Tool settings are set too high, and/or Steam settings are too high for GPU/PC hardware.

Or other glitches might occur due to wide ranging other factors such as…

B]

GPU Manufacturer specific problem due to Nvidia/AMD drivers
GPU Memory [6GB, 8GB 12GB Graphics cards]
CPU Core number [4 core, 6 core, 8 core and above]
CPU Speed [4ghz or below, 4ghz or above, 5ghz and above]
RAM Speed or amount [8GB vs 16GB vs 32GB memory modules]
Hard Disk speed [Mechanical Vs SSD Vs NVME]

For all we know it could be something basic like the majority of users with stutter all have 1080 Ti or ‘only’ 16 GB 3000mhz memory, or have an RTX 2070 with insufficient bandwidth for the quality settings chosen.

Or none of these at all.

6 Likes

is this beta or final version?

Well after a very brief testing on SteamVR Home I can happily say that it appears to be fixed for me. I think that during 5 minutes or so I only had what appeared to be 1 single stutter, but that could have been anything. It’s still early but I can dream on getting back to VR after a long wait, great job Pimax team!

Perhaps the only con is that I had a few problems detecting the HMD. At first I left the HMD in the floor and when I went back the image was broken, with a blue and black screen divided vertically with a thin line or something like that and had to turn it off. The when turning it on the HMD showed up but the LHs couldn’t detect it. After resetting the computer I still had issues detecting the LHs, but after several tries PiTool found the HMD. Then one curious thing is that after turning it off, it appeared as connected for maybe a minute, until it finally showed as disconnected.

I can’t say if this was a one time thing or could be more of an issue, I will have to test more, however I’m extremely happy with what appears to be a fix for the stutter. Even if I had connection issues, I would be at the same point than with 144, since those happened with that version too.

3 Likes

So happy to say the stutter / judder has gone but at 72hz there’s mico stutters happening and there seems to be a 5-10fps drop in performance for me. Think i’ll go back to .249 for now and put up with the judder. Hopefully this gets fixed completly before my 8KX arrives.

1 Like

first thing they need to do in elite dangerous is a pre-processing antialiasing to get rid of those bad jaggies that are impossible to remove with a post processing AA.
i see aliasing even on my 2k desktop with a 2* supersampling while on many (most?) other modern games there’s no need to supersampling because they use modern AA techniques.
And i’m talking about desktop games too, vr just amplify the problem.

just to make an example, in ED if you have a neon light on the distance that has an angle that is near to horizontal, you’ll see the neon moving left to right like Knight Rider car , that is because the rendering engine finds the neon on that particular pixel depending on inclination, so little changes will make the neon move. YOU CANT REMOVE/FIX THAT NEON WITH FXAA OR SMAA, nor with SS

Using a pre-processing antialiasing will tell the rendering engine that there’s a neon there, but as it’s far instead of precisely rendering the scene, it will approximate it smoothing it a bit ad you’ll get a much stable image without pixel moving all around the hmd.

Sormland, just to name one, has zero aliasing, and it’s well calibrated, even far things are sharp, they did a great job with AA, Elite Dangerous hasn’t done nothing to their engine in order to optimize it for HMD and while that can be acceptable in 2015 is not acceptable anymore in 2020, if they want people to keep playing it they have to improve their engine radically.

ED will always suck no matter wich res you’ll have on your hmd

3 Likes

I did a 2nd clean install. Res is identical with 249 and 255. FPS loss of 2 to 8 fps under exact same conditions still the same as before.
Standby was off by default.
My average fps in 249 is 71.9 and dipped as low as 69 in the woods :grinning:
With 255 average was 70 but as low as 64 without the woods.
Micro stutter because of large fps dip.

1 Like