New Pitool (beta) is available now

Dear Futurists,

The new Pitool is available for public beta and it is available for download now.

Release Notes:

New Features:

    1. New firmware with 120Hz mode for Pimax 5K+;
      –True 120Hz refresh rate, works with small FOV.
    1. Color selection for the front “chevron” light.
      –Switch between 3 colors: Green, Blue, Aquamarine.
      More colors will be added soon.


    1. Physical resolution reduction
      –The adaptive physical limitation of panel pixel area utilization when FOV is reduced. Approx 10% performance / framerate increase in VR.

Yours sincerely
Pimax Team


Thanks…! :slight_smile:


What about jittering of Does it fixed?


Was back-light fixed, also what’s the point in reducing the resolution? If your computer is index compatible then you should be able to run it just fine. That shouldn’t be considered an improvement. I’m pretty sure most people would rather have resolution.

1 Like

What is not mentioned in release note has not been solved yet.


Wow! 120hz!

That’s pretty awesome. Too bad the FoV couldn’t be a little wider. :-\

Time for a 5k+120 that supports all the FoV’s?

And Pimax,

Have you been researching LCD’s that are better than the ones being used now?

And don’t forget the lenses! I know it can be expensive, but a better lens to eliminate the distortion on the edges can go a long way in making a better product.

How much resolution was taken away?

As I understood it nothing is taken away. You still can choose between small, normal and large FoV. The new thing now is that you can select 120 Hz for small FoV.

Time for a 5k+120 that supports all the FoV’s?

This is a long-term goal that the development team is working towards.

Have you been researching LCD’s that are better than the ones being used now?

I haven’t got the update yet.


I have the new version installed and working, successful firmware update and I can change chevron colors… but my refresh rates are still 64/72/90 with no 120hz option.

Do you have any troubleshooting steps for me to try?

Thank you


Reboot the headset and PC?

I have the same problem. I tried installing the latest Nvidia driver + rebooted a couple times but still no 120 Hz option :frowning:

Edit 1: Headset Firmware: V2.1.255.244

Mainly when FOV is reduced, panel pixel area utilization adapts and VR performance is increased.


Maybe you’re trying to restart pitool or PC?


It’s a big shame if the frame hang bug (introduced alongside attempts at higher graphics card utilisation) isn’t fixed. That locked me, and a decent subset of users, from using 180, for many months, and now would lock us out of 197 as well. Which for me also means no trackers :frowning:

Can’t test atm away for work but hope that is an oversight and it does actually work now!

Can someone confirm there is no more FFR?


Like I said then the only thing that needs to be fixed is the backlight brightness. It’s not working at all. Otherwise it’s perfect! Nice job.

I do have FFR (but no 120 Hz mode)

1 Like

They are optimizing the pixels that have to be rendered, not removing what you actually see. If not familiar
search for @risa2000 post, he explained and visualized it very nicely.

So in short, since unneeded calculations are reduced and FPS increased and visually nothing is left behind I would count it as an advancement.
Edit: added this link:


Ok thank you.
Reinstalling gpu drivers and stuff then.

1 Like