New Pimax 8K X not connecting to my machine, white light on all firmware

(Posted similar in a reply at before I was able to create a new topic)

This issue is similar but not the same as as I’m using a desktop PC (not a laptop) and direct DisplayPort cable (not an adapter).

I’ve spent at least 7 hours looking through multiple forums, reddit posts, and troubleshooting docs on the official site and have got nowhere. I’ve also created a ticket and have provided SN and Pitool log.

I have a new Pimax 8K X, first time plugging it in I was greeted with the “DP not connect” issue, did a quick google and found that it was an issue with old firmware. So I flashed to the 8KX firmware on the site ( which left me with a white LED and no USB connection, with Windows saying it’s an unrecognized device and couldn’t install the drivers.

After trying out many different firmwares linked to on forum posts and on reddit, I’m still in the same position. The only firmware which gets me back to the “displayport not connected” issue is P2_DEBUG_M270_t20210107171555_r99ad675 but then I do get Pitool telling me to update (which fails).

I’ve also tried replugging the cable going into the HMD, uninstalling my graphics drivers in safe mode as well as Pitool then reinstalling, reinstalling my USB controller drivers on the motherboard.

CPU: 12700K
GPU: RTX 3090 (latest drivers)
Pitool version: (have also tried 272)

Firmware tried:

  • P2_RELEASE_8KX_M296
  • P2_RELEASE_8KX_M299_t20210922093742_r6066b70
  • P2_DEBUG_8KX_M299_t20210922093913_r6066b70
  • P2_DEBUG_8KX_M299_t20211101115020_r85cdd55_forEnableHDCP
  • P2_8KX_M298_EngineerTest
  • P2_DEBUG_M270_t20210107171555_r99ad675 (this gets me back to DP not connected issue but with Pitool telling me to update, which fails)

I didn’t take a note of the original firmware on the device when I received it as I didn’t think I’d need to :sweat_smile:
Also, the SN sticker is very faded which doesn’t fill me with much confidence that this is a brand new device.

If anyone can give any advice or help whilst I wait for replies from support, that would be fantastic and much appreciated.


Would be fantastic if someone can send me the correct firmware. I’m getting nowhere on my own.

1 Like

I’ve managed to get it working with the 90hz only option by using the firmware from this Reddit comment as well as making sure my main monitor has it’s 240hz option disabled.

I have to fiddle around with the order of plugging in the USB and DP cables once the PC has booted up, usually unplugging all 3 cables before turning the PC on and then once I’ve opened Pitool I plug in both USBs and then the DP, but as of right now I have it working at 90hz.

If left to go on standby it’ll freeze my PC where I can’t use any peripherals and must do a hard restart.
From the hour I’ve had on it, I’ve got to be honest, I’ve not been overly impressed with the visuals anyway. The FOV is nice but IMO not groundbreaking, and the effort it takes to get it up and running far outweighs any visual pros the HMD may have.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.