Lost of tracking with Pimax, but everything is perfect with my old vive!


My controllers (both valve index or vice wands) are loosing tracking.

I tried to upgrade/downgrade pitool, but it still loosing tracking.

And I retried with my old HTC vive… tracking is perfect !!!

So I have the proof the Pimax got serious issues with lost of tracking.

I always felt strange with the pimax on room scale experiences and thought it was laggy due to performance issues but absolutely not. I spent time these days to test a lot and the issue is clearly with loose of tracking.

I can clearly see the controller diseapear in steamVR home in some positions. And with the New Valve Index controllers it is even more noticeable because of finger tracking lost.

With my old vive, very same lighthouse position, it is perfect, not lost of tracking in any positions.

I am fear that this issue might be an hardware issue.

Do you have similar issues ? have you been able to solve it ?


You should get in contact with support.

They might need to tweak something on Your headset. I know they have solved tracking issues for people before via TeamViewer.

@Doman.Chen might be able to help but You should probably create a ticket first.