Lone Echo 2 = Extremely Poor Performance

Just a suggestion. Try an older version of Pitool. I noted that for some reason LoneEcho 2 runs at 80% GPU usage on newer versions of Pitool.

I really can’t use a much older version, or I already would be in order to disable the 1/3 smoothing rate. My HMD is not detected by much older versions. I also had WAY too many issues with multiple PiTool versions in the past and ended up with a complete clean install to get things working correctly again. That doesn’t sound too bad until you understand that I heavily mod and tweak many games. Even with a dedicated drive for the OS it can take a week of rebuilding to get all my games into the proper states once I have to truly rebuild things. From what I’m seeing now that I’m researching it, the poor performance of LE2 is a widely known quantity. It’s great that you have it working well, but you may be the exception rather than the rule. At 100% SS and will all quality settings at minimum except textures and medium, I can usually maintain 60fps. Of course, at those settings, it looks much worse than LE1.

I had an awesome experience with this game with my varjo aero :slight_smile:
The best vr experience actually

FYI mbucchia just let me know he may have an idea for setting thresholds for the motion smoothing rates. Super excited!

2 Likes

Which was ???

No literally he’s a dev, that is to say he may make it a part of his PimaxXR software, such that you (or at least he) can control 1:3 and 1:2 motion smoothing and the FPS thresholds at which it engages. Maybe this is a little more related to Something changed with Pitool on version .271 and forward

@DJSlanr The max GPU usage appears to be linked to the FOV selected. At Normal FOV I’ll peak at 90% GPU usage, no matter what settings I use. At Small FOV I’ll peak at 80% GPU usage, no matter what settings I use. I can increase the in-game SS until I’m dropping frames like crazy, but GPU usage will not exceed those amounts. Weird. I thought it might be the in-game automatic resolution function, but this happens regardless of whether that is on or off.

1 Like

All this ocurrs with Asgards Wrath for me as well. Provably a grame timing issue that piserver handles incorrectly.

I will agree that both LE1 and LE2 are fantastic games; it’s just a real shame that LE2’s performance is so woeful in comparison. It ultimately makes LE2 look worse than LE1, since the quality has to be reduced so greatly to achieve acceptable performance.

Elite dangerous is the other thorn in my side. Found a way to run without PP in oculus mode, but it performed worse. Presumably due to oculus runtime itself?

Well, Elite’s “Odyssey” incarnation too conferred a significant performance hit. :7

I think they rewrote all the shaders, also prompting much complaining about stuff, including paid cosmetics, looking different than before. :7

I stubbornly stick with my guess that “Oculus mode” forces PP on, without the user’s knowing.

1 Like

I had been so excited for Odyssey. I’ve grown up with David Braben’s Elite. Loved Horizons. Odyssey promised: Atmospheres, new graphics, get out of your ship. Couldn’t have been more excited! Then they BORKED VR

The fact that stereo vision works perfectly fine in the vanity camera, when on-foot, but with all interaction and HUD disabled, just rubs salt into the wound. Especially when you go back from it, to the virtual movie screen, and the downgrade smacks you in the face. :confused:

1 Like

I still enjoy Horizons, as my graphics/gpu get better I still hope to see less aliasing, maybe greater fps to go with higher regresh rates…and eventually I can play Odyssey with clarity/performance too. Maybe Luke Ross can fix Odyssey

So hello there

you could try this

this gave me 20 fps in green hell and high from medium, works with many games, not sure it does with le2 , it works with unity and unreal engine, afaik just be sure to read the readme and place the dll and the config right.
It can also be found in these forums im not sure where atm.

so cudos and good luck, i got to play that one next !

It works for steamvr games only. But it also has FFR, which was another thing I could use to boost frames in Elite Dangerous. Sadly not so for Oculus games.

Openvr_fsr has been superseded by vrperfkit, which works with both SteamVR and Oculus – just follow the same github link, and check fholger’s other projects.

It injects through trojanhorseing dxgi.dll, instead openvr_api.gll.

1 Like

Yeah I forgot it does supposedly work with oculus, just not on Pimax last I checked.

Interestingly I just checked LE1 for GPU usage and it’s stuck at 80% max as well. Hope this eventually gets fixed.

i had poor performance in LE1, it was because the game was running in windowed mode, in the games settings you can change it to run full screen, worth a look.

1 Like