Launching ED from PiTool always launches Oculus Store too - why?

ED is not the Oculus version, so no idea why that happens. Other games so far are fine. Any suggestions why is this is being triggered or where the config is located?

As far as I know, this has happened since I installed the Oculus app to run Lone Echo.

I already have the Store set to not launch on Windows boot.

EDIT TLDR the problem is caused by the Oculus service running in the background. This affects Elite and DCS regardless of whether launched from PiTool or not. Stopping / disabling the service solves the problem

1 Like

This happens to me too, so I’m curious what the fix is.

1 Like

It’s possible that the commands to launch ED might be triggering it detecting Oculus. But don’t know.

I know I can launch games in Oculus mode without the Oculus store being installed.

1 Like

Right OK, how would you normally launch games in Oculus mode without the store? Maybe it’s something we can find and turn off for ED

1 Like

Just checked, DCS does the same, haven’t loaded it for quite a few months.

Actually DCS is worse, because it won’t let me run the non-VR version and it keeps auto-quitting the game after a few minutes. It continually tried to load both SteamVR and Oculus Store, even when I tell Steam I want to run the standard version.

I had to ensure 5k+ and PiTool not running otherwise it defaults to VR.

But even then, after a few minutes of browsing the 2D menu, it suddenly quits - Alt-F4 in effect. Never had that before, hmmm. Seems DCS is now ‘VR only’, weird…

1 Like

I think it was Everspace. If you launch it from Desktop steam drop down you can choose A variety of launch options.

Launch Game
Launch in VR Steam
Launch in VR Oculus

Some games require command line options - novr , -vr or -openvr

While some other games have this done via in game setting.

Park was changing some numbers in the steam ap id to get some programs launching in Oculus mode.

1 Like

DCS and ED may need there launch options. @Enopho @neal_white_iii @park @mirage335 may have some insights.

1 Like

Oh I see what you mean, unfortunately I think the Store launch is entirely unrelated.

Regarding the Steam launch options, for DCS I get this. I’m always choosing the first option, and ensuring my headset is off and PiTool is not running.


Regardless, SteamVR and Oculus Store launch anyway. I have found that the 2D version will not quit if I quickly get a mission up and running, but left in the menu, the game will quickly quit back to desktop.

I haven’t played DCS for some time, so unfortunately a number of changes eg Steam updates, installation of Oculus Store etc may be contributing to this new problem.

Edit to be clear, I am launching direct from Steam and NOT from PiTool in this example, because I am deliberately trying to load 2D today. I quit PiTool first as mentioned, otherwise the game will definitely launch in VR which I don’t want. In the original post, I am definitely launching ED from PiTool because I am launching the VR version.

1 Like

It is indeed Elite that launches the Oculus store, and not PiTool, and this has been going on for ages, with other headsets too.

The game supports both the Oculus runtime, and OpenVR (SteamVR), and pokes them at startup, to inquire whether there is anybody home – presumably Oculus first, before moving on to OpenVR if there was no Oculus headset connected (I had a Rift and a Vive connected at the same time, at some point in the past, and ED would launch on the Rift, then (…and I could play another game simultaneously on the Vive, on the same machine :9)).

The behaviour came with one past Oculus software update - I do not know whether it is because Oculus got more attention-craving back then, and launches the store despite a negative handshake response, for that reason, or because ED does not hang up the phone properly. :stuck_out_tongue:

You can stop “OVRService”, to prevent it, but may want to restart it, should you want to play something off the Oculus store. :7

( EDIT: Frontier really need to interest themselves more with VR, by the way; The openvr_api.dll they distribute with the game is from 2016. I tried a while ago to replace it with the most recent one, on the extreeeeemely slim desperate hope it would make the game magically behave itself with canted cameras, but I had of course no such luck. :7 )


Copy this text below into a text file and save as a name-what-ever-you-want.bat file
run it once and it will stop OVRService`s
run it again to re start it.

sc config OVRService start= demand

net start “OVRService”

if %errorlevel% == 2 net stop “OVRService”


Ah thanks both, yeah I’m going just going to disable the service I don’t need it running it all the time. It was silly of me to assume it would be stopped by default when the Store isn’t running :roll_eyes:

Frontier really need to interest themselves more with VR

Well sadly, things seem to be going in the opposite direction. They’ve dropped mention of VR support from their site. Seems to be a legacy feature now for them. And also since they confirmed they would not support canted lenses etc despite it being a high priority on the Issue Tracker. Ah well.

1 Like

Luckily, it does not matter much, how old this particular DLL is, as it is just a shim layer to load the real stuff (vrclient.dll), which is distributed with SteamVR.

1 Like

I believe it is Oculus service, which starts the Oculus Library (UI frontend) whenever an app tries to initialize Oculus runtime, without even knowing wheter or not it has a headset attached. I have been recently running some tests on my setup and saw exactly this behavior, just by launching my tool :wink:.


Yep certainly is, because I have never owned an Oculus headset :+1:

Edit note it’s not ED related, DCS World now does it as well, and I know of no relation to Oculus!

Edit 2 - with the Oculus service disabled, as expected the Store doesn’t launch with DCS. However SteamVR always launches even though I am asking for the 2D version only. That said, I believe this is a DCS issue that has always been present

1 Like

I am sure, but all calls still go through the api one, I take it? …or does it “hand over the phone receiver”, too? :stuck_out_tongue:

Just how much has the function library grown? If openvr_api.dll only passes calls on, and little else, I kind of wonder just what the difference between the 304kb of the 2016 build, and today’s 800kb constitutes… :7

I assume when Valve added the camera rotation bits, that was only a matter of them from then on being included in their slots in the relevant matrix/-ices that already came back from existing functions, making that pretty much a retroactive thing, as long as an application took them into account, rather than something like the old function remaining without, for legacy reasons (albeit deprecated), and a new superceeding one added (…or possibly the old one taking a version argument, or returning extended data of some sort)? ( Oh yes - how on earth could anyone tell I’m not a coder? :stuck_out_tongue_winking_eye: )

It’s dispiriting. :confused:
Adam Woods’ blank stare and slack jaw for a full second or two, there, back when somebody asked how a new feature (I think it was the FSS) was going to work in VR, before he collected himself… And of course when we got it, it came with hideous stereo issues that were immediate, and impossible to miss.

Hope to be surprised with VR-mindfulness for the end-of-year expansion, but by now I’m not holding my breath. :frowning:

1 Like

Am I the only one thinking they should probably look into those menu options?

  • “Launch SteamVR in Steam VR Mode” ?
  • “Launch OculusVR in Oculus VR Mode” ?
  • “Launch SteamVR for 2.5 in Steam VR Mode” ?



I do not know. Depends how Valve builds it. Maybe they changed the linking strategy or started to link something statically?

When you build an app against OpenVR, you are building it against a particular interface version (valid at the time of build). When Valve releases a new version of SteamVR (with potentially some new functionality) they increment the interface version and keep the old interface in the lib as well.

So when an old app starts SteamVR it uses an old interface (regardless whether you replace the libraries - either openvr_api.dll, or vrclient.dll), because the interface version is hardcoded in the app. An updated vrclient.dll could just get you the fixes if they are related to the old interfaces (and were backported to those).

Basically, you cannot make an app to use a new OpenVR interface without recompiling it against the new interface version.

1 Like

I got the chance to meet Adam, the other Adam (gameplay designer), Will, Dav, Johnny Watts, even Braben briefly - all a good bunch and and very smart, no question about it.

But yes VR was not really on their radar. I brought it up and whether they had tried a Pimax, but none of them seemed to know about Rifts or Vives, let alone Pimaxes, so sadly I’m not that surprised. How VR was included in the first place is a good question, somebody was a fan somewhere.

I would like a 2020 VR update from them of course, but more importantly and realistically, I really hope they are focusing on a thorough gameplay update. VR adds a huge amount of immersion, but it can’t solve the fundamentals…


Ha ha yes. The Oculus option is a new one. Having two SteamVR ones seem superfluous, but hey even the 2D option loads SteamVR anyway so that makes three :crazy_face:


Unfortunately, I feel both to be true. In 2014 (or whenever ED was released) VR was an exotic concept, but today, it is clear that VR is going to dominate simulators and ED is basically one of them. Plus, gameplay wise I fear FDev are clueless. I have already witnessed so many half-assed features in the game (engineers, wings, multi-roles) that I no longer believe it can be salvaged. It seems like no one really gets a grasp of what the fans want or how to actually make a game out of it and at the same time no one really cares.