Latest Pitool Beta, Index controllers decided to stop working, instead acts like "hand on a stick"

So ok, after solving the other issue with the mic, I started steamVR up again and for some reason, the index controllers were not being recognized as such. I had no control over finger tracking in Steam VR home, I couldn’t even select a game to play without holding the button to bring up the steam dashboard first where before I could easily point to a game to play from steam VR home and play it there. The controllers were tracked but none of the buttons and controller functions worked as it should have unless I was looking at the steam VR dashboard. From in a game it was just treated like generic vive controller.

The only change I can think of that I made in this time was trying to set up several games with individual settings under the new beta pitool. Funnily enough, it was working great at first and then I shut it down, and several hours later opened it back up only to see the “hand on a stick” that wasn’t recognized as an index controller by the games that require it (right now only the aperture hand labs and moondust demos).

I tried rebooting and restarting the headset and the service and steamVR multiple times to no avail and then it started making it like the controllers were not paired at all. If I tried to pair the two controllers at once it would only pair one of them and then falsely report the other had been paired when it had not.

I uninstalled and reinstalled the software hoping to clear out whatever bad mojo had built up and even went through the whole room setup process again and tried to pair the controllers again and again. Each time either I got “hand on a stick” or I got nothing and/or only one controller would stay paired.

Again, from the first install it worked great, and the only change I made other than shutting it down and starting it back up again later was to try to assign the most basic configurations to a few games (none of which I started up and none of which were even attempted to start up through Pitool)

I’m attempting to roll back to the previous pitool to see if that solves the issue but so far the last time I can remember it working well (but maybe not flawlessly) was when I was using the workaround method to use the controllers via the drivers from May.

Computer is Windows 10 Pro 64Bit, 1080Ti, Intel i7 4770K, 32GB of RAM, and I WAS on the newly released beta pitool with the separate sections for controllers, base stations and trackers on the main screen.

Ok, so an update: I have since reinstalled the last beta and gotten the hand tracking to work and see that steam recognizes that i’ve got index controllers instead of just a “C” in a hexagon shape. But it seems like works when it wants to and I have no idea why. I mean, I can come back after a reboot some hours later and it may or may not be working. I got it working now, but I don’t know how well it’ll be working later…

hmm… not encouraging considering I just ordered index controllers. Oh well I guess I still have my OG Vive.

I was able to get it working again by uninstalling and reinstalling it, but it seems like every once in a while, the hands are misplaced and don’t react to any of the finger tracking.

When that happens I have to turn the controllers off, wait a minute and turn them back on. I’m hoping when I get an Index that I can just skip all the fiddling with Pitool. I guess Pitool is great for those people invested in the Oculus store but I don’t care about it at all.

It sounds like a quite rare case, and Im happy to hear you found a way to get it solved. I must add though, that PiTool is very useful, and includes many options you wouldnt be able to adjust or enable/disable without it. The SteamVR settings alone are in my opinion way to simplified and limited.

Pitool is very useful, but I’d be happier if it worked right “out of the box”. I’m seeing a lot of posts on reddit where people are now selling their Pimax because the software is “janky”. If you need to translate this to your bosses, tell them that there are days when everything works ok, and there are days when nothing works and everything in between. Some days I spend 10 minutes trying to figure out what went wrong, some days I spend most of my gaming time trying to track down an issue.

I’ve bought an Index now and while I miss the FOV, I don’t miss all the software headaches and flip-flopping back and forth between the computer and the headset trying to restart programs, restart the whole computer, unplug and replug all the connections etc.

The Vive wasn’t perfect either back in 2016, but they got it under control pretty quickly. I would hope Pimax is doing the same.

Are they going to support OpenXR? Maybe this would help solve a lot of the issues since most of what I think I’m seeing is Pitool and SteamVR not agreeing on stuff. The most useful software in the world doesn’t help a bit when it doesn’t work properly with every other piece of software on the PC.

1 Like

I agree, the software should be getting weekly updates, not monthly and each version should improve the Quality of Life experience when using the software.

Eg, that drop down to choose your game , its not sorted correctly(wrong name) , cant be filtered.

I wish they would open source their software or at least provide an sdk so that we could access the functions and create our own software.

i could make a much better ui.