Index controller tracking issues. Never gonna be fixed?

The stuff I read here sometimes… The videos we posted of matthew playing beat saber with 2 sword controllers demonstrate there is no issue like one that you are describing. I’ve played around with them numerous times and they function like other controllers (i.e. index and htc vive etc.). Also the fact anyone can use 2 vive or 2 index controllers also debunks a claim like this one that there isn’t enough “bandwidth” - is just silly.

The only time we only had 1 side was just due to the team packing a box of samples from one side. Due to customs clearance it was hecktic at last years CES.

As for any issues with index controllers many people have reported that steam updates, index firmware updates and some of our own updates have made the issue extremely hard to even demonstrate.

That’s good to know, the fact that the 8KX reportedly has no tracking issues for some users with almost double the bandwidth requirements does shoot the insufficient headset cable bandwidth theory out of the window.

Ah okay, fair enough I’ve only seen a demo with one controller at a time.

If the tracking jitters issue on index controllers was fixed in software then why are people reportedly having issues with 8KX tracking?

Maybe there was tracking issues in the past caused by software which is fixed now, and if you have a good quality motherboard you have no issues with tracking. People who still have issues may very well have motherboards of insufficient quality which don’t meet bandwidth requirements, or compatibility issues with their motherboards.

ASUS Rog Strix Z390-E.

You wouldn’t have any VRM issues with that motherboard.

If @zoyer can share their motherboard we would have a better idea if the issue is caused by motherboards which don’t meet bandwidth requirements.

1 Like

Sorry forgot to link. It’s been going on for a while. People have solved it with Steam USB dongles but that shouldn’t be necessary?

@Alex.liu was in contact with steam but not sure what happened after that.

2 Likes

that’s my setup, not sure if everyone missed/forgot about that topic we made.

1 Like

The extra dongle fix isn’t necessary for some people.

Z370 and z390 both have 24 PCI lanes so it shouldn’t be a lane problem.

Having a Google it appears that the difference between z390 and z370 is lack of USB 3.1 support on z370. Could that be the cause of a bandwidth limitation on z370 motherboards which cause the tracking jitter issue?

“The two biggest differences between Z370 and Z390 are built-in USB 3.1 Gen 2 (10Gbps) and WiFi 802.11ac support. … Given the similarity in features and support for the same CPUs - Intel’s 8th and 9th generation of the mainstream Core processors - the Z390 chipset is mostly just an updated version of Z370 .”

USB 3.0 only has a transfer speed of 5gbps, which is half the theoretical limit of bandwidth compared to USB 3.1

1 Like

I counter it with this post :smiley:

4 Likes

don’t play an uno reverse card pls :,D

1 Like

maybe @Alex.liu could step in and solve this issue for good

Honestly I’m all out of ideas. I was going to suggest that it could even be an AIB specific compatibility issue which affects certain motherboards but seeing as Gigabyte motherboards are affected as well and they’re some of the highest quality motherboards in production I doubt that highly.

One time I RMA’d a Gigabyte motherboard and it was returned to me with a post it note with an arrow pointing to a spot where my cat peed on the motherboard. The fact they had the time to meticulously analyse the board told me they clearly don’t get many RMA requests and their products don’t fail often if they have the time to do that :rofl:

5 Likes

haha :joy:
well i’m just a bit moody because I thought by now it would have been fixed or there would be any statements from alex or the pimax team. If it’s because the old pimax headsets have a worse reciever or something then I suppose this issue will never be solved publicly :male_detective:

1 Like

Just reading this post and seeing that there’s no problems when one controller is plugged into the headset. This could mean that there’s a wireless data parsing issue, there’s two steamVR tracking dongles in Index and Vive headsets and I’d assume that Pimax also has two internally inside the headset. I don’t know though if Pimax headsets have two internal dongles or just one

There might be other people in your house using wireless.
Have you tried to isolate yourself from all wireless signals and turn all the wifi generating devices off to rule out wireless interference being the cause of the tracking issues?

2 Likes

Yeah one of the 2? 3? times i sent back my index controllers they asked me to shutdown my wifi, fridge and more. So that has been taken care of. Also 1 time hanged sheets around my play area so there would be 0 reflections.

Too bad I can’t post the important parts of my conversations with the steam support since the logs get removed after 60 days

1 Like

It could be that the person who has a z390 motherboard has wireless interference problems but your tracking issues are caused by the bandwidth limitation of USB 3.0 vs USB 3.1.

You should still be able to solve the issue by purchasing a seperate steamVR tracking dongle and sending half the tracking data into a seperate USB port.

The fact the z390 guys controllers work when one controller is connected to the headset with a USB-C cable indicates he could be experiencing wireless interference.

If plugging one controller via USB-C into the headset doesn’t resolve the tracking issue for you like it did for him, then I think I’m right and your bottleneck is the USB 3.0 5gbps transfer speed limitation of z370 boards.

I plugged to usb c as well and it was perfect. had vive controllers earlier they worked really well but guess they aren’t as needy as the index controllers

1 Like

Ok so if it’s not caused by

USB 3.0 bandwidth limitation

If it’s not wireless interference if you’ve tried the steps to isolate that problem

It can’t be an issue due to insufficient PCI lanes as z390 and z370 both have 24 PCI lanes.

It’s not an AMD related CPU problem as both you and the guy you mentioned have Intel CPUs

  1. Have you tried using other USB ports on your motherboard?

  2. Have you unplugged all other unnecessary and unused USB devices before testing which could be eating up bandwidth?

Failing that, I think you should just buy a steamVR dongle as that’s a proven fix.

Yeah vive controllers are not a good comparison and it’s a false equivalency as they don’t send nearly as much tracking data or haptic data, remember the Index controllers have finger tracking and capacitive touch sensor data which has to be transmitted, the Vive controllers don’t transmit that information.

yep done all that.

Just feels like if I buy a steamvr dongle it’s like i’m accepting that they messed up (if it’s a pimax problem). I wouldn’t have bought the index controllers if it said that some or early headsets would have tracking problems with the controllers. That’s pretty much what they’re hoping for :slight_smile: (I’ve had my share of dealing with the support, gotten to know them well :upside_down_face:).

1 Like