Index Controller loose tracking with Pimax 5K+

There are several V1 users in the bug report thread.

2 Likes

Glad to see this thread to know that it’s not just me! My left Index controller keeps glitching in Alyx too. I just got them, so I haven’t tried anything else to know if it’s in this game only, but doubt it. V1 basestations. I don’t recall ever having this issue with Vive controllers.

Yes, I did notice this too.

Add your info to the bug report

1 Like

I have got the same problem, always with my right controller. It was annoying but in Half Life Alyx it’s more than annoying!

1 Like

I have got the problem not only in Alyx but also in Beat Saber and SteamVR home…
(I have an 8k)

Hey Arno,

Please fill in the information from the top post of this thread:

Thank you :slight_smile:

3 Likes

same issue here on HL:Alyx, left controller is jumpy or vanishes momentarily.

1 Like

try 253, it worked wonders for me.

Unintentional Rhyme.

6 Likes

You’re a poet and didn’t know it :smiley:

4 Likes

I had glitches too but my BS are awkwardly placed so I figured that would be part of the reason.

Gonna relocated the BS to see if that fixes it. Never had issues with the wands though.

I half assed my placement at first and it worked with the wands. Figured that was the issue and perfectly aligned the stations, but that didn’t fix it. The only thing that works for me is a single controller hooked up to the HMD via usb c to usb c. It looks outrageous, and I’ve strain relieved both ends around the controller and headstrap to avoid damaging connections. But tbh, its pretty comftorable and out of the way once im in VR and the tracking rules. For now I’ll patiently wait while I replay half life alyx for the 3rd time-

maybe this could help

1 Like

Yeah, not gonna go tethering just yet. Pimax needs to just fix this issue

2 Likes

Agreed, I have already offered my assistance for testing, and seeing how many are tied to working from home, this could help speed the testing process up quite a bit. :+1: @Alex.liu

6 Likes

i have the same problem in beat saber, haven’t tried Alyx so far.
Do we have a fix yet?

2 Likes

Of the people here that are having this issue, how many have the USB directly connected to their PC vs Connected to a powered USB hub or other such power injectors?

I only ask as I was having this issue quite badly until I replaced the Amazon basic USB 3.0 extension (6ft) with a powered one (10ft+). The twitching controllers are basically gone along with some audio static I was getting when using the Pimax 3.5mm jack.

I expect these issues are related to noise on the USB data lines. I’m going to attach some ferrites to the cable to see if that improves things even more.

2 Likes

Would be interesting to test ferrites though I have no issues that scream emi or noise.

I have tested 4 configs to no avail

  1. through my passive usb and DP extension cables at 90 Hz (120hz doesn’t work with passive extension)
  2. through a dedicated USB 3.1 PCIe card, no extensions
  3. through a powered usb hub, 4A supply
  4. straight to mobo and GPU

there are varying effects of insufficient USB bandwidth, for me I get screen grey outs, occasional headset tracking issues and overall it just feels ‘unstable’ when on a bad port. The hub and dedicated card work perfectly sans the controller issue. Plugging in one controller via USB C completely fixes the issue.

2 Likes

Are you sure both your controllers are in view of your lighthouses while you loose tracking? It’s normal behaviour of lighhouse tracked controllers to turn off any controller input on one controller as soon as its out of view. In many games this will cause the other controller to go into single controller mode which changes many of its controller input layouts.

This is very easily reproducable if you hide one controller under your shirt checking if it causes the same errors you described.

I would like this behaviour to be fixed at some point. It’s very irritating and has confused me for a while too. They should really use all the sensors in the controller to guess its movement when tracking is lost for a second.

2 Likes

I’m positive it’s not a ‘tracking issue’ in a user error sense. For one I’ve never once lost tracking with my vive wands, and my V1 base stations are screwed into the wall. I have perfect tracking using the same setup on my Vive. When this first happened I assumed they just tracked worse, so I adjusted my BS to accommodate any possible blind spots as well.

Also, it works when plugged in perfectly USB-C to USB-C from controller to HMD. Tracking still happens wirelessly when you plug the controller in, it’s just sending the data through the cable now instead of wirelessly. Presumably it seems confirmed that this is some issue with the Bluetooth receiver or pitool/steamvr as Alex Liu was able to replicate the issue. I really hope they are able to resolve the issue with a software update - and for what it’s worth I’m somewhat confident that’s possible.

3 Likes

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.