Images shakes extremly and other oculus game issues

So finally got my valve knuckles and tried using this 5k+ after a month or so, i am seeing new issues not in all games but in one game that i play a lot echo vr an oculus game, the issue is everytime i move my head the parallel projection is working hard to stabilise picture but falls behind and i end up seeing the picture shaking and it takes about 3 to 4 seconds to stabilise the picture once i stop moving my head and this is an intense game and i have 2080ti sli setup, tried with sli on and off but no luck and picture still shakes extremly, any fix for the issue, played some steam games lioe gorn and thrill of the fight and they didnt have any issues except for the controller use issues, and i also tried dead and buried 2 Oculus game through pitool as was echo vr through pitool and it also had issue where i was constantly disconnected from the game, at this point it seems to be oculus games that are effected and it has been mentioned before that pimax is working on software fixes for that about 3 months ago but still its not fixed, can you please fix oculus game issues soon, thank you. @Heliosurge, @Sean.Huang, @PimaxUSA.


Doesn’t sound good. But with Sli won’t help a program if not made for it. @VoodooDE said sli didn’t have much good at the time he tried it out on 2080 ti.

  • Are you launching from Revive or Pitool?
  • Have you tried decreasing Pitool Render? To see if performance improves? How about IG settings?
  • Some games may require special per game fixes.

If you have log files & pics (if possible) may help them identify where fixes needed. @SweViver might be able to look into these games to help the team as well.


I only launch from pitool as revive seems to have issues, i have tried the lowest render and as high as 1, what are ig settings?, I tried taking a video of the issue through the hmd but there were some vertical lines interfering and couldnt capture well, and where does pitool save logs thank you @Heliosurge

1 Like

I will look into where pitool has logs. Might be in main pimax pitool directory or %AppData\Local\Pitool

Oculus log files & game logs may have useful info as well.

IG = In Game settings. Not sure but Oculus settings may have effect as well.

1 Like

Hi @lingaraju.g. Im sorry to hear about your issue. This problem sounds like its related to Oculus games and Parallel Projection rendering.

Have you tried running Lone Echo without Parallel Projection enabled? I dont remember if the game really needs it at all, but if it does (and you get a incorrect cross-eyed image), you could at least check if the shaky image is still there when Parallel Projection is disabled.

Also, I would recommend you to disable SLI when running VR, unless you play some of the few SLI-supported games (Serious Sam 3 VR etc).

I know the Pimax team is working to improve the Oculus-support, but Im not sure what the progress is lately. A few months ago, Lone Echo and most other Oculus games worked perfectly on Pimax, but something has been changed since recent Oculus Home (or PiTool) updates.

Anyhow, first let me know if it works better without PP enabled!


@SweViver i am sure you know lone echo is the single player game while echo vr is online multiplayer, i have to install to check it, but with echo vr without PP enabled image is not displayed correctly and PP has to be on, not sure if hidden area mask is causing this issue i have to try with that setting off, i tried few other oculus games and they seemed to work fine after a PC reboot but echo vr continues to have issues, btw do i have to launch oculus app while playing oculus games because i just open them in pitool and it asks me that it has to launch oculus server something and it does it in the background, thank you.

just a longshot but i found echo arena to be shaky if the anti-aliasing was 4x.


Not to hijack your thread, but playing The Climb the screen constantly flickers, almost like a strobe light, and it makes the game unplayable. Same issue using Revive + Pimax too.

The Climb used to work on version .91.