I need Teamviewer support

Sorry if i sound a little salty but ive been through 2 headset cables and numerous not connecting headset issues. Its been 12 months since i used my Pimax 5k+. Ive got a brand new PC and now nothing i try will get the headset to work. Steam VR is blocking add-on’s and wont connect to my headset. I goto manage Addons and unblock them and nothing. Im going in a circle. Im literally ready to throw the headset into the bin if i cant solve this. Ive googled SteamVR blocking addons and stiull havent solved this.

Have you gone into SteamVR/developer settings and delete all UBS devices, unplug the headset, restart your PC, and reconnect it?

Does Steam VR crash when starting a VR app, before it blocks your headset? And what version of PiTool are you using - the latest .271?

Don’t know if this is the same issue or not, but myself and others found .271 triggers this crash and block where 270 does not.

I uninstalled 271, installed 270, and Steam VR crash / block loop is gone.


However I never had any initial connection issues with either my 5k+ or 8KX so I don’t know if there’s another underlying cause, sorry…

Yeah. Its back to going through the endless loop of Steam blocking addons and headset not tracking.

Ive done everything but what you suggested. Reinstalled all apps even did a windows reinstall out of desperation. I cant find a link to any previous Pitool versions that are not broken.

This is the one that works, at least for me and a few others: https://community.openmr.ai/t/pitool-v1-0-1-270/35466

Note the other forum page I posted, BitDefender doesn’t like it and requires the Pimax/Runtime folder to be excepted first to correctly install, but other AV apps are fine.

I rolled back to this version the other day because I had been stuck in the loop every time I tried my X. Hadn’t been using VR for a while so initially had no idea which update to my system was the trigger.

Good luck I hope it helps.

1 Like

Run both Steam and PiTool as admin and see if it solves it, as it sounds like that is the issue.
This started to happen around the time when SteamVR changed on how it handled safemode earlier this year.

It may be better if you could raise a support ticket here:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.