How to solve "Disconnect" or "Not tracked" of headset, base station, controller randomly, image follow head although not use base station. (PiTool 91)

Note : before I do this, support remote by teamviewer to set something for base station before. So if you can’t fix by these step, contact @Doman.Chen, he can help you .

Try this first

If still can’t be solved, try this (the first method I can solve issue, but happened again after restart pc).
After I swap to vive and return to pimax again, I found that all device in PiTool is blue and Ready, but when I run steamvr, base station not work and controller are not track. I have to use the below solution again. So please read it.

I just discuss with @SweViver in other topic.

This is issue.


These is step.

  1. Power on both base station. If not do this, it will show “Place the helmet in the visible positon of the base station”

  2. Checking The PiServiceLauncher.exe in task manager and end task it first.

  3. End task PVRHome.exe , PiService.exe and pi_server.ext if no both of them, then reinstall Pitool .91 again.

  4. delete all file in “Users/username/AppData/Local/Pimax/runtime/config/lighthouse/”

  5. Restart the "PiServiceLancher in Services tab in task manager.

  6. The headset and base station are connected and be Ready.

  7. Turn on the controllers and they are Ready and not randomly disconnected

  8. Sometimes, you need to delete

  9. If you not use base station, controllers try to set the room setting in PiTool. If you use base station and headset not work, try to move closed to the base station.

  10. Always try to restart PiServiceLauncher again if it still not work.

  11. Try to update firmware if has any issue after update PiTool.

  12. Switch to use another display port or usb port.

  13. Try to start game in PiTool although the headset still disconnect and if the game is fine, you can set room in PiTool, in my case I use Lucky tale because oculus game don’t need steamvr.

  14. Sometimes the headset show red light and not turn on, try to check usb driver in device manager again.


Please export the logs then PM me.


If this happens to me, i simply restart the PC. Then it works. I think it is about the piservice not detecting the basestations. It happens if i turn on the basestations (on that power switch is also the headset power brick) after i turn on the PC.
If you look in your headset, it shows just gray and red power light.

So if the piservices does not detect your headset while booting because it is not powered yet, this happens. At least this is my experience.


Another possible solution that can work I found after experiencing loss of tracking of the hmd and controllers after a Windows 10 update is to disable windows usb power management. It is simple and effective if related to a usb issue. Go into steamvr settings under developer you will find a disable windows usb power management setting. Once selected it just requires a reboot of steamvr worked immediately in my situation. Maybe worth a try if you have a similar experience of loss of tracking or device disconnecting.



@mr.uu It work yesterday, I will test a lot of time.

@Fresco May will try because my pc always show that it can’t detect keyboard when start pc although it still can be used.

I remember that my friend ever found wmr problem about black display although it still be moving the game on monitor. They solve by tick out the “Allow the computer to turn off this device to save the power” in power management tab of the properties of the headset in device manager, other usb too and this issue relate to pc. Similar problem.

Today I start my pc, I turn on switch of headset and base station.
The hmd is not connect again.

Then I start steamvr in Pitool although the headset still not be connected. After that I try to disable power management.


And close the steamvr, the HMD is connect automatically.
Then I try to turn off headset and turn on, it fine.
Good job!!.

I test to restart and headset automatically connected, great.

@Doman.Chen @SweViver

In devie manager, you can set on USB Root Hub

1 Like

After I restart my pc, then I test to turn off the headset and turn on again.

I found that the headset is not connect (diagnose 10500, I try to power off or unplug all cable), it not work. So I restart my pc again and the headset is connected.

But when I try again, it still have same issue.

So I try to check the Device manager about usb, I found that there is one usb has alert icon. So I update the driver and then the headset connected again.

When I use samsung odssey, I found this issue for a lot of time about headset is not connect. I found that my Asus mainboard has some issue and I have to change to use other driver instead.
Samsung Odssey use USB xHCI for headset.

But I think I have to use another driver for pimax.
And now I can turn on and turn off without problem.
p.s. Pimax will show diagnoc 10500 for a sec and become 10600 and then connected.

Okay now the annoy issue is solved, will try to test more.

1 Like

I think of old version of headset which has issue about loss tracking and pimax said about adding more led which make headset not have enough power, but may that problem relate to the windows.

Although I not use base station and headset is connected normally, but I found that the headset always stop tracking. It should not be like that because the headset use gyroscope sensor, after it stop tracking by itself, then the image will follow your head for a little sec and move again.

This effect be found in vive headset, but different situation. When I use it for a long time and headset is overheat, it look some sensor working wrong and then the image always follow the headset, I have to solve by use some tape to close that sensor.

1 Like

After I swap to vive and return to pimax again, I found that all device in PiTool is blue and Ready, but when I run steamvr, base station not work and controller are not tracked. I have to use the old technique by delete file in lighthouse folder and restart PiServiceLancher again.

1 Like

I just recieved my 5K plus and I have the “Not Tracked” problem.
Tried everything. Still not working.
Will contact Doman.

Please, Bubbleball, rename the tittle of the post, it is not “Not Tracking”, it is “Not Tracked”. So your post will appear when searching for “Not Tracked”

1 Like

My Pimax 5K+ was shown as disconnected for 4 days. I tried everything includes flash the firmware, reinstall pitool, still no luck. Today I tried to update usb driver, as well as delete all residue of Pitool after uninstallation. Then I reinstall the Pitool, now finally my 5K+ is alive again!!! Thank you guys so much! I appreciate the help from here. Happy New Year to you all!

1 Like

BTW, this time, I also updated my win10 to most current version.
Before today, I tried using different USB port or DP port, but no working.

1 Like

The current PiTool version at the Pimax web is v1.0.1.91.
But just after installing that version the PiTool check version alerts you that a new versión is available (the v1.0.1.95) ¿¿:roll_eyes:??
Why not just put on the web always the latest?


My understanding is that this is intentional. Pimax only updates the web-linked version, once the latest has had more testing. It’s available in PiTools so that people who are having problems can try out “early” builds.

1 Like

Remove other device from usb or if you have a link box or usb hub with adapter, may try to use it.

Try to move file in lighthouse and restart PiService sometimes.

1 Like

Finally I solved the problem!!! :-)))))
It was a very very silly issue.

Yesterday arrived the DP to miniDP adapter, so I tested the Pimax5K+ in the laptop MSI GS63VR (just to check the issue in another computer). The problem was exactly the same “Not tracked”. I tried everything (uninstall/install, restart PIserviceLauncher, delete LH folder, etc, etc).

Then, I started to rotate the headset in all directions (pitch, roll, yaw) and suddenly it worked! I couldn´t believe it.

Then, I put the Pimax5K+ over the desktop PC and initially the problem was the same but I just rotate the headset about 360 in all directions a it worked!!

I restarted the headset more than 10 times to try to determine exactly what kind of rotation (pitch, roll, yaw) and how much degrees (90, 180, 360) it was needed to be on tracking again.
Then I realised that it doesn´t depend on the rotations I made, it was more related to the DISTANCE!!

I measure the distance (with a meter tool) and it was 120cm!, I thought it was more but it was just 1.2 meter distance. With 1.2 meter the initialisation tracking routine doesn´t work very well. I put the headset at 1.5 meters and it worked perfectly!!

When I used the VivePro it was working perfectly at 1 meter distance, so for the Pimax5K+ I placed the basestation (I only use one basestation) at the same place I was using with VivePro, assuming the distance was also ok. But as I have seen it is not enough!.

The curious thing is that once the “not tracked” disappear and the headset is ready, I can put it at 1 meter distance and it works perfectly during all game play. The problem with 1 meter is only for the initialization.

I will now start to tweak and set my favorite and only VR game (IL-2) for the Pimax5K+.

A big thank to the support team who help me via teamviewer in these previous days!


This was an issue that a previous user also had (they were using a seated setup) and unfortunately that knowledge didn’t trickle into this thread. :cry:

That is why I have been accumulating solutions to help spread the knowledge a bit more easily :smile:

My assumption is that you need to be further away because the HMD is physically larger.



I get the new headset, found problem again, although all device are connected, but controller always disconnect and disappeared while playing.

I swap to use the usb 3.0 port which ever used and issue is solved.


LOL, OMG just spend 30 minutes fighting with this, you’re absolutely right. The basestation can’t be on my desk, I have to walk back ~5ft then tracking activates. Thanks!

1 Like

Today I try to setup the second headset (replacement) which never be remoted to update by support.

First time, it can be connected normally, but after restart again, the headset never be connected. It show that I have to place helmet which can be seen by base station.

I try to use 1 base station and not success.

But I try to run the game such as “Lucky tale” and the headset become connected automatically while room set up not work if I close the game.