How to Play Half Life Alyx WITHOUT Parallel Projection on Pimax Headsets and StarVR One!

Includes clip of me playing HL:Alyx culling free:

Add this command under Half Life: Alyx -> Properties -> Set Launch Options

-console -vconsole +sc_no_cull 1 +vr_multiview_instancing 0 +vr_shadow_map_culling 0 +volume_fog_enable_stereo 0

Update: Line modified with improved version.


That is pretty cool. I wonder why Valve doesn’t have this setting visible and/or on by default. Nice find.


Culling usually improves performance. That’s why the command is not used by default. But I think Valve should have made us aware of this command for us wide FOV users. I notice no reduction in performance but that might be because of how well optimized the title is and the dynamic resolution.


Yeah can see that. Also by keeping it off and not having it a visible setting gives them an edge on their narrow FoV headset vs a Wide one.

Ie " Looks nice with Wide FoV, but will the culling better on Index"


Ooooooor, they could calculate the culling frustum correctly to begin with, so that you don’t need to disable it. :7

I guess the same option should work with SteamVR Home, by the way…

EDIT: Watched the video… The black smudge looks like the shadows spazzing out.
The shadows were already rendering incorrectly before, when not rendering parallel projections, along with various forms of decals (bullet holes, spatter) - not seeing any of that?
(…and still not noticing any difference in performance, if you disable adaptive quality?)


Agreed it would be a good experiment in VrHome.

Liked and subscribed. This is incredible


Excellent work! Nice! Perfect timing for the 8KX release… well, hopefully.


I put this here, I let you do the rest (thx to dmel642):
you can edit this file to have the same effect for steamvr home (still have shadows issue):
path: “your_steam_path\steamapps\common\SteamVR\tools\tools.vrmanifest”
bellow “app_key”: “openvr.tool.steamvr_environments” you have the key “arguments”, you can add the necessary command at the end.


There are some slight moments of jitter in certain spots where it goes down to 80fps but I haven’t played it enough in various areas to know for sure. Probably the larger the map level, the more affect it has.

As for black smudge. I’ve tried every “shadow” related command and haven’t figured it out yet. It looks like the shadow problem is coming from dynamic objects/props. I’ve been reading about dynamic object lighting here:,shadows%20from%20those%20light%20sources.

My goal is first to disable shadows on dynamic objects. Then enable it but find some kind of strength settings. I’m hoping reducing intensity will help. The third possibility is that since this issue only occurs on the right eye it must still be some kind of culling/rendering issue beyond the camera’s FOV.

I did notice spatter and water reflections were also a problem. Will try to fix that too. Haven’t noticed bullet holes.


@NextGenVR Your persistence and patience is admirable, thanks :slight_smile:


Thanks man.
I eventually gave up waiting for the comfort kit before trying Alyx, and started it yesterday, so I discovered that culling thing and was even tempted to narrow the field of view (I was using normal@120fps).

I hope that volumetric fog options will also help with some of those dark scenes, where you see absolutely nothing! The black aren’t really black in the headset, and that means we already miss a lot of details in dark scenes, but it seemed even worse than elsewhere this time, so I hope it can help eventually.

Will see the next time I try it … which will be when I receive the comfort kit this time. That short trip back with the 5K+ made me recall why I waited so long and that my previous feedbacks about the lack of comfort were not exagerated. The confort is utter trash, and even my friend who tried the Pimax for the 1st time, wanting to try Alyx, was very disappointed (and hurt is nose) … even if he praised the visual quality compared to his OG Vive.


the timing might be a year too early actually

I have been playing hl:A a certain amount of hours, with the following command lines since the beginning,
-console -vconsole +sc_no_cull 1 +vr_multiview_instancing 0 +vr_enable_volume_fog 0

I play it in Large mode, without PP thanks to the previous commande lines, 90hz and 72hz , without smart smoothing nor FFR. no issue, 2080ti
However, the only issue I have is with some light sources that appear on a different location depending on the eye.
When there is a light, its double appears like 1 meter /3 feet next to it on the other eye.
Did someone manage to get rid of this issue?


I haven’t noticed that lighting issue (but it might still be present). I also have PP off. The only issue I’ve noticed is occasional object clipping at the outer edges of the view (in Normal FOV). There was a later post suggesting a few more command line options. I think the main change fixes the fog and leaves it enabled. This is what I’ve been using:

-console -vconsole +sc_no_cull 1 +vr_shadow_map_culling 0 +vr_multiview_instancing 0 +volume_fog_enable_stereo 0


before reading your answer I tried a slightly different command line than the one I wrote on my previous comment
-console -vconsole +sc_no_cull 1 +volume_fog_enable_stereo 0 +vr_multiview_instancing 0 +vr_shadow_map_culling 0
Which is the same as you said.
Turns out I didn’t encounter the issue I stated in the first place.
So weither I’m lucky, or the thing that was missing (volume_fog_enable_stereo) was responsible of my issue.

Besides, I also tried -nowindow in order to avoid any spectator window on the monitor, the idea was to avoid any wasted resource, but for some reason this was adding some aliasing.
I removed the -nowindow command and aliasing went away. .

I took those lines from here :slight_smile:


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.