HL Alyx performance optimization

Game runs pretty strangely on my 5k+

distortion is worse than i remember it being in a while.

im using pitool and the latest beta firmware.

Overall i think the distortion is worse ever since they introduced 144hz

But dropping to Normal minimizes the issue.

My real problem im running on normal with 1 Render Quality and 1.0 in steam

and every now an then the framerate dips and I see what can only be described as a pixelation effect. I think this is a game engine thing because it looks like giant blocky pixels like you zoomed in on a photo.

this happened to me inside the first apartment where you are looking at the holo map on the table. before you get the gravity gloves.

it also happened to be when you get off the train.

I was running on ultra but switching to low makes no difference.

I should mention im running a core i7-4790 and rtx 2080Ti.

and im installed to an nvme ssd

Are you using the latest Nvidia driver that came out yesterday, v445.75?

1 Like

Do you have Fixed Foveated Rendering set to Close? If not, definitely change it to that.


Very strange, I’ve been running 120Hz, normal FOV on a 2070 super and I have not once noticed the auto resolution, but many others have.

I have noticed however issues with distortion slightly, and I also notice warbles in some scenes even though smart smoothing is disabled (train ride style sequences). Lastly, audio and lips do not seem to sync up well at all for some reason. Gameplay itself is flawless however.

Hopefully someone finds the ini setting to disable the adaptive resolution, because performance is awesome for me as is.

I believe the wobbles during the train scene were to represent movement of the train. I’m about 5 hours into it, and it is just too damn good. The sense of presence is beyond anything I’ve ever played. I don’t want to stop playing but I need to sleep :weary: :yawning_face: :laughing:


You might be right! It’s nothing major - my complaints are polish complaints basically. The game itself is just unbelievable on the 5k, easily the best thing I’ve played in VR. The dark ‘horror’ sections and when you first get out and fight the combine are what i experienced today before work, really unbelievable. Can’t wait to play some more.


Steam issued a patch about 90 minutes ago.


same pixelations here, I’ll try those new drivers tomorrow, have to charge controllers first XD

1 Like

does it make a huge difference? I will try it now

On playing the first chapter I was very surprised to see exactly this effect with my 5k+ and RTX 2080. Do you have a 2080 or 2080TI if not this reply is probably a red herring? For me in Pitool I turned of Fixed Foveated Rendering and did a full hardware restart. It was like a night and day difference. So much so I replayed from the beginning and the issue never returned. Good luck and hope you sort it :+1:

(I’m guessing FFR was trying to keep the maximum framerate by dramaticallty reducing the image quality. With it off I have a beautiful game and personally don’t notice any framedrop - milage may vary).

1 Like

I believe the the graphics engine in HLA will reduce the graphics if it sees you are dropping frames, try lowering you graphics setting and not upping them.

The gun battles with the Combine are impressive! The game is absolutely incredible and it provides a theme park level experience at home. I feel like I’m in a sci-fi movie when I play.

btw - anyone else experience the “electrical” moment? (You’ll know what I mean…)


Anyone tracking their CPU usage? It seems really high(70-85%) on a 7700K.

Thanks I will try that. It’s strange because my other min spec pc (gtx 1060 and i5-7500 )with a Rift S looks gorgeous. (Except for that FOV)

I’m still fiddling with finding settings that look right. I swear this 144hz beta drivers have way more distortion than previous.

I’ll have to play Asgards Wrath to confirm that though.

Hello guys,

I have a strange feeling while playing Alyx or Beat saber with my 5K+. Does Pitool zoom in the image ?

I feel like scale isn’t ok despite the height is correctly set up in room setup. Didn’t feel that with the vive.

I’m 2 meters tall and those god damn doors shouldn’t feel so Impressive :grimacing:.

Are you sure your IPD is set correctly?

I played Elite Dangerous for months at my self-measured IPD. I had no eyestrain, but my arms seemed too skinny and far away. The 3D effect wasn’t as “deep” as I would have liked.

Someone on the forum said that you can reduce your IPD setting to see a stronger depth effect. I tried reducing my IPD by about 2 mm. That fixed the in-game scaling (arms matched my perceived body) and did improve the feeling of depth in space. At first I had some eyestrain, but I soon adapted to it.


I have something frustrating, the game engine is downsampling very early. Using a 2080ti (with latest drivers), i7 6700K, with 32gb ram.

Config is Pitool is set to small FOV, 90hz, FFR on Conservative, PP on, GPU Catalyst 0
(I would hope, with that hardware, I’d at least be able to run at normal FOV). Game is set to High Fidelity.

I have reached the point in game where I exited the subway and am looking at the first power station for the crypt (or something), looking straight at the Northern Star hotel. There is a lot of geometry in this scene, but nothing that an 2080ti shouldnt be able to cope with.

And yet, the game is applying its downsampling very early. The entire hotel, buildings to the right, and power station are all a blurry mess. Looking at the floor or the small chairs/tables are clear and high resolution.

I can see in fpsVR that GPU usage isn’t above 60%, and CPU usage is hovering around 70%, occasionally getting an orange bar. Zero orange bars for the GPU. Neither are warm, around 65°C

Turning GPU Catalyst up doesn’t help either. What’s going on? Every other game seems to be fine.

EDIT: Well, turning off FFR fixed it. Wtf. Isn’t FFR supposed to help?

1 Like

i was going to say turn off ffr. i posted the same thing you did a few days ago.

I turn ffr on in most cases , but some games just dont work with it.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.