Headset stuck in DFU mode


I somehow have managed to get my headset stuck in DFU mode.
The led is flashing different colours, this is a sn102 and i am using the tool for the 102 serial numbers.
The latest tool put the headset into DFU mode however when i try to exit DFU mode, the DfuSeCommand doesn’t recognise that a DFU unit is connected and crashes (stops responding). I have tried to exit this mode manually with the console through “DfuSeCommand.exe 0 return” which results in the application needing to be ended as it stops responding.
I have then tried to fix this by installing a device driver for DFU using Zadig. Still the same problem.
Have also tried using the flasher made by @Sjef but this says “pimax not found”
I only received the headset this evening, have i already bricked it?
Also the right hand lens seems to have blurring around the periphery whereas the left hand lens seems to be a perfect picture.

My tool was written for the sn100, not the sn102.

If you go to windows devicemanager, how does the pimax report under the Universal Serial Bus controllers ? My sn100 says “STM device in DFU mode”. ANd if you then click that, go to details, what hardware id’s do you see if you click that in the pulldown property menu ?

Hi sjefdeklerk, thanks for replying!
In windows device manager it’s in the category “Universal Serial Bus Devices” and is listed as “DFU in FS Mode”.
“Manufacturer STMicroelectronics”

Originally when i plugged it in, it was listed as the same, but with no driver installed so i used Zadig to install a driver for it.

Hmm someone else had that exact same mode: http://community.openmr.ai/t/cant-upgrade-manually/2352/3

He got it to work as you see, I don’t know much about this BE headset, but @PIMAX-Support probably can help out.

Ahh yep, it’s strange that when i open the upgrade tool it knows that the unit is in DFU mode as it says “return from DFU mode” however when i click this and it runs DfuSeCommand.exe, this program stops responding after it prints “0 device(s) found, please plug your DFU device!” in command prompt.

edit It seems the flasher tool doesn’t really know that the headset is in DFU mode as it still says “return from DFU mode” when i launch the tool with the headset unplugged.
Are you sure you don’t want to write a custom flasher tool for the 102’s too? :stuck_out_tongue_winking_eye:

Well i’ve finally fixed it. It turns out the right driver wasn’t being installed (which would normally happen with windows update) but seeing as my update is turned off, it wasn’t automatically downloading and installing the right driver.
Next issue to resolve is why the right hand lens is excessively blurry around the edges!

1 Like