Headset does not work, PiTool shows "Disconnected: Diagnose(10935)"

Hello, backer #3597 here. Got my Pimax 5K Plus today and it does not seem to work. I installed PiTool, plugged the headset in and PiTool shows “Disconnected: Diagnose(10935)”, unknown reasons upon clicking. Headset is glowing in the front, LED color is red, screen is dark. Volume buttons on the headset are working for setting system volume and microphone on the headset also seems to work in Skype. Another thing is that my mouse is lagging a bit when I have PiService.exe process running.

I have tried reinstalling PiTool, turning the headset on and off, connecting to different USB and DP ports and checking all connections including on the headset, and restarting PiService and SteamVR, and the computer…

My PC specs:


Intel Core i5-6600K 3.50 GHz

CORSAIR Vengeance LPX 2x8GB DDR4 3000MHz 15-17-17-35 Black (cmk16gx4m2b3000c15)

Sapphire Tri-X Radeon R9 390X 8GB

Windows 10 64-bit

Thank you for help.



Congrats Title updated.

@anon74848233 please add to early backers group.

i have an old system similar to yours.

Ensure your Usb is plugged into the Red ports on your motherboard.

I connect first DP then Usb(red ports) the wall plug.

It might be an idea to obly have necessary usb devices plugged in ie keyboard mouse, headset & maybe game pad.

The r9 390 will give limited amount of titles to play reasonably well. If your not running latest amd driver try it. If you are then a roll back might be needed.

My main system now is an Ryzen 7 2700x with 1080ti.

1 Like

Is @Heliosurge’s solution works well?

I have no red ports on my motherboard (those are USB 3.1 right?). Only black and blue ones. Latest GPU driver is already installed. Will try your connection order later today.

1 Like

I believe so. Another thing to check is ensure your bios is up-to-date & usb/chipset drivers installed from mb site as W10 doesn’t alawys get it right.

If I read right i think your black ports on rear might be the 3.1 ports.

I updated motherboard BIOS, tried to connect wall plug last as Heliosurge suggested, tried different USB (black ones are 2.0, blue ones are 3.1) and Displayport ports… no luck so far, still getting the same 10935 error. I will try to reinstall GPU driver next but then I am out of ideas…

1 Like

@anon74848233 looks like we need a member of the tech team. Maybe to setup a teamview session.

There has been progress! I updated windows, and now the headset LED is green and display is lit up with a grey color. Unfortunately PiTool is still showing the same old Diagnose(10935) error…

1 Like

My apologies good to hear in progress. What is the message on the error?

PiTool message is “Disconnected: Diagnose(10935)” and upon clicking on it it says “Unknown reasons, you can do: Support:https://pimaxvr.com/support/

I will try on a different computer with nvidia GPU tomorrow.

1 Like

Sounds good. It might be an idea to submit a ticket just in case if needed.

1 Like

yes,you can contact our support team via service desk if you need help. @Sean.Huang @Alan.sun @Doman.Chen
Please follow these steps:

click the “Support” button on the banner for submit your issue
2.Give me your question number for teach support to contact with you via service desk
3.The issue will be solved soon

1 Like

Tried it on a different computer with GeForce 1050 Ti and it works! Great picture too. So AMD GPU was probably the issue. Thank you all.


Amd is still likely working on improving their driver for pimax. One user here identified Steam is setting the auto ss too high on vega.

I have also the problem with error 10935

My GPU is AMD Fury X

I received my headset a week agou, tried alot of different things.
Reinstalled AMD Drivers, Reinstalled PiTool.
Windows is on the newest official version.
I really hoped to start developing with this headset, but it doesn’t work.

Please help me out to fix the problem!

I tried everything, different firmwares, drivers, also installed a fresh windows copy, to be sure.
Nothing helped. I still receive the Error 10935.
Pimax support gave up and said I need another graphics card.
Another Person reported, he has also a Fury X, first had problems with the same Error number, then since one new firmware it worked out. But not for me :frowning:

My GPU: AMD Fury X from xfx

If someone has some suggestions, i would really appreciate every help!


I will try my r9 390 again. If it runs then I’d say support needs to revaluate as I know in November I could run it back then with better than expected results. The 2 Vega 64 setups however was a no go; Amd needed to wotk on the Vega drivers.

1 Like

Thank you for trying this out! I think it’s a driver, communication fault and not a fault of the operating system.
Oculus and Vive (connected via hdmi) are working flawlessly on the Fury X, only my pimax (connected via display port) doesn’t

1 Like

Definitely a driver issue. Fury was the first to have hbm memory & likely similar to the Vega’s architecture. I was surprised when my r9 390 was running pimax stably. Considering back in Nov the 2 systems had too manu problems.

I7 8700 16g vega 64 water cooled
Threadripper (2000 series) 32g Vega 64 totally watercooled.

It was a trick just to get the headset connected. Then unplayable in games & desktop freezing.

1 Like

Ou no such a shame, that especially newer graphic cards don’t support it :see_no_evil:
I am still wondering how does @Zeehond was able to use fury x to drive the pimax :smiley:

I will continue to test every new release of pitool, firmware with the newest amd drivers…
just waiting and hoping :smiley:

1 Like