Headset can't recognize my dedicated GPU

Recently I got the Pimax 4K headset, I downloaded and ran PiPlay_Setup_2.0.7.54_setup.exe on my laptop, but it can’t recognize my dedicated GPU (GTX 1050 ti) and so it uses only the integrated intel hd graphic card.
I’ve updated the drivers of both cards but nothing happened.
I can’t find any way to force the headset to use my nvidia card.

try disabling the on board gpu in the bios, and also disable it in the device manager.


1 Like

I’ve tried but it seems that the only way to broadcast to the headset it’s by using only the onboard gpu because with only nvidia card activated, when I press fn key to open up the monitor manager, it’s says that it’s impossible to broadcast, update drivers or change GPU.
I’ve even tried to execute the PiPlay_setup.exe with only nvidia (right click on the icon> execute with > nvidia) but it’s still recognizing only the intel gpu.

Which headset are you using? Judging by your system specs posted is this a laptop?

If so make & model please.

The headset is the Pimax 4K
Yes, I’m using a gaming laptop, the Asus ROG GL753VE-GC004T.
According to Intel Driver & Support Assistant, Asus has installed custom drivers for the intel integrated GPU.
According to Device Manager, the drivers of the intel video card are the last installed.

1 Like

Try this link to force Nvidia Gpu preference as you have Optimus Graphics.

You may need to uninstall Piplay & try Pitool. But try the above first.

I tried and nothing changed, then I reinstalled PiPlay with antivirus deactivated, administrative permits and through the Nvidia card but according to the compatibility check, PiPlay still recognizing only the intel card, I tried to run a 1080p VR video with PiPlay, it was very laggy and the Steam VR button doesn’t appear.
In conclusion, PiPlay actually can recognize the headset both via HDMI and USB, but if I deactivate the intel card through the device manager, PiPlay stops recognizing the headset via HDMI.
I think that the problem stills in the intel gpu custom card drivers which were installed by the PC manufactur, so I try to see if it is possible to update them from the asus website.

Ok, I I installed correctly the last drivers from the ASUS website for the intel card, reinstalled PiPlay which finally recognized a different version of intel drivers in the PC compatibility check and then… absolutely nothing changed… I’ve also tried Pitool but the problem persists…

You have Nvidia Optimus which switches back & forth between the Intel & Nvidia card. You need to try what’s in the Vid link in the Nvidia Control Panel to prioritize the Nvidia Card.

If it doesn’t work in Piplay, Uninstall Piplay & Install Pitool (try maybe 144 or 180).

Optimus Hybrid graphics though might not work.

@Doman.Chen might be able to give some details. But you may need to file a support Ticket.


@Hande83 I will create a ticket for you and let our technicians help you. Thank you

1 Like

Continuing the discussion from Headset can't recognize my dedicated GPU:

Yes, I prioritized the Nvidia card in every way through the Nvidia and Windows control panels, each Pimax program was running on nvidia GPU with its classic overlay (alt + z), I also directly downloaded SteamVR which recognized the headset, and tried to play a VR video with his video player but the performance still the same, poor like that of an Intel HD graphic.
I believe that in desktop computers to avoid that problem, it’s necessary just to connect the headset directly to the port of the dedicated GPU, but with a notebook like mine, I’m afraid that the single HDMI port is hard wired with the integrated video card.

However with SteamVR, I created a system report to better understand what is happening and I would like to share it with the support, @Matthew.Xu let me know.

1 Like

Yep it is possible your DP is direct to Intel Graphics. Some of these Nvidia Optimus Laptops the Nvidia card is only connected to Laptop screen.

Have you filed a support ticket?