Hand tracking not working : "device not ready" / "disconnected"

I finally received mine today but I have the same problem described here: https://community.openmr.ai/t/hand-tracker-not-working/34203

I followed this guide https://www.reddit.com/r/Pimax_Official/comments/ixflnr/hand_tracking_module_installation_and_setup_guide/

I uninstalled Pitool, every Pimax folders to make a clean install. I tried many usb ports, but all I get is “Leap Motion device not ready”. In leap motion control panel, device status is “disconnected”. Windows recognises a new device when I plug the leap motion.
I could plug an usb-c sdcard adapter to my hmd, it works: the usb-c port is not faulty.

hmd : 5k+ serial 204
Pitool :
headset firmware :
windows 10 pro, version 20h2

1 Like

Hi Korgen,

do you know this Tread Hand Tracking not working, install issues. Anyone with 5k+/xr have it working? some users have the same problem …


1 Like

Yes I saw that, and there’s no solution for the moment -_-
I created this thread here intentionnaly.

1 Like


Have you ever tried to get a ticket so that our technical team can give you some help? The ticket link I’ve send to you through PM.


I spent a whole month with the support team to be delivered (they needed weeks to understand they mixed my french adress with somebody else in Hungary…), so I’m not enthousiast to open a 3rd ticket again.

Btw, as indicated in these 2 other threads it seems to be a software issue.
I have exactly the same problem and as they said, the support team couldn’t do anything.

Hello @Ultraleap_Dan

Maybe you could take a look at this issue.
Thank you.

Hi Korgen,

Sorry to hear about the issue that you are having.

Please can you reinstall the WinUSB drivers from the location below:

Leap Motion\Core Software\Drivers\dpinst64.exe

Please can you also share a screenshot of your about tab to see if the hand tracking module is being recognised here?

Do you have a USB 3.0 male to a USB C female cable that you can use to connect the hand tracking module directly to your PC to see if this allows the device to be recognised?


Hi, I launched dpinst64.exe but it didn’t change anything.

Unfortunately I don’t have a female usb-c cable to test.

Here is the about tab :

I forgot to say that I have 2m extention cables (usb and displayport) for the Pimax. I can’t get rid of them for now but I may be able to make a short test if needed.
Thank you for helping :wink:

1 Like


Hello Dan,

I have exactly the same behavior as many users, see also here:

Hand Tracking not working, install issues. Anyone with 5k+/xr have it working?

With a USB 3.0 male to a USB C female cable directly on the PC it works:


1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.