Green Light / black screen

Hello everybody. I have a problem.After I dissasembled my Pimax, i recived a green light and no picture on my screen. Reconnected usb and HDMI cables and rebooted the PC didn"t help. I think it"s blocked

First check Diagnose in hlp tab if using pitool.

Try the below

You will need a copy of the firmware for p4k I think @Century has a copy and you will need to reflash the firmware.

If you power the p4k when it is dismantled there is a light sensor that will brick the headset but is not unbrickable.

If needed submit a ticket and Doman or another support tech can assist.


Thanks for answering. I wrote to Century, and asked for help with firmware

1 Like

Yes, there is still firmware (just remembered):


Thanks. Today in the evening i’ll try to fix it.


Still not working. I reflashed the firmware but it didn’t help. Do you have any idea what it can be?

@Century may have some ideas. With what pitool and such works best.

Your sure the mini hdmi and Usb inside headset is plugged in fully? If you do end up checking just be sure not to power unit while disassembled.

Might be an idea to post your system specs.

1 Like

Honestly, I use 4K so rarely that I don’t even remember how to flash it :sweat_smile:

But here is my version of PiTool and the firmware with which it worked for the last time about a month ago about:


What the power unit do you mean? Where is it locate?

Plugging in the headset when it is dismantled activates the brick.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.