Getting Steam to detect Pimax headset

I got the headset working really quickly for the Pimax store - headtracking, sound, picture looks great.

The problem I am having is that SteamVR just can’t seem to see the Pimax headset, no matter how I tweak it - it just shows “Not Ready” in red, and the HMD icon stays grey, instead of showing as green.

When I start up Piplay, it displays the message “SteamVR is not installed, wheather to enter SteamVR installation guide?”
SteamVR is definitely installed.

I have an AMD RX 480 card, two monitors - my main monitor is a freesync monitor. I’ve tried three different versions of Pimax 1.2.57, 1.2.52 and am currently on 1.2.75 - none of them are visible to Steam.

Pimax seems to be a great bit of kit, but I’m keen to see it in action. Thanks in advance for your help.

Have you tried launching steamvr from Piplay?

And if i may ask what are your system specs?

Hey! Guess what? After a whoooooole lot of mucking about, I tried uninstalling SteamVR completely, and then re-installing it, and it seems to have worked! It even has a pi symbol in the SteamVR icon.

The trick I needed to try was

  • shut down Pimax
  • completely uninstall SteamVR by right clicking on Steam/Library/Tools/SteamVR and selecting uninstall
  • close down Steam
  • restart Pimax
  • restart Steam
  • reinstall SteamVR
    … and the HMD icon shows up in green with a pi-icon on it. And it seems to work, just trying out the Steam tutorial now.

Awesome! Glad you got it working; congrats & enjoy. :wink::+1::sparkles: